summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2010-01-30 18:03:35 +0000
committerUlrich Müller <ulm@gentoo.org>2010-01-30 18:03:35 +0000
commitd285319dd0bbd33f991d8898ea1aea47b46af469 (patch)
tree0d7f8c1be3153e10385443e3b4b7ddd9a90b2bae /app-emacs/auctex
parentAdd temporary fix for broken h5part plugin (see bug #301538). Also changed hd... (diff)
downloadgentoo-2-d285319dd0bbd33f991d8898ea1aea47b46af469.tar.gz
gentoo-2-d285319dd0bbd33f991d8898ea1aea47b46af469.tar.bz2
gentoo-2-d285319dd0bbd33f991d8898ea1aea47b46af469.zip
Add prefix keywords, change EAPI to 3.
(Portage version: 2.2_rc62/cvs/Linux i686)
Diffstat (limited to 'app-emacs/auctex')
-rw-r--r--app-emacs/auctex/ChangeLog9
-rw-r--r--app-emacs/auctex/auctex-11.85-r1.ebuild61
2 files changed, 68 insertions, 2 deletions
diff --git a/app-emacs/auctex/ChangeLog b/app-emacs/auctex/ChangeLog
index b9137a643dda..e1b1542fdea3 100644
--- a/app-emacs/auctex/ChangeLog
+++ b/app-emacs/auctex/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emacs/auctex
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/auctex/ChangeLog,v 1.96 2009/12/26 17:24:25 pva Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/auctex/ChangeLog,v 1.97 2010/01/30 18:03:35 ulm Exp $
+
+*auctex-11.85-r1 (30 Jan 2010)
+
+ 30 Jan 2010; Ulrich Mueller <ulm@gentoo.org> +auctex-11.85-r1.ebuild:
+ Add prefix keywords, change EAPI to 3.
26 Dec 2009; Peter Volkov <pva@gentoo.org> auctex-11.85.ebuild:
virtual/ghostscript->app-text/ghostscript-gpl: ghostscript-gpl is the only
diff --git a/app-emacs/auctex/auctex-11.85-r1.ebuild b/app-emacs/auctex/auctex-11.85-r1.ebuild
new file mode 100644
index 000000000000..e8e559a65656
--- /dev/null
+++ b/app-emacs/auctex/auctex-11.85-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/auctex/auctex-11.85-r1.ebuild,v 1.1 2010/01/30 18:03:35 ulm Exp $
+
+EAPI=3
+
+inherit elisp eutils latex-package
+
+DESCRIPTION="Extended support for writing, formatting and using (La)TeX, Texinfo and BibTeX files"
+HOMEPAGE="http://www.gnu.org/software/auctex/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3 FDL-1.2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+IUSE="preview-latex"
+
+DEPEND="virtual/latex-base
+ preview-latex? ( !dev-tex/preview-latex
+ app-text/dvipng
+ app-text/ghostscript-gpl )"
+RDEPEND="${DEPEND}"
+
+TEXMF="/usr/share/texmf-site"
+
+src_compile() {
+ # Remove broken Info file (will be recreated by the build system)
+ rm doc/auctex.info
+
+ EMACS_NAME=emacs EMACS_FLAVOUR=emacs econf --disable-build-dir-test \
+ --with-auto-dir="${EPREFIX}/var/lib/auctex" \
+ --with-lispdir="${EPREFIX}${SITELISP}/${PN}" \
+ --with-packagelispdir="${EPREFIX}${SITELISP}/${PN}" \
+ --with-packagedatadir="${EPREFIX}${SITEETC}/${PN}" \
+ --with-texmf-dir="${EPREFIX}${TEXMF}" \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ $(use_enable preview-latex preview) || die "econf failed"
+ emake || die "emake failed"
+ cd doc; emake tex-ref.pdf || die "creation of tex-ref.pdf failed"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die "emake install failed"
+ elisp-site-file-install "${FILESDIR}/50${PN}-gentoo.el" || die
+ if use preview-latex; then
+ elisp-site-file-install "${FILESDIR}/60${PN}-gentoo.el" || die
+ fi
+ keepdir /var/lib/auctex
+ dodoc ChangeLog CHANGES README RELEASE TODO FAQ INSTALL*
+}
+
+pkg_postinst() {
+ # rebuild TeX-inputfiles-database
+ use preview-latex && latex-package_pkg_postinst
+ elisp-site-regen
+}
+
+pkg_postrm(){
+ use preview-latex && latex-package_pkg_postrm
+ elisp-site-regen
+}