summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2002-11-01 02:52:02 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2002-11-01 02:52:02 +0000
commit08bd106430ca5599005323021f7635b2f1a1f72b (patch)
treed56e46390f1a7838a1a5eecfd8573e5eb47d0c98 /app-emacs/chess
parentmasked app-emacs/monk (incomplete for now) (diff)
downloadgentoo-2-08bd106430ca5599005323021f7635b2f1a1f72b.tar.gz
gentoo-2-08bd106430ca5599005323021f7635b2f1a1f72b.tar.bz2
gentoo-2-08bd106430ca5599005323021f7635b2f1a1f72b.zip
looks like an app-emacs/ import to me
Diffstat (limited to 'app-emacs/chess')
-rw-r--r--app-emacs/chess/ChangeLog11
-rw-r--r--app-emacs/chess/chess-2.0_beta3.ebuild52
-rw-r--r--app-emacs/chess/files/50chess-gentoo.el13
-rw-r--r--app-emacs/chess/files/digest-chess-2.0_beta33
4 files changed, 79 insertions, 0 deletions
diff --git a/app-emacs/chess/ChangeLog b/app-emacs/chess/ChangeLog
new file mode 100644
index 000000000000..09b0224a5f1f
--- /dev/null
+++ b/app-emacs/chess/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-emacs/chess
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/chess/ChangeLog,v 1.1 2002/11/01 02:52:00 mkennedy Exp $
+
+*chess-2.0_beta3 (31 Oct 2002)
+
+ 31 Oct 2002; Matthew Kennedy <mkennedy@gentoo.org> ChangeLog,
+ chess-2.0_beta3.ebuild, files/50chess-gentoo.el,
+ files/digest-chess-2.0_beta3 :
+
+ Initial import.
diff --git a/app-emacs/chess/chess-2.0_beta3.ebuild b/app-emacs/chess/chess-2.0_beta3.ebuild
new file mode 100644
index 000000000000..14ff4a660fd5
--- /dev/null
+++ b/app-emacs/chess/chess-2.0_beta3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/chess/chess-2.0_beta3.ebuild,v 1.1 2002/11/01 02:52:00 mkennedy Exp $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="A chess client and library for Emacs"
+HOMEPAGE="http://emacs-chess.sourceforge.net/"
+SRC_URI="mirror://sourceforge/emacs-chess/${P/_beta/b}.tar.bz2
+ mirror://gentoo/emacs-chess-sounds-2.0.tar.bz2
+ mirror://gentoo/emacs-chess-pieces-2.0.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/emacs"
+RDEPEND="${DEPEND}
+ app-games/gnuchess"
+
+S="${WORKDIR}/${P/_beta/b}"
+
+SITEFILE=50chess-gentoo.el
+
+src_unpack() {
+ unpack ${A}
+ cd ${S} && rm -f *.elc
+}
+
+src_compile() {
+ make || die
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+
+ cp -r ${S}/../pieces ${S}/../sounds ${D}/${SITELISP}/${PN}
+
+ doinfo chess.info
+ dohtml *.html
+ dodoc COPYING ChangeLog EPD.txt PGN.txt PLAN README TODO
+}
+
+pkg_postinst() {
+ elisp-site-regen
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}
diff --git a/app-emacs/chess/files/50chess-gentoo.el b/app-emacs/chess/files/50chess-gentoo.el
new file mode 100644
index 000000000000..461d241cc1df
--- /dev/null
+++ b/app-emacs/chess/files/50chess-gentoo.el
@@ -0,0 +1,13 @@
+
+;;; chess site-lisp configuration
+
+(setq load-path (cons "@SITELISP@" load-path))
+(require 'chess)
+
+;; Change the engine preference order -- gnuchess is a dependency (we
+;; depend on app-games/gnuchess explicitly). We make crafty and
+;; phalanx optional. The user can override this anytime using M-x
+;; customize-group RET chess RET
+
+(custom-set-variables
+ '(chess-default-engine (quote (chess-gnuchess chess-crafty chess-phalanx))))
diff --git a/app-emacs/chess/files/digest-chess-2.0_beta3 b/app-emacs/chess/files/digest-chess-2.0_beta3
new file mode 100644
index 000000000000..93dbfe8f6c71
--- /dev/null
+++ b/app-emacs/chess/files/digest-chess-2.0_beta3
@@ -0,0 +1,3 @@
+MD5 0adb9ecabafb21819264dac1a12d930b chess-2.0b3.tar.bz2 196850
+MD5 86cd8cac846b0874e030692a8306d029 emacs-chess-sounds-2.0.tar.bz2 3390098
+MD5 23b4fb5038232fc01c238a213cee5e63 emacs-chess-pieces-2.0.tar.bz2 297687