summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2014-02-02 11:28:25 +0000
committerUlrich Müller <ulm@gentoo.org>2014-02-02 11:28:25 +0000
commite29ef1313783eb4b5652a37756c487f81ea9b670 (patch)
tree9f2c270ec590b377096b2d660a4b73ffc267cbcf /app-emacs/emacs-daemon
parentppc/ppc64 stable, bug #492430 (diff)
downloadgentoo-2-e29ef1313783eb4b5652a37756c487f81ea9b670.tar.gz
gentoo-2-e29ef1313783eb4b5652a37756c487f81ea9b670.tar.bz2
gentoo-2-e29ef1313783eb4b5652a37756c487f81ea9b670.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 9433907D693FB5B8!)
Diffstat (limited to 'app-emacs/emacs-daemon')
-rw-r--r--app-emacs/emacs-daemon/ChangeLog9
-rw-r--r--app-emacs/emacs-daemon/emacs-daemon-0.21.ebuild54
2 files changed, 61 insertions, 2 deletions
diff --git a/app-emacs/emacs-daemon/ChangeLog b/app-emacs/emacs-daemon/ChangeLog
index 1d4760b6f803..fade60366f7c 100644
--- a/app-emacs/emacs-daemon/ChangeLog
+++ b/app-emacs/emacs-daemon/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emacs/emacs-daemon
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/emacs-daemon/ChangeLog,v 1.72 2013/12/29 12:53:24 ulm Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/emacs-daemon/ChangeLog,v 1.73 2014/02/02 11:28:25 ulm Exp $
+
+*emacs-daemon-0.21 (02 Feb 2014)
+
+ 02 Feb 2014; Ulrich Müller <ulm@gentoo.org> +emacs-daemon-0.21.ebuild:
+ Version bump.
29 Dec 2013; Ulrich Müller <ulm@gentoo.org> emacs-daemon-0.20.ebuild:
Drop to unstable keyword on s390 and sh.
diff --git a/app-emacs/emacs-daemon/emacs-daemon-0.21.ebuild b/app-emacs/emacs-daemon/emacs-daemon-0.21.ebuild
new file mode 100644
index 000000000000..76bc3aaf3a86
--- /dev/null
+++ b/app-emacs/emacs-daemon/emacs-daemon-0.21.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/emacs-daemon/emacs-daemon-0.21.ebuild,v 1.1 2014/02/02 11:28:25 ulm Exp $
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="Gentoo support for Emacs running as a server in the background"
+HOMEPAGE="http://wiki.gentoo.org/wiki/Project:Emacs"
+SRC_URI="http://dev.gentoo.org/~ulm/emacs/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+
+DEPEND=">=virtual/emacs-23"
+RDEPEND="${DEPEND}"
+
+SITEFILE="10${PN}-gentoo.el"
+
+pkg_setup() {
+ local has_daemon has_gtk line
+ has_daemon=$(${EMACS} ${EMACSFLAGS} --eval "(princ (fboundp 'daemonp))")
+ has_gtk=$(${EMACS} ${EMACSFLAGS} --eval "(princ (featurep 'gtk))")
+
+ if [[ ${has_daemon} != t ]]; then
+ while read line; do ewarn "${line}"; done <<-EOF
+ Your current Emacs version does not support running as a daemon which
+ is required for ${CATEGORY}/${PN}.
+ Use "eselect emacs" to select an Emacs version >= 23.
+ EOF
+ elif [[ ${has_gtk} == t ]]; then
+ while read line; do ewarn "${line}"; done <<-EOF
+ Your current Emacs is compiled with GTK+. There is a long-standing bug
+ in GTK+ that prevents Emacs from recovering from X disconnects:
+ <http://bugzilla.gnome.org/show_bug.cgi?id=85715>
+ If you run Emacs as a daemon, then it is strongly recommended that you
+ compile it with the Lucid or the Motif toolkit instead, i.e. with
+ USE="athena Xaw3d -gtk -motif" or USE="motif -gtk -athena -Xaw3d".
+ EOF
+ fi
+}
+
+src_compile() { :; }
+
+src_install() {
+ newinitd emacs.rc emacs
+ newconfd emacs.conf emacs
+ exeinto /usr/libexec/emacs
+ doexe emacs-wrapper.sh emacs-stop.sh
+ elisp-site-file-install "${SITEFILE}"
+ dodoc README ChangeLog
+}