summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2005-02-11 14:39:44 +0000
committerMamoru Komachi <usata@gentoo.org>2005-02-11 14:39:44 +0000
commit35db1cb68baae0a6401eea8e0b1b5bb8540cf7ad (patch)
treedaab6ba034ded40b03a8d94c7e7b37d60a237b34 /app-emacs/emacs-w3m/emacs-w3m-1.4.3-r1.ebuild
parentstable on amd64. see #80601 (diff)
downloadgentoo-2-35db1cb68baae0a6401eea8e0b1b5bb8540cf7ad.tar.gz
gentoo-2-35db1cb68baae0a6401eea8e0b1b5bb8540cf7ad.tar.bz2
gentoo-2-35db1cb68baae0a6401eea8e0b1b5bb8540cf7ad.zip
Added a patch for emacs-cvs. This closes bug #81406.
(Portage version: 2.0.51-r15)
Diffstat (limited to 'app-emacs/emacs-w3m/emacs-w3m-1.4.3-r1.ebuild')
-rw-r--r--app-emacs/emacs-w3m/emacs-w3m-1.4.3-r1.ebuild73
1 files changed, 73 insertions, 0 deletions
diff --git a/app-emacs/emacs-w3m/emacs-w3m-1.4.3-r1.ebuild b/app-emacs/emacs-w3m/emacs-w3m-1.4.3-r1.ebuild
new file mode 100644
index 000000000000..9506047cfbae
--- /dev/null
+++ b/app-emacs/emacs-w3m/emacs-w3m-1.4.3-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/emacs-w3m/emacs-w3m-1.4.3-r1.ebuild,v 1.1 2005/02/11 14:39:44 usata Exp $
+
+inherit elisp eutils
+
+IUSE=""
+MY_P="${P/_/}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="emacs-w3m is an interface program of w3m on Emacs."
+HOMEPAGE="http://emacs-w3m.namazu.org"
+SRC_URI="http://emacs-w3m.namazu.org/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~alpha ~sparc ~ppc"
+
+DEPEND="virtual/w3m"
+
+pkg_setup() {
+ # use async doesn't ensure you built w3m with async flag,
+ # but it's safe to abort if you have it.
+ ewarn
+ ewarn "emacs-w3m hangs if you build w3m with async support."
+ ewarn "Please turn off async USE flag if you set it."
+ ewarn
+ if use async ; then
+ die "async USE flag detected. aborting."
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-e22.diff
+}
+
+src_compile() {
+ autoconf || die
+ ./configure --prefix=/usr \
+ --with-lispdir=${SITELISP}/${PN} \
+ --with-icondir=/usr/share/${PN}/icon
+
+ make || die
+}
+
+src_install () {
+ make lispdir=${D}/${SITELISP}/${PN} \
+ infodir=${D}/usr/share/info \
+ ICONDIR=${D}/usr/share/${PN}/icon \
+ install || die
+
+ make lispdir=${D}/${SITELISP}/${PN} \
+ ICONDIR=${D}/usr/share/${PN}/icon \
+ install-icons || die
+
+ elisp-site-file-install ${FILESDIR}/70emacs-w3m-gentoo.el
+
+ dodoc ChangeLog* README*
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ einfo "Please see /usr/share/doc/${P}/README.gz."
+ einfo
+ einfo "If you want to use shimbun library, please emerge app-emacs/apel and app-emacs/flim."
+ einfo
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}