summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2006-08-08 07:14:06 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2006-08-08 07:14:06 +0000
commitd4b9aaadc233c063a5539e72ced1c0e6b558e3de (patch)
treea778979d3d2531ae95d0eff2930dd124287d3646 /app-emacs/gnus
parentredigest, bug 142920 (diff)
downloadgentoo-2-d4b9aaadc233c063a5539e72ced1c0e6b558e3de.tar.gz
gentoo-2-d4b9aaadc233c063a5539e72ced1c0e6b558e3de.tar.bz2
gentoo-2-d4b9aaadc233c063a5539e72ced1c0e6b558e3de.zip
New upstream version; Resolves Bug #138010.
(Portage version: 2.1.1_pre4-r3)
Diffstat (limited to 'app-emacs/gnus')
-rw-r--r--app-emacs/gnus/ChangeLog9
-rw-r--r--app-emacs/gnus/files/digest-gnus-5.10.83
-rw-r--r--app-emacs/gnus/gnus-5.10.8.ebuild47
3 files changed, 57 insertions, 2 deletions
diff --git a/app-emacs/gnus/ChangeLog b/app-emacs/gnus/ChangeLog
index af199f898f5e..4f5176c093a5 100644
--- a/app-emacs/gnus/ChangeLog
+++ b/app-emacs/gnus/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emacs/gnus
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/gnus/ChangeLog,v 1.15 2005/06/05 11:37:46 hansmi Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/gnus/ChangeLog,v 1.16 2006/08/08 07:14:06 mkennedy Exp $
+
+*gnus-5.10.8 (08 Aug 2006)
+
+ 08 Aug 2006; Matthew Kennedy <mkennedy@gentoo.org> +gnus-5.10.8.ebuild:
+ New upstream version; Resolves Bug #138010.
05 Jun 2005; Michael Hanselmann <hansmi@gentoo.org> gnus-5.10.6.ebuild:
Stable on ppc.
diff --git a/app-emacs/gnus/files/digest-gnus-5.10.8 b/app-emacs/gnus/files/digest-gnus-5.10.8
new file mode 100644
index 000000000000..cd87954879c7
--- /dev/null
+++ b/app-emacs/gnus/files/digest-gnus-5.10.8
@@ -0,0 +1,3 @@
+MD5 385e1db2a0cb0a89db30870f0a37453b gnus-5.10.8.tar.gz 2496529
+RMD160 4a2fdea20961d7a714670b59f4d34864ebcaa930 gnus-5.10.8.tar.gz 2496529
+SHA256 4855d339470c252055b9d848ded8a8cad151c178d10d2bd8328960c32c446a90 gnus-5.10.8.tar.gz 2496529
diff --git a/app-emacs/gnus/gnus-5.10.8.ebuild b/app-emacs/gnus/gnus-5.10.8.ebuild
new file mode 100644
index 000000000000..b7f6141d94e1
--- /dev/null
+++ b/app-emacs/gnus/gnus-5.10.8.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/gnus/gnus-5.10.8.ebuild,v 1.1 2006/08/08 07:14:06 mkennedy Exp $
+
+inherit elisp
+
+IUSE="emacs-w3"
+
+DESCRIPTION="The Gnus newsreader and mail-reader"
+HOMEPAGE="http://www.gnus.org/"
+SRC_URI="http://quimby.gnus.org/gnus/dist/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+DEPEND="virtual/emacs
+ emacs-w3? ( app-emacs/w3 )"
+
+src_compile() {
+ local myconf
+ if use emacs-w3 ; then
+ myconf="${myconf} --with-w3=/usr/share/emacs/site-lisp/w3"
+ myconf="${myconf} --with-url=/usr/share/emacs/site-lisp/w3"
+ else
+ myconf="${myconf} --without-w3 --without-url"
+ fi
+ econf \
+ --with-emacs \
+ --with-lispdir=/usr/share/emacs/site-lisp/gnus \
+ --with-etcdir=/usr/share/emacs/etc \
+ ${myconf} || die "econf failed"
+ emake || die
+}
+
+src_install() {
+ einstall \
+ lispdir=${D}/usr/share/emacs/site-lisp/gnus \
+ etcdir=${D}/usr/share/emacs/etc \
+ || die
+
+ elisp-site-file-install ${FILESDIR}/70${PN}-gentoo.el
+
+ dodoc ChangeLog GNUS-NEWS README todo
+
+ # fix info documentation
+ find ${D}/usr/share/info -type f -exec mv {} {}.info \;
+}