summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2002-11-01 02:52:02 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2002-11-01 02:52:02 +0000
commit08bd106430ca5599005323021f7635b2f1a1f72b (patch)
treed56e46390f1a7838a1a5eecfd8573e5eb47d0c98 /app-emacs/htmlize
parentmasked app-emacs/monk (incomplete for now) (diff)
downloadgentoo-2-08bd106430ca5599005323021f7635b2f1a1f72b.tar.gz
gentoo-2-08bd106430ca5599005323021f7635b2f1a1f72b.tar.bz2
gentoo-2-08bd106430ca5599005323021f7635b2f1a1f72b.zip
looks like an app-emacs/ import to me
Diffstat (limited to 'app-emacs/htmlize')
-rw-r--r--app-emacs/htmlize/ChangeLog11
-rw-r--r--app-emacs/htmlize/files/50htmlize-gentoo.el7
-rw-r--r--app-emacs/htmlize/files/digest-htmlize-0.671
-rw-r--r--app-emacs/htmlize/htmlize-0.67.ebuild38
4 files changed, 57 insertions, 0 deletions
diff --git a/app-emacs/htmlize/ChangeLog b/app-emacs/htmlize/ChangeLog
new file mode 100644
index 000000000000..ed6346184851
--- /dev/null
+++ b/app-emacs/htmlize/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-emacs/htmlize
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/htmlize/ChangeLog,v 1.1 2002/11/01 02:52:01 mkennedy Exp $
+
+*htmlize-0.67 (31 Oct 2002)
+
+ 31 Oct 2002; Matthew Kennedy <mkennedy@gentoo.org> ChangeLog,
+ htmlize-0.67.ebuild, files/50htmlize-gentoo.el,
+ files/digest-htmlize-0.67 :
+
+ Initial import.
diff --git a/app-emacs/htmlize/files/50htmlize-gentoo.el b/app-emacs/htmlize/files/50htmlize-gentoo.el
new file mode 100644
index 000000000000..330c5c134259
--- /dev/null
+++ b/app-emacs/htmlize/files/50htmlize-gentoo.el
@@ -0,0 +1,7 @@
+
+;;; htmlize site-lisp configuration
+
+(setq load-path (cons "@SITELISP@" load-path))
+(autoload 'htmlize-file "htmlize"
+htmlize-many-files
+htmlize-many-files-dired \ No newline at end of file
diff --git a/app-emacs/htmlize/files/digest-htmlize-0.67 b/app-emacs/htmlize/files/digest-htmlize-0.67
new file mode 100644
index 000000000000..15f41a5df870
--- /dev/null
+++ b/app-emacs/htmlize/files/digest-htmlize-0.67
@@ -0,0 +1 @@
+MD5 ffe23f208746b5591df6d9c05e225c24 htmlize-0.67.tar.bz2 11898
diff --git a/app-emacs/htmlize/htmlize-0.67.ebuild b/app-emacs/htmlize/htmlize-0.67.ebuild
new file mode 100644
index 000000000000..9bf5f34cc19b
--- /dev/null
+++ b/app-emacs/htmlize/htmlize-0.67.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/htmlize/htmlize-0.67.ebuild,v 1.1 2002/11/01 02:52:01 mkennedy Exp $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="HTML-ize font-lock buffers in Emacs"
+HOMEPAGE="http://www.emacswiki.org/cgi-bin/wiki.pl?SaveAsHtml"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/emacs"
+
+S="${WORKDIR}/${P}"
+
+SITEFILE=50htmlize-gentoo.el
+
+src_compile() {
+ emacs --batch -f batch-byte-compile --no-site-file --no-init-file *.el
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ einfo "Please see ${SITELISP}/${PN}/htmlize.el for the complete documentation."
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}