summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2003-11-03 10:04:07 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2003-11-03 10:04:07 +0000
commite0fb0eea2093dc872e5c2d80f8665a49ae8c1d0f (patch)
tree0fb5dd1cc6d4028e3ea44473e7715ad7cc60d737 /app-emacs/http-emacs/http-emacs-1.1.ebuild
parent*** empty log message *** (diff)
downloadgentoo-2-e0fb0eea2093dc872e5c2d80f8665a49ae8c1d0f.tar.gz
gentoo-2-e0fb0eea2093dc872e5c2d80f8665a49ae8c1d0f.tar.bz2
gentoo-2-e0fb0eea2093dc872e5c2d80f8665a49ae8c1d0f.zip
*** empty log message ***
Diffstat (limited to 'app-emacs/http-emacs/http-emacs-1.1.ebuild')
-rw-r--r--app-emacs/http-emacs/http-emacs-1.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-emacs/http-emacs/http-emacs-1.1.ebuild b/app-emacs/http-emacs/http-emacs-1.1.ebuild
new file mode 100644
index 000000000000..e12d8240ad02
--- /dev/null
+++ b/app-emacs/http-emacs/http-emacs-1.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/http-emacs/http-emacs-1.1.ebuild,v 1.1 2003/11/03 10:04:01 mkennedy Exp $
+
+inherit elisp
+
+DESCRIPTION="http-emacs includes http-post and http-get which allows you to fetch, render and post html pages via emacs. It also includes simple-wiki-* modules, which allow you to edit remote (and local) wikis via emacs, and also includes a major-mode for the same."
+HOMEPAGE="http://emacswiki.org/cgi-bin/wiki.pl?SimpleWikiEditMode"
+SRC_URI="http://savannah.nongnu.org/download/http-emacs/http-emacs.pkg/${PV}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="virtual/emacs"
+S=${WORKDIR}/${PN}
+
+SITEFILE=50http-emacs-gentoo.el
+
+src_compile() {
+ elisp-comp http-*.el || die
+}
+
+src_install() {
+ elisp-install ${PN} http-*.el*
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+ dodoc CONTRIBUTORS
+}