summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-11-14 10:04:02 +0000
committerMamoru Komachi <usata@gentoo.org>2004-11-14 10:04:02 +0000
commit83a861f0e6e517bac1f797b18362e574d69e84c4 (patch)
treeecf9631e825a0e4c5ae7daaf7a0c093e42f5a053 /app-emacs/liece
parentStable on ppc. (Manifest recommit) (diff)
downloadgentoo-2-83a861f0e6e517bac1f797b18362e574d69e84c4.tar.gz
gentoo-2-83a861f0e6e517bac1f797b18362e574d69e84c4.tar.bz2
gentoo-2-83a861f0e6e517bac1f797b18362e574d69e84c4.zip
Upsteam doesn't support liece anymore. Please use riece instead.
Diffstat (limited to 'app-emacs/liece')
-rw-r--r--app-emacs/liece/ChangeLog7
-rw-r--r--app-emacs/liece/files/delegate.el95
-rw-r--r--app-emacs/liece/files/digest-liece-1.4.7-r11
-rw-r--r--app-emacs/liece/files/digest-liece-2.0.0_alpha200305261
-rw-r--r--app-emacs/liece/files/liece-1.4.7-gentoo.patch25
-rw-r--r--app-emacs/liece/liece-1.4.7-r1.ebuild48
-rw-r--r--app-emacs/liece/liece-2.0.0_alpha20030526.ebuild43
7 files changed, 6 insertions, 214 deletions
diff --git a/app-emacs/liece/ChangeLog b/app-emacs/liece/ChangeLog
index f4d25cd0efb4..e5827f6aa305 100644
--- a/app-emacs/liece/ChangeLog
+++ b/app-emacs/liece/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emacs/liece
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/liece/ChangeLog,v 1.10 2004/06/24 22:16:45 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/liece/ChangeLog,v 1.11 2004/11/14 10:04:02 usata Exp $
+
+ 14 Nov 2004; Mamoru KOMACHI <usata@gentoo.org> -files/delegate.el,
+ -files/liece-1.4.7-gentoo.patch, -liece-1.4.7-r1.ebuild,
+ -liece-2.0.0_alpha20030526.ebuild:
+ Upsteam doesn't support liece anymore. Please use riece instead.
18 Jun 2004; Sven Wegener <swegener@gentoo.org> liece-1.4.10-r1.ebuild,
liece-1.4.7-r1.ebuild:
diff --git a/app-emacs/liece/files/delegate.el b/app-emacs/liece/files/delegate.el
deleted file mode 100644
index 6bcdea1dfc10..000000000000
--- a/app-emacs/liece/files/delegate.el
+++ /dev/null
@@ -1,95 +0,0 @@
-;;; delegate.el --- allow delegation for lisp variables
-
-;; Copyright (C) 2002 Daiki Ueno
-
-;; Author: Daiki Ueno <ueno@unixuser.org>
-;; Keywords: internal
-
-;; This file is not part of any package.
-
-;; This program is free software; you can redistribute it and/or
-;; modify it under the terms of the GNU General Public License as
-;; published by the Free Software Foundation; either version 2, or (at
-;; your option) any later version.
-
-;; This program is distributed in the hope that it will be useful, but
-;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-;; General Public License for more details.
-
-;; You should have received a copy of the GNU General Public License
-;; along with this program; see the file COPYING. If not, write to the
-;; Free Software Foundation, Inc., 59 Temple Place - Suite 330,
-;; Boston, MA 02111-1307, USA.
-
-;;; Commentary:
-
-;; Here is a simple example how this package can be used.
-;;
-;; (define-delegated-variable-alias 'browse-url-browser-function
-;; 'liece-url-browser-function
-;; "browse-url")
-;;
-;; With this, the variable `liece-url-browser-function' is declared to
-;; be "delegated" to another variable. Unlike using `defvaralias',
-;; delegated variable itself is responsible for its value. Moreover we
-;; can hint the input source from which the variable is loaded.
-;;
-;; The delegated variable can be assigned to the default value of
-;; `defcustom' form below.
-;;
-;; (defcustom liece-url-browser-function
-;; (delegated-variable-get-safe 'liece-url-browser-function)
-;; "Default URL Browser."
-;; :group 'liece-url)
-
-;;; Code:
-
-(defvar delegated-variables nil
- "Alist mapping delegated variable names to symbols and filenames.")
-
-;;;###autoload
-(put 'define-delegated-variable-alias 'lisp-indent-function 2)
-
-;;;###autoload
-(defun define-delegated-variable-alias (variable alias &optional filename)
- "Define a variable delegated to another variable."
- (let ((entry (assq alias delegated-variables)))
- (and (null filename) (boundp variable)
- (setq filename (symbol-file variable)))
- (if entry
- (setcdr entry (list variable filename))
- (setq delegated-variables
- (cons (list alias variable filename)
- delegated-variables)))))
-
-;;;###autoload
-(defun delegated-variable-get (variable)
- "Return variable's value.
-Error if that is not delegated to another variable."
- (let ((entry (assq variable delegated-variables))
- filename)
- (if entry
- (if (boundp variable)
- (symbol-value variable)
- (setq variable (nth 1 entry) filename (nth 2 entry))
- (and (not (boundp variable)) filename
- (load filename 'noerror))
- (if (boundp variable)
- (symbol-value variable)
- (delegated-variable-get variable))) ;follow an indirection
- (signal 'wrong-type-argument
- (list "Not a delegated variable" variable)))))
-
-;;;###autoload
-(defun delegated-variable-get-safe (variable)
- "Return variable's value.
-If that is not delegated, don't throw an error. This function is
-typically used to set the default value within `defcustom' form."
- (condition-case nil
- (delegated-variable-get variable)
- (wrong-type-argument)))
-
-(provide 'delegate)
-
-;;; delegate.el ends here
diff --git a/app-emacs/liece/files/digest-liece-1.4.7-r1 b/app-emacs/liece/files/digest-liece-1.4.7-r1
deleted file mode 100644
index 75f400d93c38..000000000000
--- a/app-emacs/liece/files/digest-liece-1.4.7-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 ed4f6fa2171031883ff6202fda7fbbb4 liece-1.4.7.tar.gz 216362
diff --git a/app-emacs/liece/files/digest-liece-2.0.0_alpha20030526 b/app-emacs/liece/files/digest-liece-2.0.0_alpha20030526
deleted file mode 100644
index e4d927ebb631..000000000000
--- a/app-emacs/liece/files/digest-liece-2.0.0_alpha20030526
+++ /dev/null
@@ -1 +0,0 @@
-MD5 0e3f2d4d1b780f4c266728f81d371b26 liece-2.0.0_alpha20030526.tar.gz 292714
diff --git a/app-emacs/liece/files/liece-1.4.7-gentoo.patch b/app-emacs/liece/files/liece-1.4.7-gentoo.patch
deleted file mode 100644
index 6672f9cf5da2..000000000000
--- a/app-emacs/liece/files/liece-1.4.7-gentoo.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-diff -urN liece-1.4.7.ORIG/lisp/gettext.el liece-1.4.7/lisp/gettext.el
---- liece-1.4.7.ORIG/lisp/gettext.el 2002-03-21 11:24:07.000000000 +0900
-+++ liece-1.4.7/lisp/gettext.el 2003-08-18 22:41:45.000000000 +0900
-@@ -244,7 +244,7 @@
- Here's how the path to message files is constructed under SunOS 5.0:
- {pathname}/{LANG}/LC_MESSAGES/{domain}.mo
- \[XEmacs I18N level 3 emulating function]"
-- (let* ((lang (or (getenv "LC_ALL") (getenv "LC_MESSAGES") (getenv "LANG")))
-+ (let* ((lang (or (getenv "LC_ALL") (getenv "LC_MESSAGES") (getenv "LANG") "C"))
- (language (progn
- (string-match "\\([^_.]+\\)\\(_[^.]+\\)?\\(\\.[^@]+\\)?"
- lang)
-diff -urN liece-1.4.7.ORIG/lisp/liece.el liece-1.4.7/lisp/liece.el
---- liece-1.4.7.ORIG/lisp/liece.el 2001-10-02 14:01:38.000000000 +0900
-+++ liece-1.4.7/lisp/liece.el 2003-08-18 22:42:49.000000000 +0900
-@@ -506,8 +506,7 @@
- (file-exists-p liece-directory)
- (yes-or-no-p "Upgrade the location of the data files? ")
- (let ((file
-- (expand-file-name
-- (make-temp-name "liece") temporary-file-directory)))
-+ (make-temp-file "liece")))
- (unwind-protect
- (progn
- (rename-file liece-directory file 'ok-if-exists)
diff --git a/app-emacs/liece/liece-1.4.7-r1.ebuild b/app-emacs/liece/liece-1.4.7-r1.ebuild
deleted file mode 100644
index b97b2f7ad029..000000000000
--- a/app-emacs/liece/liece-1.4.7-r1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/liece/liece-1.4.7-r1.ebuild,v 1.5 2004/06/24 22:16:45 agriffis Exp $
-
-inherit elisp eutils
-
-IUSE=""
-
-DESCRIPTION="Liece is a client implementation of IRC (Internet Relay Chat, RFC 1459)."
-HOMEPAGE="http://www.unixuser.org/~ueno/liece/"
-SRC_URI="http://www.unixuser.org/~ueno/liece/dist/${P}.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86"
-
-DEPEND="virtual/emacs
- app-emacs/apel"
-
-src_unpack() {
-
- unpack ${A}
- epatch ${FILESDIR}/${P}-gentoo.patch
-}
-
-src_compile() {
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --with-lispdir=${SITELISP} \
- --mandir=/usr/share/man || die "./configure failed"
-
- emake || die
-}
-
-src_install () {
- make PREFIX=${D}/usr prefix=${D}/usr \
- infodir=${D}/usr/share/info \
- lispdir=${D}/${SITELISP} install || die
- elisp-site-file-install ${FILESDIR}/60liece-gentoo.el
-}
-
-pkg_postinst() {
- elisp-site-regen
-}
-
-pkg_postrm() {
- elisp-site-regen
-}
diff --git a/app-emacs/liece/liece-2.0.0_alpha20030526.ebuild b/app-emacs/liece/liece-2.0.0_alpha20030526.ebuild
deleted file mode 100644
index af4d6847719b..000000000000
--- a/app-emacs/liece/liece-2.0.0_alpha20030526.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/liece/liece-2.0.0_alpha20030526.ebuild,v 1.5 2004/06/24 22:16:45 agriffis Exp $
-
-inherit elisp
-
-DESCRIPTION="Liece is a client implementation of IRC (Internet Relay Chat, RFC 1459)."
-HOMEPAGE="http://www.unixuser.org/~ueno/liece/"
-SRC_URI="mirror://gentoo/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-# This is unstable branch taken from CVS snapshot, so please not to
-# mark it stable at any point. btw, I recommend you to use app-emacs/riece ;)
-KEYWORDS="~x86 alpha ~sparc ~ppc"
-IUSE=""
-
-DEPEND="virtual/emacs
- >=app-emacs/apel-10.6"
-
-S="${WORKDIR}/${PN}"
-
-src_unpack() {
-
- unpack ${A}
- cp ${FILESDIR}/delegate.el ${S}/lisp
-}
-
-src_compile() {
-
- econf --with-lispdir=${D}/${SITELISP} || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- einstall PREFIX=${D}/usr LISPDIR=${D}/${SITELISP} \
- || die "install failed"
- elisp-install ${PN} lisp/delegate.el*
- elisp-site-file-install ${FILESDIR}/60liece-gentoo.el \
- || die "elisp-site-file-install failed"
-
- dodoc AUTHORS INSTALL README
-}