summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2014-05-23 19:23:25 +0000
committerUlrich Müller <ulm@gentoo.org>2014-05-23 19:23:25 +0000
commit3262ff46489ee9fe0ed6bec20688d9dd37f14a12 (patch)
tree7497867bd0143e265b89a0e4c8fdeffc664f365e /app-emacs/magit
parentOld. (diff)
downloadgentoo-2-3262ff46489ee9fe0ed6bec20688d9dd37f14a12.tar.gz
gentoo-2-3262ff46489ee9fe0ed6bec20688d9dd37f14a12.tar.bz2
gentoo-2-3262ff46489ee9fe0ed6bec20688d9dd37f14a12.zip
Fix incompatibily with emacs-vcs. Call elisp-compile, because the upstream build system doesn't care about byte-compile errors.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 9433907D693FB5B8!)
Diffstat (limited to 'app-emacs/magit')
-rw-r--r--app-emacs/magit/ChangeLog9
-rw-r--r--app-emacs/magit/files/magit-1.2.0-delete-directory.patch33
-rw-r--r--app-emacs/magit/magit-1.2.0-r1.ebuild43
3 files changed, 84 insertions, 1 deletions
diff --git a/app-emacs/magit/ChangeLog b/app-emacs/magit/ChangeLog
index 238151533686..e23fb906e941 100644
--- a/app-emacs/magit/ChangeLog
+++ b/app-emacs/magit/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emacs/magit
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/magit/ChangeLog,v 1.11 2014/05/05 07:21:06 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/magit/ChangeLog,v 1.12 2014/05/23 19:23:25 ulm Exp $
+
+*magit-1.2.0-r1 (23 May 2014)
+
+ 23 May 2014; Ulrich Müller <ulm@gentoo.org> +magit-1.2.0-r1.ebuild,
+ +files/magit-1.2.0-delete-directory.patch:
+ Fix incompatibily with emacs-vcs. Call elisp-compile, because the upstream
+ build system doesn't care about byte-compile errors.
05 May 2014; Hans de Graaff <graaff@gentoo.org> magit-1.2.0.ebuild:
Fix HOMEPAGE. Restrict tests since the tests are not included in the archive.
diff --git a/app-emacs/magit/files/magit-1.2.0-delete-directory.patch b/app-emacs/magit/files/magit-1.2.0-delete-directory.patch
new file mode 100644
index 000000000000..6c85345e9460
--- /dev/null
+++ b/app-emacs/magit/files/magit-1.2.0-delete-directory.patch
@@ -0,0 +1,33 @@
+Fix byte-compile failure with Emacs 24.3.91.
+
+The upstream git repo has a more complicated fix which we don't use,
+because the Gentoo package need not care about Emacs 22 and XEmacs
+compatibility. Instead, always define magit-delete-directory as an
+alias of delete-directory. This will work for all supported Emacs
+versions.
+
+--- magit-1.2.0-orig/magit.el
++++ magit-1.2.0/magit.el
+@@ -775,21 +775,7 @@
+ after-change-functions)
+ ,@body)))))
+
+- (if (>= (magit-max-args-internal 'delete-directory) 2)
+- (defalias 'magit-delete-directory 'delete-directory)
+- (defun magit-delete-directory (directory &optional recursive)
+- "Deletes a directory named DIRECTORY. If RECURSIVE is non-nil,
+-recursively delete all of DIRECTORY's contents as well.
+-
+-Does not follow symlinks."
+- (if (or (file-symlink-p directory)
+- (not (file-directory-p directory)))
+- (delete-file directory)
+- (if recursive
+- ;; `directory-files-no-dot-files-regex' borrowed from Emacs 23
+- (dolist (file (directory-files directory 'full "\\([^.]\\|\\.\\([^.]\\|\\..\\)\\).*"))
+- (magit-delete-directory file recursive)))
+- (delete-directory directory)))))
++ (defalias 'magit-delete-directory 'delete-directory))
+
+ ;;; Utilities
+
diff --git a/app-emacs/magit/magit-1.2.0-r1.ebuild b/app-emacs/magit/magit-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..0f8902974418
--- /dev/null
+++ b/app-emacs/magit/magit-1.2.0-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/magit/magit-1.2.0-r1.ebuild,v 1.1 2014/05/23 19:23:25 ulm Exp $
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="An Emacs mode for GIT"
+HOMEPAGE="http://magit.github.io/"
+SRC_URI="http://github.com/downloads/magit/magit/${P}.tar.gz"
+
+LICENSE="GPL-3+ FDL-1.2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="contrib"
+
+ELISP_PATCHES="${P}-delete-directory.patch"
+SITEFILE="50${PN}-gentoo.el"
+
+RESTRICT="test"
+
+src_compile() {
+ # The upstream build system ignores errors during byte-compilation
+ # and happily installs broken files, causing errors at runtime.
+ # Call elisp-compile, in order to catch them here already.
+ elisp-compile *.el
+ emake core docs
+ use contrib && emake contrib
+ rm 50magit.el magit-pkg.el || die
+}
+
+src_install() {
+ elisp-install ${PN} *.{el,elc} || die
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ doinfo magit.info
+ dodoc README.md
+
+ if use contrib; then
+ elisp-install ${PN} contrib/*.{el,elc} || die
+ dobin contrib/magit
+ fi
+}