summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2006-11-24 09:45:33 +0000
committerChristian Faulhammer <opfer@gentoo.org>2006-11-24 09:45:33 +0000
commit8f05048f65eef1eadbc2917fa984019795539823 (patch)
treed0ff7c85487cd2acff7c3c1a01877b2d77e3410e /app-emacs/mailcrypt/mailcrypt-3.5.8-r1.ebuild
parentBump. (diff)
downloadgentoo-2-8f05048f65eef1eadbc2917fa984019795539823.tar.gz
gentoo-2-8f05048f65eef1eadbc2917fa984019795539823.tar.bz2
gentoo-2-8f05048f65eef1eadbc2917fa984019795539823.zip
added test USE flag to pull in dev-python/py-gnupg and modified src_test(). Reverted amd64 to ~amd64 as they don't have dev-python/py-gnupg in stable, all other arches stay
(Portage version: 2.1.1-r2)
Diffstat (limited to 'app-emacs/mailcrypt/mailcrypt-3.5.8-r1.ebuild')
-rw-r--r--app-emacs/mailcrypt/mailcrypt-3.5.8-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-emacs/mailcrypt/mailcrypt-3.5.8-r1.ebuild b/app-emacs/mailcrypt/mailcrypt-3.5.8-r1.ebuild
new file mode 100644
index 000000000000..be7e93200d68
--- /dev/null
+++ b/app-emacs/mailcrypt/mailcrypt-3.5.8-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/mailcrypt/mailcrypt-3.5.8-r1.ebuild,v 1.1 2006/11/24 09:45:33 opfer Exp $
+
+inherit elisp
+
+
+DESCRIPTION="Provides a simple interface to public key cryptography with PGP [and now GnuPG!]."
+HOMEPAGE="http://mailcrypt.sourceforge.net/"
+SRC_URI="mirror://sourceforge/mailcrypt/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="test"
+
+KEYWORDS="x86 ~amd64 ppc sparc"
+
+DEPEND="virtual/emacs"
+RDEPEND="${DEPEND}
+ app-crypt/gnupg
+ test? ( dev-python/py-gnupg )"
+
+src_compile() {
+ export EMACS=/usr/bin/emacs
+ econf || die
+ make || die
+}
+
+src_test() {
+ use test && emake check
+}
+
+src_install() {
+ einstall lispdir=${D}/${SITELISP}/${PN} || die
+ elisp-site-file-install ${FILESDIR}/50mailcrypt-gentoo.el
+ dodoc ANNOUNCE ChangeLog* INSTALL LCD-entry mailcrypt.dvi NEWS ONEWS README*
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ einfo ""
+ einfo "See /usr/share/doc/${P}/INSTALL.gz for how to customize mailcrypt"
+ einfo ""
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}