summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2002-11-01 02:52:02 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2002-11-01 02:52:02 +0000
commit08bd106430ca5599005323021f7635b2f1a1f72b (patch)
treed56e46390f1a7838a1a5eecfd8573e5eb47d0c98 /app-emacs/matlab
parentmasked app-emacs/monk (incomplete for now) (diff)
downloadgentoo-2-08bd106430ca5599005323021f7635b2f1a1f72b.tar.gz
gentoo-2-08bd106430ca5599005323021f7635b2f1a1f72b.tar.bz2
gentoo-2-08bd106430ca5599005323021f7635b2f1a1f72b.zip
looks like an app-emacs/ import to me
Diffstat (limited to 'app-emacs/matlab')
-rw-r--r--app-emacs/matlab/ChangeLog11
-rw-r--r--app-emacs/matlab/files/50matlab-gentoo.el12
-rw-r--r--app-emacs/matlab/files/digest-matlab-2.2.31
-rw-r--r--app-emacs/matlab/matlab-2.2.3.ebuild38
4 files changed, 62 insertions, 0 deletions
diff --git a/app-emacs/matlab/ChangeLog b/app-emacs/matlab/ChangeLog
new file mode 100644
index 000000000000..99903d7d6ef0
--- /dev/null
+++ b/app-emacs/matlab/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-emacs/matlab
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/matlab/ChangeLog,v 1.1 2002/11/01 02:52:01 mkennedy Exp $
+
+*matlab-2.2.3 (31 Oct 2002)
+
+ 31 Oct 2002; Matthew Kennedy <mkennedy@gentoo.org> ChangeLog,
+ matlab-2.2.3.ebuild, files/50matlab-gentoo.el,
+ files/digest-matlab-2.2.3 :
+
+ Initial import.
diff --git a/app-emacs/matlab/files/50matlab-gentoo.el b/app-emacs/matlab/files/50matlab-gentoo.el
new file mode 100644
index 000000000000..69ca8b1c235a
--- /dev/null
+++ b/app-emacs/matlab/files/50matlab-gentoo.el
@@ -0,0 +1,12 @@
+
+;;; matlab site-lisp configuration
+
+(setq load-path (cons "@SITELISP@" load-path))
+
+(autoload 'matlab-mode "matlab" "Enter Matlab mode." t)
+(setq auto-mode-alist (cons '("\\.m\\'" . matlab-mode) auto-mode-alist))
+(autoload 'matlab-shell "matlab" "Interactive Matlab mode." t)
+
+(autoload 'tlc-mode "tlc" "tlc Editing Mode" t)
+(add-to-list 'auto-mode-alist '("\\.tlc$" . tlc-mode))
+(setq tlc-indent-function t)
diff --git a/app-emacs/matlab/files/digest-matlab-2.2.3 b/app-emacs/matlab/files/digest-matlab-2.2.3
new file mode 100644
index 000000000000..e0c34ad1b789
--- /dev/null
+++ b/app-emacs/matlab/files/digest-matlab-2.2.3
@@ -0,0 +1 @@
+MD5 5fec7d2a4ced01c3c407ecacd4c3eaa5 matlab-2.2.3.tar.bz2 49171
diff --git a/app-emacs/matlab/matlab-2.2.3.ebuild b/app-emacs/matlab/matlab-2.2.3.ebuild
new file mode 100644
index 000000000000..ec407a31a7f0
--- /dev/null
+++ b/app-emacs/matlab/matlab-2.2.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/matlab/matlab-2.2.3.ebuild,v 1.1 2002/11/01 02:52:01 mkennedy Exp $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="Major modes for MATLAB dot-m and dot-tlc files"
+HOMEPAGE="ftp://ftp.mathworks.com/pub/contrib/emacs_add_ons/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/emacs"
+
+S="${WORKDIR}/${P}"
+
+SITEFILE=50matlab-gentoo.el
+
+src_compile() {
+ emacs --batch -f batch-byte-compile --no-site-file --no-init-file *.el
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ einfo "Please see ${SITELISP}/${PN}/ for the complete documentation."
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}