summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2002-11-01 02:52:02 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2002-11-01 02:52:02 +0000
commit08bd106430ca5599005323021f7635b2f1a1f72b (patch)
treed56e46390f1a7838a1a5eecfd8573e5eb47d0c98 /app-emacs/python-mode
parentmasked app-emacs/monk (incomplete for now) (diff)
downloadgentoo-2-08bd106430ca5599005323021f7635b2f1a1f72b.tar.gz
gentoo-2-08bd106430ca5599005323021f7635b2f1a1f72b.tar.bz2
gentoo-2-08bd106430ca5599005323021f7635b2f1a1f72b.zip
looks like an app-emacs/ import to me
Diffstat (limited to 'app-emacs/python-mode')
-rw-r--r--app-emacs/python-mode/ChangeLog11
-rw-r--r--app-emacs/python-mode/files/50python-mode-gentoo.el10
-rw-r--r--app-emacs/python-mode/files/digest-python-mode-4.61
-rw-r--r--app-emacs/python-mode/python-mode-4.6.ebuild35
4 files changed, 57 insertions, 0 deletions
diff --git a/app-emacs/python-mode/ChangeLog b/app-emacs/python-mode/ChangeLog
new file mode 100644
index 000000000000..4934d9984cac
--- /dev/null
+++ b/app-emacs/python-mode/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-emacs/python-mode
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/python-mode/ChangeLog,v 1.1 2002/11/01 02:52:01 mkennedy Exp $
+
+*python-mode-4.6 (31 Oct 2002)
+
+ 31 Oct 2002; Matthew Kennedy <mkennedy@gentoo.org> ChangeLog,
+ python-mode-4.6.ebuild, files/50python-mode-gentoo.el,
+ files/digest-python-mode-4.6 :
+
+ Initial import.
diff --git a/app-emacs/python-mode/files/50python-mode-gentoo.el b/app-emacs/python-mode/files/50python-mode-gentoo.el
new file mode 100644
index 000000000000..12b6ed4af80e
--- /dev/null
+++ b/app-emacs/python-mode/files/50python-mode-gentoo.el
@@ -0,0 +1,10 @@
+
+;;; python-mode site-lisp configuration
+
+(setq load-path (cons "@SITELISP@" load-path))
+(setq auto-mode-alist
+ (cons '("\\.py$" . python-mode) auto-mode-alist))
+(setq interpreter-mode-alist
+ (cons '("python" . python-mode)
+ interpreter-mode-alist))
+(autoload 'python-mode "python-mode" "Python editing mode." t)
diff --git a/app-emacs/python-mode/files/digest-python-mode-4.6 b/app-emacs/python-mode/files/digest-python-mode-4.6
new file mode 100644
index 000000000000..0407739b9a7e
--- /dev/null
+++ b/app-emacs/python-mode/files/digest-python-mode-4.6
@@ -0,0 +1 @@
+MD5 b745ffc1a604fde7adb194fce0d2a5cc python-mode-4.6.tar.bz2 31831
diff --git a/app-emacs/python-mode/python-mode-4.6.ebuild b/app-emacs/python-mode/python-mode-4.6.ebuild
new file mode 100644
index 000000000000..2384b1fec050
--- /dev/null
+++ b/app-emacs/python-mode/python-mode-4.6.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/python-mode/python-mode-4.6.ebuild,v 1.1 2002/11/01 02:52:01 mkennedy Exp $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="Python Mode is a major editing mode for the XEmacs and FSF Emacs text editors."
+HOMEPAGE="http://www.python.org/emacs/python-mode/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/emacs"
+
+S="${WORKDIR}/${P}"
+
+src_compile() {
+ emacs -batch -eval '(byte-compile-file "python-mode.el")'
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install ${FILESDIR}/50python-mode-gentoo.el
+}
+
+pkg_postinst() {
+ elisp-site-regen
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}