summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2013-01-04 10:50:38 +0000
committerChristian Faulhammer <fauli@gentoo.org>2013-01-04 10:50:38 +0000
commit70c374ee1f88c9e82b412886de6ca71fd0d96e67 (patch)
treebc6ed4d5007f216c88cd25586856794ede99b2eb /app-emacs/python-mode
parentclean up (diff)
downloadgentoo-2-70c374ee1f88c9e82b412886de6ca71fd0d96e67.tar.gz
gentoo-2-70c374ee1f88c9e82b412886de6ca71fd0d96e67.tar.bz2
gentoo-2-70c374ee1f88c9e82b412886de6ca71fd0d96e67.zip
version bump and also associate with .pyx files as lined out in bug 445366 by Michael Orlitzky
(Portage version: 2.1.11.31/cvs/Linux i686, signed Manifest commit with key 2B859DE3)
Diffstat (limited to 'app-emacs/python-mode')
-rw-r--r--app-emacs/python-mode/ChangeLog11
-rw-r--r--app-emacs/python-mode/files/50python-mode-gentoo.el1
-rw-r--r--app-emacs/python-mode/python-mode-6.1.0.ebuild26
3 files changed, 36 insertions, 2 deletions
diff --git a/app-emacs/python-mode/ChangeLog b/app-emacs/python-mode/ChangeLog
index db6c55943a6f..90215a914621 100644
--- a/app-emacs/python-mode/ChangeLog
+++ b/app-emacs/python-mode/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emacs/python-mode
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/python-mode/ChangeLog,v 1.65 2012/11/03 10:57:51 ulm Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/python-mode/ChangeLog,v 1.66 2013/01/04 10:50:37 fauli Exp $
+
+*python-mode-6.1.0 (04 Jan 2013)
+
+ 04 Jan 2013; Christian Faulhammer <fauli@gentoo.org>
+ files/50python-mode-gentoo.el, +python-mode-6.1.0.ebuild:
+ version bump and also associate with .pyx files as lined out in bug 445366 by
+ Michael Orlitzky
*python-mode-6.0.12 (03 Nov 2012)
diff --git a/app-emacs/python-mode/files/50python-mode-gentoo.el b/app-emacs/python-mode/files/50python-mode-gentoo.el
index bdb5c12ceb6b..75812316482a 100644
--- a/app-emacs/python-mode/files/50python-mode-gentoo.el
+++ b/app-emacs/python-mode/files/50python-mode-gentoo.el
@@ -6,5 +6,6 @@
"Start an interactive Python interpreter in another window." t)
(add-to-list 'auto-mode-alist '("\\.py$" . python-mode))
+(add-to-list 'auto-mode-alist '("\\.pyx$" . python-mode))
(add-to-list 'interpreter-mode-alist '("python" . python-mode))
(add-to-list 'interpreter-mode-alist '("jython" . jython-mode))
diff --git a/app-emacs/python-mode/python-mode-6.1.0.ebuild b/app-emacs/python-mode/python-mode-6.1.0.ebuild
new file mode 100644
index 000000000000..aaa63fb92287
--- /dev/null
+++ b/app-emacs/python-mode/python-mode-6.1.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/python-mode/python-mode-6.1.0.ebuild,v 1.1 2013/01/04 10:50:38 fauli Exp $
+
+EAPI=4
+
+inherit elisp
+
+MY_P="${PN}.el-${PV}"
+DESCRIPTION="An Emacs major mode for editing Python source"
+HOMEPAGE="https://launchpad.net/python-mode"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${MY_P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+S="${WORKDIR}/${MY_P}"
+SITEFILE="50${PN}-gentoo.el"
+DOCS="NEWS README"
+
+pkg_postinst() {
+ elisp-site-regen
+ elog "Note that doctest and pymacs are in their own packages,"
+ elog "app-emacs/doctest-mode and app-emacs/pymacs, respectively."
+}