summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2004-05-11 05:23:51 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2004-05-11 05:23:51 +0000
commitc87de7aa1e747d423f2636b09a926f3c472349e2 (patch)
treed39176e22790d0cffc6973535708bfb2b5b250f9 /app-emacs/slime
parent~amd64,~ppc (Manifest recommit) (diff)
downloadgentoo-2-c87de7aa1e747d423f2636b09a926f3c472349e2.tar.gz
gentoo-2-c87de7aa1e747d423f2636b09a926f3c472349e2.tar.bz2
gentoo-2-c87de7aa1e747d423f2636b09a926f3c472349e2.zip
*** empty log message ***
Diffstat (limited to 'app-emacs/slime')
-rw-r--r--app-emacs/slime/ChangeLog10
-rw-r--r--app-emacs/slime/Manifest9
-rw-r--r--app-emacs/slime/files/70slime-gentoo.el16
-rw-r--r--app-emacs/slime/files/digest-slime-0.131
-rw-r--r--app-emacs/slime/files/swank-loader.lisp4
-rw-r--r--app-emacs/slime/files/swank.asd42
-rw-r--r--app-emacs/slime/metadata.xml6
-rw-r--r--app-emacs/slime/slime-0.13.ebuild66
8 files changed, 154 insertions, 0 deletions
diff --git a/app-emacs/slime/ChangeLog b/app-emacs/slime/ChangeLog
new file mode 100644
index 000000000000..299841ff3bae
--- /dev/null
+++ b/app-emacs/slime/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-emacs/slime
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/slime/ChangeLog,v 1.1 2004/05/11 05:23:51 mkennedy Exp $
+
+*slime-0.13 (11 May 2004)
+
+ 11 May 2004; <mkennedy@gentoo.org> +metadata.xml, +files/70slime-gentoo.el,
+ +files/swank-loader.lisp, +files/swank.asd, +slime-0.13.ebuild:
+ Initial port. Ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>
+
diff --git a/app-emacs/slime/Manifest b/app-emacs/slime/Manifest
new file mode 100644
index 000000000000..8f8f4fb45e9b
--- /dev/null
+++ b/app-emacs/slime/Manifest
@@ -0,0 +1,9 @@
+MD5 4feada061d5fdeefef639564a34517cd slime-0.13.ebuild~ 2482
+MD5 9267a5e2b79065d45e251d5b39717126 slime-0.13.ebuild 2109
+MD5 fcd33d07e4ee719b01157946734f4fe8 metadata.xml 158
+MD5 909ff27dec8d97d16b944bf184b638b6 files/digest-slime-0.13 63
+MD5 1c15ee0769d7f32006679d98268d626e files/swank.asd 934
+MD5 910993d2e23f61b956f2df6fad49b657 files/70slime-gentoo.el 577
+MD5 795ef212ff502911b5bfb98558962d99 files/swank.lisp-sbcl.patch 511
+MD5 e4086b50bade07de735b2e62d60c41cb files/swank-loader.lisp 50
+MD5 ae46ef5b6d0e6033335cbf6dc1ead846 files/swank.asd~ 927
diff --git a/app-emacs/slime/files/70slime-gentoo.el b/app-emacs/slime/files/70slime-gentoo.el
new file mode 100644
index 000000000000..4fde74012ac1
--- /dev/null
+++ b/app-emacs/slime/files/70slime-gentoo.el
@@ -0,0 +1,16 @@
+
+;;; site-lisp configuration for slime-cvs
+
+(add-to-list 'load-path "@SITELISP@")
+(require 'slime)
+(add-hook 'lisp-mode-hook
+ (lambda () (slime-mode t)))
+(add-hook 'inferior-lisp-mode-hook
+ (lambda () (inferior-slime-mode t)))
+
+;; this prevents us from requiring the user get dev-lisp/hyperspec
+;; (which is non-free) as a hard dependency
+
+(if (file-exists-p "/usr/share/doc/hyperspec-6.0/HyperSpec")
+ (setq common-lisp-hyperspec-root "file:///usr/share/doc/hyperspec-6.0/HyperSpec/")
+ (setq common-lisp-hyperspec-root "http://www.lispworks.com/reference/HyperSpec/"))
diff --git a/app-emacs/slime/files/digest-slime-0.13 b/app-emacs/slime/files/digest-slime-0.13
new file mode 100644
index 000000000000..505c4fe37d93
--- /dev/null
+++ b/app-emacs/slime/files/digest-slime-0.13
@@ -0,0 +1 @@
+MD5 183e8af3e4561dfbe801e23a44c5a4b4 slime-0.13.tar.bz2 198978
diff --git a/app-emacs/slime/files/swank-loader.lisp b/app-emacs/slime/files/swank-loader.lisp
new file mode 100644
index 000000000000..497b877c7a36
--- /dev/null
+++ b/app-emacs/slime/files/swank-loader.lisp
@@ -0,0 +1,4 @@
+
+;;; fake swank-loader.lisp file
+
+(require :swank) \ No newline at end of file
diff --git a/app-emacs/slime/files/swank.asd b/app-emacs/slime/files/swank.asd
new file mode 100644
index 000000000000..991c3822d637
--- /dev/null
+++ b/app-emacs/slime/files/swank.asd
@@ -0,0 +1,42 @@
+;;; -*- mode: lisp; syntax: common-lisp; indent-tabs-mode: nil; package: cl-user -*-
+
+(defpackage #:swank-system
+ (:use #:common-lisp
+ #:asdf))
+
+(in-package #:swank-system)
+
+;; http://www.caddr.com/macho/archives/sbcl-devel/2004-3/3014.html
+
+(defclass unsafe-file (cl-source-file) ())
+
+(defmethod perform :around ((op compile-op) (c unsafe-file))
+ (setf (operation-on-warnings op) :ignore
+ (operation-on-failure op) :warn) ; adjust to taste
+ (call-next-method))
+
+(defsystem #:swank
+ :name "Swank is the Common Lisp back-end to Slime"
+ :licence "GPL-2"
+ :components
+ #+cmu ((:file "swank-backend")
+ (:file "nregex")
+ (:file "swank-source-path-parser")
+ (:file "swank-cmucl")
+ (:file "swank"))
+ #+sbcl ((:file "swank-backend")
+ (:file "swank-sbcl")
+ (:file "nregex")
+ (:file "swank-source-path-parser")
+ (:file "swank-gray")
+ (:unsafe-file "swank"))
+ #+clisp ((:file "swank-backend")
+ (:file "nregex")
+ (:file "xref")
+ (:file "metering")
+ (:file "swank-clisp")
+ (:file "swank-gray")
+ (:file "swank"))
+ #+sbcl :depends-on #+sbcl (:sb-bsd-sockets))
+
+;; swank.asd ends here
diff --git a/app-emacs/slime/metadata.xml b/app-emacs/slime/metadata.xml
new file mode 100644
index 000000000000..247bba1deff4
--- /dev/null
+++ b/app-emacs/slime/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<herd>common-lisp</herd>
+</pkgmetadata>
diff --git a/app-emacs/slime/slime-0.13.ebuild b/app-emacs/slime/slime-0.13.ebuild
new file mode 100644
index 000000000000..2a74dec36509
--- /dev/null
+++ b/app-emacs/slime/slime-0.13.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/slime/slime-0.13.ebuild,v 1.1 2004/05/11 05:23:51 mkennedy Exp $
+
+inherit elisp
+
+DESCRIPTION="SLIME: The Superior Lisp Interaction Mode for Emacs"
+HOMEPAGE="http://common-lisp.net/project/slime/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+LICENSE="GPL-2 | public-domain | LLGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="virtual/emacs
+ dev-lisp/common-lisp-controller
+ virtual/commonlisp"
+
+S="${WORKDIR}/${P}"
+
+CLPACKAGE=swank
+
+src_compile() {
+ echo "(add-to-list 'load-path \".\")" >script
+ emacs --batch -q -l script -f batch-byte-compile hyperspec.el slime.el || die
+}
+
+src_install() {
+ elisp-install ${PN} hyperspec.el slime.el slime.elc ${FILESDIR}/swank-loader.lisp
+ elisp-site-file-install ${FILESDIR}/70slime-gentoo.el
+ dodoc README* ChangeLog
+ insinto /usr/share/common-lisp/source/swank
+ # ChangeLog is needed at compile time!!
+ doins *.lisp ${FILESDIR}/swank.asd ChangeLog
+ dodir /usr/share/common-lisp/systems
+ dosym /usr/share/common-lisp/source/swank/swank.asd \
+ /usr/share/common-lisp/systems
+}
+
+pkg_preinst() {
+ rm -rf /usr/lib/common-lisp/*/${CLPACKAGE} || true
+}
+
+pkg_postrm() {
+ rm -rf /usr/lib/common-lisp/*/${CLPACKAGE} || true
+ elisp-site-regen
+}
+
+pkg_postinst() {
+ /usr/sbin/register-common-lisp-source ${CLPACKAGE}
+ elisp-site-regen
+ while read line; do einfo "${line}"; done <<EOF
+
+SLIME notes for Gentoo
+----------------------
+
+Gentoo's port for SLIME uses its own swank.asd so that it fits more
+cleanly into the Gentoo Common Lisp Controller framework. For this
+reason, DO NOT report problems to SLIME's upstream authors. Always
+report problems to the Gentoo Bugzilla at http://bugs.gentoo.org
+unless you are absolutely certain your problem it is not related to
+the Gentoo port of SLIME.
+
+Matthew Kennedy <mkennedy@gentoo.org>
+
+EOF
+}