summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2007-04-17 06:51:52 +0000
committerUlrich Müller <ulm@gentoo.org>2007-04-17 06:51:52 +0000
commit930d9b682e005a8a2cbfc6606c48f8ffdf925cd8 (patch)
treea8231825f02dcca772f04cd1943b4cbed6b5a3c8 /app-emacs/tnt
parentStable on ppc64; bug #174845 (diff)
downloadgentoo-2-930d9b682e005a8a2cbfc6606c48f8ffdf925cd8.tar.gz
gentoo-2-930d9b682e005a8a2cbfc6606c48f8ffdf925cd8.tar.bz2
gentoo-2-930d9b682e005a8a2cbfc6606c48f8ffdf925cd8.zip
Use elisp-comp for compilation, #174868.
(Portage version: 2.1.2.4)
Diffstat (limited to 'app-emacs/tnt')
-rw-r--r--app-emacs/tnt/ChangeLog7
-rw-r--r--app-emacs/tnt/files/digest-tnt-2.6-r13
-rw-r--r--app-emacs/tnt/tnt-2.6-r1.ebuild32
3 files changed, 41 insertions, 1 deletions
diff --git a/app-emacs/tnt/ChangeLog b/app-emacs/tnt/ChangeLog
index 9f9342cd2c53..e1816afa9640 100644
--- a/app-emacs/tnt/ChangeLog
+++ b/app-emacs/tnt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emacs/tnt
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/tnt/ChangeLog,v 1.8 2007/04/06 20:41:48 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/tnt/ChangeLog,v 1.9 2007/04/17 06:51:52 ulm Exp $
+
+*tnt-2.6-r1 (17 Apr 2007)
+
+ 17 Apr 2007; Ulrich Mueller <ulm@gentoo.org> +tnt-2.6-r1.ebuild:
+ Use elisp-comp instead of (implicit) elisp-compile. Fixes bug #174868.
06 Apr 2007; Christian Faulhammer <opfer@gentoo.org> -tnt-2.4.ebuild,
tnt-2.6.ebuild:
diff --git a/app-emacs/tnt/files/digest-tnt-2.6-r1 b/app-emacs/tnt/files/digest-tnt-2.6-r1
new file mode 100644
index 000000000000..e80a042df53d
--- /dev/null
+++ b/app-emacs/tnt/files/digest-tnt-2.6-r1
@@ -0,0 +1,3 @@
+MD5 6c2481d87da5fbf3424caca4f2b5129d tnt-2.6.tar.gz 112490
+RMD160 f698f25813fbb60035fbbbb55a339145cb7bbbbc tnt-2.6.tar.gz 112490
+SHA256 207ee988867537f8707c26503c6c7c9c2f9f818720199a813360d60e66d272eb tnt-2.6.tar.gz 112490
diff --git a/app-emacs/tnt/tnt-2.6-r1.ebuild b/app-emacs/tnt/tnt-2.6-r1.ebuild
new file mode 100644
index 000000000000..f35d165ec432
--- /dev/null
+++ b/app-emacs/tnt/tnt-2.6-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/tnt/tnt-2.6-r1.ebuild,v 1.1 2007/04/17 06:51:52 ulm Exp $
+
+inherit elisp
+
+DESCRIPTION="Client for the AOL Instant Messenging service using the Emacs text editor as its UI"
+HOMEPAGE="http://tnt.sourceforge.net/"
+SRC_URI="mirror://sourceforge/tnt/${P}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+SITEFILE=51${PN}-gentoo.el
+
+DEPEND=""
+
+src_compile() {
+ elisp-comp *.el || die "elisp-comp failed"
+}
+
+src_install() {
+ elisp-install ${PN} *.{el,elc}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ insinto "$SITELISP/tnt/sounds"
+ doins sounds/*
+ dodoc ChangeLog PROTOCOL README
+ insinto /usr/share/doc/${PF}/procmail
+ doins procmail/*
+}