summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2002-11-01 02:52:02 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2002-11-01 02:52:02 +0000
commit08bd106430ca5599005323021f7635b2f1a1f72b (patch)
treed56e46390f1a7838a1a5eecfd8573e5eb47d0c98 /app-emacs/u-vm-color
parentmasked app-emacs/monk (incomplete for now) (diff)
downloadgentoo-2-08bd106430ca5599005323021f7635b2f1a1f72b.tar.gz
gentoo-2-08bd106430ca5599005323021f7635b2f1a1f72b.tar.bz2
gentoo-2-08bd106430ca5599005323021f7635b2f1a1f72b.zip
looks like an app-emacs/ import to me
Diffstat (limited to 'app-emacs/u-vm-color')
-rw-r--r--app-emacs/u-vm-color/ChangeLog11
-rw-r--r--app-emacs/u-vm-color/files/50u-vm-color-gentoo.el9
-rw-r--r--app-emacs/u-vm-color/files/digest-u-vm-color-1.71
-rw-r--r--app-emacs/u-vm-color/u-vm-color-1.7.ebuild39
4 files changed, 60 insertions, 0 deletions
diff --git a/app-emacs/u-vm-color/ChangeLog b/app-emacs/u-vm-color/ChangeLog
new file mode 100644
index 000000000000..3b9b3de4fa30
--- /dev/null
+++ b/app-emacs/u-vm-color/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-emacs/u-vm-color
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/u-vm-color/ChangeLog,v 1.1 2002/11/01 02:52:02 mkennedy Exp $
+
+*u-vm-color-1.7 (31 Oct 2002)
+
+ 31 Oct 2002; Matthew Kennedy <mkennedy@gentoo.org> ChangeLog,
+ u-vm-color-1.7.ebuild, files/50u-vm-color-gentoo.el,
+ files/digest-u-vm-color-1.7 :
+
+ Initial import.
diff --git a/app-emacs/u-vm-color/files/50u-vm-color-gentoo.el b/app-emacs/u-vm-color/files/50u-vm-color-gentoo.el
new file mode 100644
index 000000000000..14969766ec8d
--- /dev/null
+++ b/app-emacs/u-vm-color/files/50u-vm-color-gentoo.el
@@ -0,0 +1,9 @@
+
+;;; u-vm-color site-lisp configuration
+
+(setq load-path (cons "@SITELISP@" load-path))
+(require 'u-vm-color)
+(add-hook 'vm-mode-hook 'u-vm-color-presentation-mode)
+(add-hook 'vm-presentation-mode-hook 'u-vm-color-presentation-mode)
+(add-hook 'vm-summary-mode-hook 'u-vm-color-summary-mode)
+
diff --git a/app-emacs/u-vm-color/files/digest-u-vm-color-1.7 b/app-emacs/u-vm-color/files/digest-u-vm-color-1.7
new file mode 100644
index 000000000000..764044abbbad
--- /dev/null
+++ b/app-emacs/u-vm-color/files/digest-u-vm-color-1.7
@@ -0,0 +1 @@
+MD5 a8c5478d5e385c4c5bc730e8507a361e u-vm-color-1.7.tar.bz2 3833
diff --git a/app-emacs/u-vm-color/u-vm-color-1.7.ebuild b/app-emacs/u-vm-color/u-vm-color-1.7.ebuild
new file mode 100644
index 000000000000..4dac088eb476
--- /dev/null
+++ b/app-emacs/u-vm-color/u-vm-color-1.7.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/u-vm-color/u-vm-color-1.7.ebuild,v 1.1 2002/11/01 02:52:02 mkennedy Exp $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="Color schemes for VM"
+HOMEPAGE="ftp://ftp.cis.ohio-state.edu/pub/emacs-lisp/archive/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/emacs
+ app-emacs/vm"
+
+S="${WORKDIR}/${P}"
+
+SITEFILE=50u-vm-color-gentoo.el
+
+src_compile() {
+ emacs --batch -f batch-byte-compile --no-site-file --no-init-file *.el
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ einfo "Please see ${SITELISP}/${PN}/u-vm-color.el for the complete documentation."
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}