summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2007-08-26 02:55:19 +0000
committerUlrich Müller <ulm@gentoo.org>2007-08-26 02:55:19 +0000
commit8ecc8bb5de9de960a3526b873b490d5eb2b61924 (patch)
tree7553b9d12d5fb3a6b047194ec27c8f02fd462b18 /app-emacs/vm
parentupdate selinux policy maskings (diff)
downloadgentoo-2-8ecc8bb5de9de960a3526b873b490d5eb2b61924.tar.gz
gentoo-2-8ecc8bb5de9de960a3526b873b490d5eb2b61924.tar.bz2
gentoo-2-8ecc8bb5de9de960a3526b873b490d5eb2b61924.zip
Use vm-mime-8bit-composition-charset to determine charset for sending.
(Portage version: 2.1.3.7)
Diffstat (limited to 'app-emacs/vm')
-rw-r--r--app-emacs/vm/ChangeLog9
-rw-r--r--app-emacs/vm/files/digest-vm-8.0.2.487-r13
-rw-r--r--app-emacs/vm/files/vm-8.0.2.487-proper-charset.patch11
-rw-r--r--app-emacs/vm/vm-8.0.2.487-r1.ebuild49
4 files changed, 71 insertions, 1 deletions
diff --git a/app-emacs/vm/ChangeLog b/app-emacs/vm/ChangeLog
index 5cd15746cf66..72f737182af6 100644
--- a/app-emacs/vm/ChangeLog
+++ b/app-emacs/vm/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emacs/vm
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/vm/ChangeLog,v 1.36 2007/08/19 12:41:08 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/vm/ChangeLog,v 1.37 2007/08/26 02:55:19 ulm Exp $
+
+*vm-8.0.2.487-r1 (26 Aug 2007)
+
+ 26 Aug 2007; Ulrich Mueller <ulm@gentoo.org>
+ +files/vm-8.0.2.487-proper-charset.patch, +vm-8.0.2.487-r1.ebuild:
+ Use vm-mime-8bit-composition-charset to determine charset for sending;
+ backported from version 8.0.3.
*vm-8.0.3.495 (19 Aug 2007)
diff --git a/app-emacs/vm/files/digest-vm-8.0.2.487-r1 b/app-emacs/vm/files/digest-vm-8.0.2.487-r1
new file mode 100644
index 000000000000..e64393392275
--- /dev/null
+++ b/app-emacs/vm/files/digest-vm-8.0.2.487-r1
@@ -0,0 +1,3 @@
+MD5 1829a2e8296f681ac5414f11013c34f9 vm-8.0.2-487.tgz 536869
+RMD160 f4c13d135dc79ee5f31d4c1000b88d831928e591 vm-8.0.2-487.tgz 536869
+SHA256 5fa6d10596ec28d1a0db035c75ac724e4942744551ed708247983d9c150b24d9 vm-8.0.2-487.tgz 536869
diff --git a/app-emacs/vm/files/vm-8.0.2.487-proper-charset.patch b/app-emacs/vm/files/vm-8.0.2.487-proper-charset.patch
new file mode 100644
index 000000000000..eb9fb9ee26f1
--- /dev/null
+++ b/app-emacs/vm/files/vm-8.0.2.487-proper-charset.patch
@@ -0,0 +1,11 @@
+--- lisp/vm-mime.el~ 2007-07-25 00:21:40.000000000 +0200
++++ lisp/vm-mime.el 2007-08-26 04:41:18.000000000 +0200
+@@ -1536,7 +1537,7 @@
+ (throw 'done nil))))
+ ;; Couldn't do any magic with vm-coding-system-priorities. Pass
+ ;; back a Japanese iso-2022 MIME character set.
+- (t "iso-2022-jp")))
++ (t (or vm-mime-8bit-composition-charset "iso-2022-jp"))))
+ ;; If we're non-MULE and there are eight bit characters, use a
+ ;; sensible default.
+ (goto-char (point-min))
diff --git a/app-emacs/vm/vm-8.0.2.487-r1.ebuild b/app-emacs/vm/vm-8.0.2.487-r1.ebuild
new file mode 100644
index 000000000000..d4334cb880ba
--- /dev/null
+++ b/app-emacs/vm/vm-8.0.2.487-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/vm/vm-8.0.2.487-r1.ebuild,v 1.1 2007/08/26 02:55:19 ulm Exp $
+
+inherit elisp eutils versionator
+
+VM_PV=$(replace_version_separator 3 '-')
+VM_P=${PN}-${VM_PV}
+
+DESCRIPTION="The VM mail reader for Emacs"
+HOMEPAGE="http://www.nongnu.org/viewmail/"
+SRC_URI="http://download.savannah.nongnu.org/releases/viewmail/${VM_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="bbdb"
+
+DEPEND="bbdb? ( app-emacs/bbdb )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${VM_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-proper-charset.patch"
+
+ if ! use bbdb; then
+ elog "Excluding vm-pcrisis.el since the \"bbdb\" USE flag is not set."
+ epatch "${FILESDIR}/vm-8.0-no-pcrisis.patch"
+ fi
+}
+
+src_compile() {
+ local myconf
+ use bbdb && myconf="--with-other-dirs=${SITELISP}/bbdb"
+ econf --with-emacs="emacs" \
+ --with-pixmapdir="/usr/share/pixmaps/vm" \
+ ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die "emake install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ dodoc NEWS README TODO example.vm || die "dodoc failed"
+}