summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2007-07-03 06:53:41 +0000
committerChristian Faulhammer <opfer@gentoo.org>2007-07-03 06:53:41 +0000
commit578f5617dc5f2a2e4c382cb04124a5a3d4e2ce7c (patch)
tree6489d42717965606b5bfac97b53b256e2af68e3b /app-emacs/wanderlust
parentActually dropped old one. (diff)
downloadgentoo-2-578f5617dc5f2a2e4c382cb04124a5a3d4e2ce7c.tar.gz
gentoo-2-578f5617dc5f2a2e4c382cb04124a5a3d4e2ce7c.tar.bz2
gentoo-2-578f5617dc5f2a2e4c382cb04124a5a3d4e2ce7c.zip
added some die comments; exchanged manual make calls with emake
(Portage version: 2.1.2.9)
Diffstat (limited to 'app-emacs/wanderlust')
-rw-r--r--app-emacs/wanderlust/ChangeLog6
-rw-r--r--app-emacs/wanderlust/wanderlust-2.14.0-r3.ebuild12
2 files changed, 11 insertions, 7 deletions
diff --git a/app-emacs/wanderlust/ChangeLog b/app-emacs/wanderlust/ChangeLog
index 3f885f199d39..b97f3e422c38 100644
--- a/app-emacs/wanderlust/ChangeLog
+++ b/app-emacs/wanderlust/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emacs/wanderlust
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/wanderlust/ChangeLog,v 1.55 2007/05/03 20:19:04 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/wanderlust/ChangeLog,v 1.56 2007/07/03 06:53:41 opfer Exp $
+
+ 03 Jul 2007; Christian Faulhammer <opfer@gentoo.org>
+ wanderlust-2.14.0-r3.ebuild:
+ added some die comments; exchanged manual make calls with emake
03 May 2007; Ulrich Mueller <ulm@gentoo.org> wanderlust-2.10.1-r2.ebuild,
wanderlust-2.12.2.ebuild, wanderlust-2.14.0-r1.ebuild,
diff --git a/app-emacs/wanderlust/wanderlust-2.14.0-r3.ebuild b/app-emacs/wanderlust/wanderlust-2.14.0-r3.ebuild
index 8ba79b68e3ef..2a58864fda85 100644
--- a/app-emacs/wanderlust/wanderlust-2.14.0-r3.ebuild
+++ b/app-emacs/wanderlust/wanderlust-2.14.0-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/wanderlust/wanderlust-2.14.0-r3.ebuild,v 1.3 2007/05/03 20:19:04 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/wanderlust/wanderlust-2.14.0-r3.ebuild,v 1.4 2007/07/03 06:53:41 opfer Exp $
inherit elisp eutils
@@ -34,8 +34,8 @@ src_unpack() {
src_compile() {
use ssl && echo "(setq wl-install-utils t)" >> WL-CFG
- make || die
- make info || die
+ emake || die "emake failed"
+ emake info || die "emake info failed"
if use bbdb; then
cd utils
EMACS="emacs -L ../../elmo -L ../../wl" elisp-comp bbdb-wl.el
@@ -43,13 +43,13 @@ src_compile() {
}
src_install() {
- make \
+ emake \
LISPDIR="${D}/usr/share/emacs/site-lisp" \
PIXMAPDIR="${D}/usr/share/wl/icons" \
- install || die
+ install || die "emake install failed"
elisp-install wl utils/bbdb-wl.{el,elc}
- elisp-site-file-install "${FILESDIR}/70wl-gentoo.el" || die
+ elisp-site-file-install "${FILESDIR}/70wl-gentoo.el" || die "elisp-site-file-install failed"
dodir /usr/share/wl/samples