summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2009-08-28 16:11:04 +0000
committerUlrich Müller <ulm@gentoo.org>2009-08-28 16:11:04 +0000
commitd3159c222a106b186a5786ade70236f20fbdc57e (patch)
treef60bc1486fd3bc55487d3b664b7f3b08682180c7 /app-emacs/yasnippet
parentUpdate dependencies. Add more sanity checks. Improve python_execute_function(). (diff)
downloadgentoo-2-d3159c222a106b186a5786ade70236f20fbdc57e.tar.gz
gentoo-2-d3159c222a106b186a5786ade70236f20fbdc57e.tar.bz2
gentoo-2-d3159c222a106b186a5786ade70236f20fbdc57e.zip
Version bump.
(Portage version: 2.2_rc40/cvs/Linux i686)
Diffstat (limited to 'app-emacs/yasnippet')
-rw-r--r--app-emacs/yasnippet/ChangeLog7
-rw-r--r--app-emacs/yasnippet/files/50yasnippet-gentoo.el3
-rw-r--r--app-emacs/yasnippet/yasnippet-0.6.0c.ebuild47
3 files changed, 53 insertions, 4 deletions
diff --git a/app-emacs/yasnippet/ChangeLog b/app-emacs/yasnippet/ChangeLog
index 658e56e0e8e4..cfc64053d6db 100644
--- a/app-emacs/yasnippet/ChangeLog
+++ b/app-emacs/yasnippet/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emacs/yasnippet
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/yasnippet/ChangeLog,v 1.7 2009/06/03 17:27:18 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/yasnippet/ChangeLog,v 1.8 2009/08/28 16:11:04 ulm Exp $
+
+*yasnippet-0.6.0c (28 Aug 2009)
+
+ 28 Aug 2009; Ulrich Mueller <ulm@gentoo.org> +yasnippet-0.6.0c.ebuild:
+ Version bump.
03 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
-yasnippet-0.5.8.ebuild, -yasnippet-0.5.9.ebuild:
diff --git a/app-emacs/yasnippet/files/50yasnippet-gentoo.el b/app-emacs/yasnippet/files/50yasnippet-gentoo.el
index 5d7f23af726b..d07f448098bd 100644
--- a/app-emacs/yasnippet/files/50yasnippet-gentoo.el
+++ b/app-emacs/yasnippet/files/50yasnippet-gentoo.el
@@ -1,6 +1,3 @@
-
-;;; yasnippet site-lisp configuration
-
(add-to-list 'load-path "@SITELISP@")
(autoload 'yas/initialize "yasnippet" "Do necessary initialization.")
(autoload 'yas/load-directory "yasnippet"
diff --git a/app-emacs/yasnippet/yasnippet-0.6.0c.ebuild b/app-emacs/yasnippet/yasnippet-0.6.0c.ebuild
new file mode 100644
index 000000000000..1d09937d79ed
--- /dev/null
+++ b/app-emacs/yasnippet/yasnippet-0.6.0c.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/yasnippet/yasnippet-0.6.0c.ebuild,v 1.1 2009/08/28 16:11:04 ulm Exp $
+
+inherit elisp
+
+DESCRIPTION="Yet another snippet extension for Emacs"
+HOMEPAGE="http://code.google.com/p/yasnippet/"
+SRC_URI="http://yasnippet.googlecode.com/files/${P}.tar.bz2
+ doc? ( http://yasnippet.googlecode.com/files/${PN}-doc-${PV}.tar.bz2 )"
+
+# Homepage says MIT licence, source contains GPL-2 copyright notice
+LICENSE="MIT GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND=">=app-emacs/dropdown-list-20080316"
+RDEPEND="${DEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_unpack() {
+ elisp_src_unpack
+
+ # remove bundled copy of dropdown-list
+ rm "${S}/dropdown-list.el" || die
+}
+
+src_install() {
+ elisp_src_install
+
+ insinto "${SITEETC}/${PN}"
+ doins -r snippets || die "doins failed"
+
+ if use doc; then
+ dohtml -r "${WORKDIR}"/doc/* || die "dohtml failed"
+ fi
+}
+
+pkg_postinst() {
+ elisp-site-regen
+
+ elog "Please add the following code into your .emacs to use yasnippet:"
+ elog "(yas/initialize)"
+ elog "(yas/load-directory \"${SITEETC}/${PN}/snippets\")"
+}