summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2013-01-15 07:24:42 +0000
committerNaohiro Aota <naota@gentoo.org>2013-01-15 07:24:42 +0000
commit141f50c4605398de877c2e409ef627cd928dcf1f (patch)
treeaf7e60fe59356cf394294a447ce1a842cbcff45d /app-emacs
parentadding ~arm keywords to net-analyzer/metasploit rdeps (diff)
downloadgentoo-2-141f50c4605398de877c2e409ef627cd928dcf1f.tar.gz
gentoo-2-141f50c4605398de877c2e409ef627cd928dcf1f.tar.bz2
gentoo-2-141f50c4605398de877c2e409ef627cd928dcf1f.zip
Drop doc USE flag from <app-emacs/twittering-mode-9999
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key F8551514)
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/twittering-mode/ChangeLog9
-rw-r--r--app-emacs/twittering-mode/twittering-mode-2.0.0.ebuild17
-rw-r--r--app-emacs/twittering-mode/twittering-mode-9999.ebuild11
3 files changed, 18 insertions, 19 deletions
diff --git a/app-emacs/twittering-mode/ChangeLog b/app-emacs/twittering-mode/ChangeLog
index 69c1fb48f5c2..42a6c379c281 100644
--- a/app-emacs/twittering-mode/ChangeLog
+++ b/app-emacs/twittering-mode/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emacs/twittering-mode
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/twittering-mode/ChangeLog,v 1.2 2012/03/13 14:47:58 naota Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/twittering-mode/ChangeLog,v 1.3 2013/01/15 07:24:42 naota Exp $
+
+ 15 Jan 2013; Naohiro Aota <naota@gentoo.org> twittering-mode-2.0.0.ebuild,
+ twittering-mode-9999.ebuild:
+ Drop doc USE flag from <app-emacs/twittering-mode-9999
13 Mar 2012; Naohiro Aota <naota@gentoo.org>
-files/twittering-mode-9999-proxy-test.patch, twittering-mode-9999.ebuild:
@@ -14,4 +18,3 @@
+metadata.xml:
New ebuild app-emacs/twittering-mode written by me. Emacs major mode for
Twitter.
-
diff --git a/app-emacs/twittering-mode/twittering-mode-2.0.0.ebuild b/app-emacs/twittering-mode/twittering-mode-2.0.0.ebuild
index 553404b629b3..54de96a8daf3 100644
--- a/app-emacs/twittering-mode/twittering-mode-2.0.0.ebuild
+++ b/app-emacs/twittering-mode/twittering-mode-2.0.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/twittering-mode/twittering-mode-2.0.0.ebuild,v 1.1 2011/05/07 09:05:23 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/twittering-mode/twittering-mode-2.0.0.ebuild,v 1.2 2013/01/15 07:24:42 naota Exp $
EAPI=4
@@ -11,10 +11,12 @@ if [ "${PV}" = "9999" ]; then
inherit git-2
SRC_URI=""
KEYWORDS=""
+ IUSE="doc"
else
SRC_URI="mirror://sourceforge/twmode/${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
RESTRICT="test"
+ IUSE=""
fi
DESCRIPTION="Emacs major mode for Twitter."
@@ -22,20 +24,13 @@ HOMEPAGE="http://twmode.sourceforge.net/"
LICENSE="GPL-2"
SLOT="0"
-IUSE="doc"
DEPEND=""
RDEPEND="app-crypt/gnupg"
-src_prepare() {
- if [ "${PV}" = "9999" ]; then
- epatch "${FILESDIR}"/${P}-proxy-test.patch
- fi
-}
-
src_compile() {
elisp-compile twittering-mode.el || die
- use doc && emake -C doc/manual
+ [ "${PV}" = "9999" ] && use doc && emake -C doc/manual
}
src_test() {
@@ -43,6 +38,6 @@ src_test() {
}
src_install() {
- use doc && dodoc doc/manual/twmode/twmode.html
+ [ "${PV}" = "9999" ] && use doc && dodoc doc/manual/twmode/twmode.html
elisp-install ${PN} twittering-mode.el *.elc || die
}
diff --git a/app-emacs/twittering-mode/twittering-mode-9999.ebuild b/app-emacs/twittering-mode/twittering-mode-9999.ebuild
index dbb54fb91da8..3b8bd4772a65 100644
--- a/app-emacs/twittering-mode/twittering-mode-9999.ebuild
+++ b/app-emacs/twittering-mode/twittering-mode-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/twittering-mode/twittering-mode-9999.ebuild,v 1.2 2012/03/13 14:47:58 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/twittering-mode/twittering-mode-9999.ebuild,v 1.3 2013/01/15 07:24:42 naota Exp $
EAPI=4
@@ -11,10 +11,12 @@ if [ "${PV}" = "9999" ]; then
inherit git-2
SRC_URI=""
KEYWORDS=""
+ IUSE="doc"
else
SRC_URI="mirror://sourceforge/twmode/${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
RESTRICT="test"
+ IUSE=""
fi
DESCRIPTION="Emacs major mode for Twitter."
@@ -22,14 +24,13 @@ HOMEPAGE="http://twmode.sourceforge.net/"
LICENSE="GPL-2"
SLOT="0"
-IUSE="doc"
DEPEND=""
RDEPEND="app-crypt/gnupg"
src_compile() {
elisp-compile twittering-mode.el || die
- use doc && emake -C doc/manual
+ [ "${PV}" = "9999" ] && use doc && emake -C doc/manual
}
src_test() {
@@ -37,6 +38,6 @@ src_test() {
}
src_install() {
- use doc && dodoc doc/manual/twmode/twmode.html
+ [ "${PV}" = "9999" ] && use doc && dodoc doc/manual/twmode/twmode.html
elisp-install ${PN} twittering-mode.el *.elc || die
}