summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2011-03-29 16:16:05 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2011-03-29 16:16:05 +0000
commit609d7ab01474adfa2e022251289d4e9e9f759dac (patch)
treece6a00f5ee2aa40d9d5a41dfdd517029b3de12e5 /app-emacs
parentStable on amd64 wrt bug #361125 (diff)
downloadgentoo-2-609d7ab01474adfa2e022251289d4e9e9f759dac.tar.gz
gentoo-2-609d7ab01474adfa2e022251289d4e9e9f759dac.tar.bz2
gentoo-2-609d7ab01474adfa2e022251289d4e9e9f759dac.zip
Version bumped.
(Portage version: 2.1.9.44/cvs/Linux x86_64)
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/navi2ch/ChangeLog9
-rw-r--r--app-emacs/navi2ch/navi2ch-1.8.4.ebuild51
2 files changed, 58 insertions, 2 deletions
diff --git a/app-emacs/navi2ch/ChangeLog b/app-emacs/navi2ch/ChangeLog
index 17da3c2f2731..16fe6592cd01 100644
--- a/app-emacs/navi2ch/ChangeLog
+++ b/app-emacs/navi2ch/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emacs/navi2ch
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/navi2ch/ChangeLog,v 1.66 2010/05/23 19:56:07 ulm Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/navi2ch/ChangeLog,v 1.67 2011/03/29 16:16:05 matsuu Exp $
+
+*navi2ch-1.8.4 (29 Mar 2011)
+
+ 29 Mar 2011; MATSUU Takuto <matsuu@gentoo.org> +navi2ch-1.8.4.ebuild:
+ Version bumped.
23 May 2010; Ulrich Mueller <ulm@gentoo.org> -navi2ch-1.8.3.ebuild:
Remove old.
diff --git a/app-emacs/navi2ch/navi2ch-1.8.4.ebuild b/app-emacs/navi2ch/navi2ch-1.8.4.ebuild
new file mode 100644
index 000000000000..4937b90d642e
--- /dev/null
+++ b/app-emacs/navi2ch/navi2ch-1.8.4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/navi2ch/navi2ch-1.8.4.ebuild,v 1.1 2011/03/29 16:16:04 matsuu Exp $
+
+EAPI=3
+
+inherit elisp
+
+DESCRIPTION="A navigator for 2ch"
+HOMEPAGE="http://navi2ch.sourceforge.net/"
+SRC_URI="mirror://sourceforge/navi2ch/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_configure() {
+ econf \
+ --with-lispdir="${EPREFIX}${SITELISP}/${PN}" \
+ --with-icondir="${EPREFIX}${SITEETC}/${PN}"
+}
+
+# This is NOT redundant, elisp.eclass redefines src_compile
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ elisp-install ${PN} contrib/*.el || die
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ dodoc ChangeLog* NEWS README TODO || die
+ newdoc contrib/README README.contrib || die
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ elog
+ elog "Please add to your ~/.emacs"
+ elog "If you use mona-font,"
+ elog "\t(setq navi2ch-mona-enable t)"
+ elog "If you use izonmoji-mode,"
+ elog "\t(require 'izonmoji-mode)"
+ elog "\t(add-hook 'navi2ch-bm-mode-hook 'izonmoji-mode-on)"
+ elog "\t(add-hook 'navi2ch-article-mode-hook 'izonmoji-mode-on)"
+ elog "\t(add-hook 'navi2ch-popup-article-mode-hook 'izonmoji-mode-on)"
+ elog
+}