summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-07-25 18:35:39 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-07-25 18:35:39 +0000
commit633f1268c9936492a73b68579e74695d000aa224 (patch)
treecc218e224358931a299215ecfb8d24a77db21e12 /app-emacs
parentmedia-libs/freeverb3: Bump to 2.5.5 (diff)
downloadgentoo-2-633f1268c9936492a73b68579e74695d000aa224.tar.gz
gentoo-2-633f1268c9936492a73b68579e74695d000aa224.tar.bz2
gentoo-2-633f1268c9936492a73b68579e74695d000aa224.zip
Bump to latest version.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/nxml-libvirt-schemas/ChangeLog10
-rw-r--r--app-emacs/nxml-libvirt-schemas/nxml-libvirt-schemas-0.8.2.ebuild67
2 files changed, 75 insertions, 2 deletions
diff --git a/app-emacs/nxml-libvirt-schemas/ChangeLog b/app-emacs/nxml-libvirt-schemas/ChangeLog
index 2e6cd172a30e..fe6621b57a7a 100644
--- a/app-emacs/nxml-libvirt-schemas/ChangeLog
+++ b/app-emacs/nxml-libvirt-schemas/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emacs/nxml-libvirt-schemas
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/nxml-libvirt-schemas/ChangeLog,v 1.1 2009/12/16 19:12:59 flameeyes Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/nxml-libvirt-schemas/ChangeLog,v 1.2 2010/07/25 18:35:39 flameeyes Exp $
+
+*nxml-libvirt-schemas-0.8.2 (25 Jul 2010)
+
+ 25 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ +nxml-libvirt-schemas-0.8.2.ebuild:
+ Bump to latest version.
*nxml-libvirt-schemas-0.7.4 (16 Dec 2009)
diff --git a/app-emacs/nxml-libvirt-schemas/nxml-libvirt-schemas-0.8.2.ebuild b/app-emacs/nxml-libvirt-schemas/nxml-libvirt-schemas-0.8.2.ebuild
new file mode 100644
index 000000000000..3fff0c25b418
--- /dev/null
+++ b/app-emacs/nxml-libvirt-schemas/nxml-libvirt-schemas-0.8.2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/nxml-libvirt-schemas/nxml-libvirt-schemas-0.8.2.ebuild,v 1.1 2010/07/25 18:35:39 flameeyes Exp $
+
+BACKPORTS=
+
+EAPI=2
+
+inherit elisp eutils
+
+MY_P="libvirt-${PV}"
+
+DESCRIPTION="Extension for nxml-mode with libvirt schemas"
+HOMEPAGE="http://www.libvirt.org/"
+
+SRC_URI="http://libvirt.org/sources/${MY_P}.tar.gz
+ ${BACKPORTS:+mirror://gentoo/${MY_P}-backports-${BACKPORTS}.tar.bz2}"
+
+# This is the license of the package, but the schema files are
+# provided without license, maybe it's bad.
+LICENSE="LGPL-2.1"
+
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="|| ( >=app-emacs/nxml-mode-20041004-r3 >=virtual/emacs-23 )"
+
+# Yes this requires Java, but I'd rather not repackage this, if you
+# know something better in C, I'll be glad to use that.
+DEPEND="app-text/trang"
+
+SITEFILE=60${PN}-gentoo.el
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ [[ -d "${WORKDIR}/patches" ]] && \
+ EPATCH_SUFFIX="patch" EPATCH_FORCE="yes" EPATCH_SOURCE="${WORKDIR}/patches" epatch
+}
+
+src_compile() {
+ emake -C docs/schemas -f "${FILESDIR}/Makefile-trang" || die "trang failed"
+}
+
+src_test() {
+ # No we don't need tests here… trang will take care of checking
+ # the well-formedness of the schema files for us
+ :
+}
+
+src_install() {
+ insinto ${SITEETC}/${PN}
+ doins "${FILESDIR}/schemas.xml" docs/schemas/*.rnc || die "install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+}
+
+pkg_postinst () {
+ elisp-site-regen
+
+ if [ $(emacs -batch -q --eval "(princ (fboundp 'nxml-mode))") = nil ]; then
+ ewarn "This package needs nxml-mode. You should either install"
+ ewarn "app-emacs/nxml-mode, or use \"eselect emacs\" to select"
+ ewarn "an Emacs version >= 23."
+ fi
+} \ No newline at end of file