summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2003-02-09 11:29:59 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2003-02-09 11:29:59 +0000
commit6bddc361048d8ca3bf89910e825b60f7bf12ec60 (patch)
tree45d81f1a02a79429962e3418c55b3636129e03b2 /app-emacs
parentVersion bump to latest stable. resolves bug #13177 (diff)
downloadgentoo-2-6bddc361048d8ca3bf89910e825b60f7bf12ec60.tar.gz
gentoo-2-6bddc361048d8ca3bf89910e825b60f7bf12ec60.tar.bz2
gentoo-2-6bddc361048d8ca3bf89910e825b60f7bf12ec60.zip
resolves bug 13156 (~ keywords for now)
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/haskell-mode/ChangeLog13
-rw-r--r--app-emacs/haskell-mode/files/50haskell-mode-gentoo.el19
-rw-r--r--app-emacs/haskell-mode/files/digest-haskell-mode-1.441
-rw-r--r--app-emacs/haskell-mode/haskell-mode-1.44.ebuild39
4 files changed, 72 insertions, 0 deletions
diff --git a/app-emacs/haskell-mode/ChangeLog b/app-emacs/haskell-mode/ChangeLog
new file mode 100644
index 000000000000..ca25f634c143
--- /dev/null
+++ b/app-emacs/haskell-mode/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for app-emacs/haskell-mode
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/haskell-mode/ChangeLog,v 1.1 2003/02/09 11:29:59 mkennedy Exp $
+
+*haskell-mode (09 Feb 2003)
+
+ 09 Feb 2003; Matthew Kennedy <mkennedy@gentoo.org> ChangeLog,
+ haskell-mode-1.44.ebuild, files/50haskell-mode-gentoo.el,
+ files/digest-haskell-mode-1.44 :
+
+ Initial import. Ebuild contributed by Peter Simons
+ <simons+gentoo@cryp.to> of bug #13156 (polished up by
+ <mkennedy@gentoo.org>)
diff --git a/app-emacs/haskell-mode/files/50haskell-mode-gentoo.el b/app-emacs/haskell-mode/files/50haskell-mode-gentoo.el
new file mode 100644
index 000000000000..861eef194c81
--- /dev/null
+++ b/app-emacs/haskell-mode/files/50haskell-mode-gentoo.el
@@ -0,0 +1,19 @@
+
+;;; uboat site-lisp configuration
+
+(setq load-path (cons "@SITELISP@" load-path))
+(setq auto-mode-alist
+ (append auto-mode-alist
+ '(("\\.[hg]s$" . haskell-mode)
+ ("\\.hi$" . haskell-mode)
+ ("\\.l[hg]s$" . literate-haskell-mode))))
+(autoload 'haskell-mode "haskell-mode"
+ "Major mode for editing Haskell scripts." t)
+(autoload 'literate-haskell-mode "haskell-mode"
+ "Major mode for editing literate Haskell scripts." t)
+(add-hook 'haskell-mode-hook 'turn-on-haskell-font-lock)
+(add-hook 'haskell-mode-hook 'turn-on-haskell-decl-scan)
+(add-hook 'haskell-mode-hook 'turn-on-haskell-doc-mode)
+(add-hook 'haskell-mode-hook 'turn-on-haskell-indent)
+(add-hook 'haskell-mode-hook 'turn-on-haskell-simple-indent)
+(add-hook 'haskell-mode-hook 'turn-on-haskell-hugs)
diff --git a/app-emacs/haskell-mode/files/digest-haskell-mode-1.44 b/app-emacs/haskell-mode/files/digest-haskell-mode-1.44
new file mode 100644
index 000000000000..33cfd29bfc92
--- /dev/null
+++ b/app-emacs/haskell-mode/files/digest-haskell-mode-1.44
@@ -0,0 +1 @@
+MD5 8317d8bf8588e254e753977e48ad3bf6 haskell-mode-1.44.tar.gz 58601
diff --git a/app-emacs/haskell-mode/haskell-mode-1.44.ebuild b/app-emacs/haskell-mode/haskell-mode-1.44.ebuild
new file mode 100644
index 000000000000..c5139c98fea1
--- /dev/null
+++ b/app-emacs/haskell-mode/haskell-mode-1.44.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/haskell-mode/haskell-mode-1.44.ebuild,v 1.1 2003/02/09 11:29:59 mkennedy Exp $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="Mode for editing (and running) Haskell programs in Emacs"
+HOMEPAGE="http://www.haskell.org/haskell-mode/"
+SRC_URI="http://www.haskell.org/haskell-mode/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="virtual/emacs"
+RDEPEND="${DEPEND}"
+S="${WORKDIR}/${P}"
+
+SITEFILE=50haskell-mode-gentoo.el
+
+src_compile() {
+ emacs --batch -f batch-byte-compile --no-site-file --no-init-file *.el
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+ dohtml *.html *.hs
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ einfo "See /usr/share/doc/${P}/html/installation-guide.html"
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}