summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2008-02-08 14:01:22 +0000
committerUlrich Müller <ulm@gentoo.org>2008-02-08 14:01:22 +0000
commit7cc34744cfe12b831533b96de8cb87ca4d42ebfa (patch)
treea7886ca98a8170f2f09ce788aa4434cf5dd14918 /app-emacs
parentStable for HPPA (bug #209293). (diff)
downloadgentoo-2-7cc34744cfe12b831533b96de8cb87ca4d42ebfa.tar.gz
gentoo-2-7cc34744cfe12b831533b96de8cb87ca4d42ebfa.tar.bz2
gentoo-2-7cc34744cfe12b831533b96de8cb87ca4d42ebfa.zip
Version bump.
(Portage version: 2.1.4.1)
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/pymacs/ChangeLog11
-rw-r--r--app-emacs/pymacs/files/0.23_beta5-fix-pytest-nonascii.patch11
-rw-r--r--app-emacs/pymacs/files/50pymacs-gentoo.el2
-rw-r--r--app-emacs/pymacs/pymacs-0.23_beta5.ebuild36
4 files changed, 57 insertions, 3 deletions
diff --git a/app-emacs/pymacs/ChangeLog b/app-emacs/pymacs/ChangeLog
index dd928338b2f4..758cc53dad96 100644
--- a/app-emacs/pymacs/ChangeLog
+++ b/app-emacs/pymacs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emacs/pymacs
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/pymacs/ChangeLog,v 1.21 2007/07/26 18:30:21 corsair Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/pymacs/ChangeLog,v 1.22 2008/02/08 14:01:22 ulm Exp $
+
+*pymacs-0.23_beta5 (08 Feb 2008)
+
+ 08 Feb 2008; Ulrich Mueller <ulm@gentoo.org>
+ +files/0.23_beta5-fix-pytest-nonascii.patch, files/50pymacs-gentoo.el,
+ +pymacs-0.23_beta5.ebuild:
+ Version bump. Beta release without manual and doesn't install contribs.
26 Jul 2007; Markus Rothe <corsair@gentoo.org> pymacs-0.22-r1.ebuild:
Added ~ppc64; bug #186188
diff --git a/app-emacs/pymacs/files/0.23_beta5-fix-pytest-nonascii.patch b/app-emacs/pymacs/files/0.23_beta5-fix-pytest-nonascii.patch
new file mode 100644
index 000000000000..b68c6ec078c6
--- /dev/null
+++ b/app-emacs/pymacs/files/0.23_beta5-fix-pytest-nonascii.patch
@@ -0,0 +1,11 @@
+--- Pymacs-0.23-beta5-orig/tests/pytest 2008-02-07 19:21:08.000000000 +0100
++++ Pymacs-0.23-beta5/tests/pytest 2008-02-08 13:58:23.000000000 +0100
+@@ -391,7 +391,7 @@
+ text = self.identifier + u' '
+ write(text)
+ self.column = len(text)
+- write(u'E·'[succes])
++ write(u'E.'[succes])
+ self.column += 1
+ self.counter += 1
+
diff --git a/app-emacs/pymacs/files/50pymacs-gentoo.el b/app-emacs/pymacs/files/50pymacs-gentoo.el
index 951e6ee5935c..df3fa3131814 100644
--- a/app-emacs/pymacs/files/50pymacs-gentoo.el
+++ b/app-emacs/pymacs/files/50pymacs-gentoo.el
@@ -1,5 +1,5 @@
-;;; emacs site-lisp configuration for pymacs
+;;; pymacs site-lisp configuration
(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/pymacs/pymacs-0.23_beta5.ebuild b/app-emacs/pymacs/pymacs-0.23_beta5.ebuild
new file mode 100644
index 000000000000..318dfeed9ca6
--- /dev/null
+++ b/app-emacs/pymacs/pymacs-0.23_beta5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/pymacs/pymacs-0.23_beta5.ebuild,v 1.1 2008/02/08 14:01:22 ulm Exp $
+
+inherit distutils elisp eutils versionator
+
+MY_P=Pymacs-$(replace_version_separator 2 -)
+DESCRIPTION="A tool that allows both-side communication beetween Python and Emacs-lisp"
+HOMEPAGE="http://pymacs.progiciels-bpi.ca/"
+SRC_URI="http://pymacs.progiciels-bpi.ca/archives/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~x86 ~x86-fbsd"
+IUSE=""
+
+SITEFILE=50${PN}-gentoo.el
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PV}-fix-pytest-nonascii.patch
+}
+
+src_compile() {
+ emake || die "emake failed"
+ elisp-compile pymacs.el || die "elisp-compile failed"
+}
+
+src_install() {
+ elisp_src_install
+ distutils_src_install
+ dodoc THANKS
+}