summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2003-02-03 03:43:29 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2003-02-03 03:43:29 +0000
commitbec634b16705f7632a936a8d022ac05a88d033f4 (patch)
tree38d9424e02d296adbd0c498e1d6838a9344297c6 /app-emacs
parentadd a new patch for xchat-2 to have tabs on left and right, merge the GTK ico... (diff)
downloadgentoo-2-bec634b16705f7632a936a8d022ac05a88d033f4.tar.gz
gentoo-2-bec634b16705f7632a936a8d022ac05a88d033f4.tar.bz2
gentoo-2-bec634b16705f7632a936a8d022ac05a88d033f4.zip
minor version bump, but ~86'd because of the release freeze
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/ecb/ChangeLog10
-rw-r--r--app-emacs/ecb/ecb-1.90.ebuild58
-rw-r--r--app-emacs/ecb/files/digest-ecb-1.901
-rw-r--r--app-emacs/ecb/files/ecb-1.90-gentoo.patch45
4 files changed, 113 insertions, 1 deletions
diff --git a/app-emacs/ecb/ChangeLog b/app-emacs/ecb/ChangeLog
index a6291a82efa1..82e4881853c6 100644
--- a/app-emacs/ecb/ChangeLog
+++ b/app-emacs/ecb/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-emacs/ecb
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/ecb/ChangeLog,v 1.1 2002/11/01 02:52:01 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/ecb/ChangeLog,v 1.2 2003/02/03 03:43:29 mkennedy Exp $
+
+*ecb-1.90 (31 Jan 2003)
+
+ 1 Jan 2003; Matthew Kennedy <mkennedy@gentoo.org> ChangeLog,
+ ecb-1.90.ebuild, files/50ecb-gentoo.el, files/ecb-1.9-gentoo.patch,
+ files/digest-ecb-1.80 :
+
+ Minor version bump.
*ecb-1.80 (31 Oct 2002)
diff --git a/app-emacs/ecb/ecb-1.90.ebuild b/app-emacs/ecb/ecb-1.90.ebuild
new file mode 100644
index 000000000000..f33bccb0b967
--- /dev/null
+++ b/app-emacs/ecb/ecb-1.90.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/ecb/ecb-1.90.ebuild,v 1.1 2003/02/03 03:43:29 mkennedy Exp $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="ECB is source code browser for Emacs. It is a global minor-mode which displays a couple of windows that can be used to browse directories, files and methods. It supports method parsing for Java, C, C++, Elisp etc."
+HOMEPAGE="http://home.swipnet.se/mayhem/ecb.html"
+SRC_URI="mirror://sourceforge/ecb/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="virtual/emacs
+ app-emacs/speedbar
+ app-emacs/eieio
+ app-emacs/jde
+ app-emacs/elib"
+
+S="${WORKDIR}/${P}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S} && patch -p1 <${FILESDIR}/${P}-gentoo.patch || die
+ sed -e "s,@ECB_INFO@,/usr/share/info/ecb.info.gz,g" <ecb-help.el >ecb-help.el.new && \
+ mv ecb-help.el.new ecb-help.el
+ sed -e "s,@ECB_HTML@,/usr/share/doc/${P}/html/ecb.html,g" <ecb-help.el >ecb-help.el.new && \
+ mv ecb-help.el.new ecb-help.el
+}
+
+src_compile() {
+ make LOADPATH="${SITELISP}/elib ${SITELISP}/semantic ${SITELISP}/eieio ${SITELISP}/jde/lisp" || die
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install ${FILESDIR}/50ecb-gentoo.el
+ dodoc HISTORY README RELEASE_NOTES
+ makeinfo --force ecb.texi
+ doinfo ecb.info*
+ dohtml ecb.html
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ einfo ""
+ einfo "Add the following to your ~/.emacs to use ECB:"
+ einfo " (require 'ecb)"
+ einfo "To start ECB:"
+ einfo " M-x ecb-activate"
+ einfo ""
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}
diff --git a/app-emacs/ecb/files/digest-ecb-1.90 b/app-emacs/ecb/files/digest-ecb-1.90
new file mode 100644
index 000000000000..4447232d4c77
--- /dev/null
+++ b/app-emacs/ecb/files/digest-ecb-1.90
@@ -0,0 +1 @@
+MD5 7c0e8f5afe0bf7ab9c0cbda43de55e9f ecb-1.90.tar.gz 362425
diff --git a/app-emacs/ecb/files/ecb-1.90-gentoo.patch b/app-emacs/ecb/files/ecb-1.90-gentoo.patch
new file mode 100644
index 000000000000..50320b5cb470
--- /dev/null
+++ b/app-emacs/ecb/files/ecb-1.90-gentoo.patch
@@ -0,0 +1,45 @@
+diff -ur ecb-1.90/ecb-help.el ecb-1.90~/ecb-help.el
+--- ecb-1.90/ecb-help.el 2003-01-31 07:51:15.000000000 -0600
++++ ecb-1.90~/ecb-help.el 2003-01-31 19:55:44.000000000 -0600
+@@ -67,16 +67,7 @@
+ (const :tag "Html" :value html)))
+
+
+-(defcustom ecb-help-info-path (concat
+- (if ecb-running-xemacs
+- (if (file-exists-p
+- (concat ecb-ecb-dir
+- ecb-help-info-subdir
+- ecb-help-info-start-file))
+- ecb-help-info-subdir
+- "../../info/")
+- ecb-help-info-subdir)
+- ecb-help-info-start-file)
++(defcustom ecb-help-info-path "@ECB_INFO@"
+ "*Path where the ECB online help in info format resides.
+ This must be the location of the file \"ecb.info\" which comes with the ECB
+ distribution. If is installed by unpacking the archive available on the ECB
+@@ -92,22 +83,7 @@
+ :group 'ecb-help
+ :type 'file)
+
+-(defcustom ecb-help-html-path (concat
+- (if ecb-running-xemacs
+- (cond ((file-exists-p
+- (concat ecb-ecb-dir
+- ecb-help-html-subdir
+- ecb-help-html-start-file))
+- ecb-help-html-subdir)
+- ((file-exists-p
+- (concat ecb-ecb-dir
+- "../../html/"
+- ecb-help-html-start-file))
+- "../../html/")
+- (t
+- "../../etc/ecb/html/"))
+- ecb-help-html-subdir)
+- ecb-help-html-start-file)
++(defcustom ecb-help-html-path "@ECB_HTML@"
+ "*Path where the ECB online help in HTML format resides.
+ This must be the location of the file \"index.html\" which comes with the ECB
+ distribution. If is installed by unpacking the archive available on the ECB