summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2003-03-24 11:31:07 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2003-03-24 11:31:07 +0000
commitfaf9f7f29c7803bc9e3410c3f26ce5cccd60dfa2 (patch)
treeebb3413008a26d97becf5e0d02b5aecf6b555a66 /app-emacs
parentUnmask (diff)
downloadgentoo-2-faf9f7f29c7803bc9e3410c3f26ce5cccd60dfa2.tar.gz
gentoo-2-faf9f7f29c7803bc9e3410c3f26ce5cccd60dfa2.tar.bz2
gentoo-2-faf9f7f29c7803bc9e3410c3f26ce5cccd60dfa2.zip
minor fix to -gentoo.el
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/htmlize/ChangeLog6
-rw-r--r--app-emacs/htmlize/files/50htmlize-gentoo.el6
-rw-r--r--app-emacs/htmlize/htmlize-0.67.ebuild4
3 files changed, 10 insertions, 6 deletions
diff --git a/app-emacs/htmlize/ChangeLog b/app-emacs/htmlize/ChangeLog
index f58fa9733ddb..b7808d9d9192 100644
--- a/app-emacs/htmlize/ChangeLog
+++ b/app-emacs/htmlize/ChangeLog
@@ -1,9 +1,13 @@
# ChangeLog for app-emacs/htmlize
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/htmlize/ChangeLog,v 1.2 2003/02/12 03:53:49 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/htmlize/ChangeLog,v 1.3 2003/03/24 11:31:07 mkennedy Exp $
*htmlize-0.67 (31 Oct 2002)
+ 24 Mar 2003; Matthew Kennedy <mkennedy@gentoo.org> htmlize-0.67.ebuild,
+ files/50htmlize-gentoo.el:
+ fix to -gentoo.el
+
31 Oct 2002; Matthew Kennedy <mkennedy@gentoo.org> ChangeLog,
htmlize-0.67.ebuild, files/50htmlize-gentoo.el,
files/digest-htmlize-0.67 :
diff --git a/app-emacs/htmlize/files/50htmlize-gentoo.el b/app-emacs/htmlize/files/50htmlize-gentoo.el
index 330c5c134259..ba92740d245d 100644
--- a/app-emacs/htmlize/files/50htmlize-gentoo.el
+++ b/app-emacs/htmlize/files/50htmlize-gentoo.el
@@ -1,7 +1,5 @@
;;; htmlize site-lisp configuration
-(setq load-path (cons "@SITELISP@" load-path))
-(autoload 'htmlize-file "htmlize"
-htmlize-many-files
-htmlize-many-files-dired \ No newline at end of file
+(add-to-list 'load-path "@SITELISP@")
+(require 'htmlize)
diff --git a/app-emacs/htmlize/htmlize-0.67.ebuild b/app-emacs/htmlize/htmlize-0.67.ebuild
index cd0353f2a1fb..7588a2e373ac 100644
--- a/app-emacs/htmlize/htmlize-0.67.ebuild
+++ b/app-emacs/htmlize/htmlize-0.67.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/htmlize/htmlize-0.67.ebuild,v 1.2 2003/02/13 07:06:19 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/htmlize/htmlize-0.67.ebuild,v 1.3 2003/03/24 11:31:07 mkennedy Exp $
inherit elisp
@@ -19,6 +19,8 @@ S="${WORKDIR}/${P}"
SITEFILE=50htmlize-gentoo.el
+# NOTE: this version of htmlize may have issues with emacs-cvs
+
src_compile() {
emacs --batch -f batch-byte-compile --no-site-file --no-init-file *.el
}