summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2009-10-26 13:46:53 +0000
committerChristian Faulhammer <fauli@gentoo.org>2009-10-26 13:46:53 +0000
commitff53d2a86c1a66a516c16b59fec55d1f2fd49e21 (patch)
tree1387dccbf52b0777bc0e368fe6d2fcbb6042854c /app-emacs
parentKeywording for ppc. (diff)
downloadgentoo-2-ff53d2a86c1a66a516c16b59fec55d1f2fd49e21.tar.gz
gentoo-2-ff53d2a86c1a66a516c16b59fec55d1f2fd49e21.tar.bz2
gentoo-2-ff53d2a86c1a66a516c16b59fec55d1f2fd49e21.zip
version bump
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/org-mode/ChangeLog8
-rw-r--r--app-emacs/org-mode/org-mode-6.32.ebuild39
2 files changed, 46 insertions, 1 deletions
diff --git a/app-emacs/org-mode/ChangeLog b/app-emacs/org-mode/ChangeLog
index efb1f45f08f6..55bd4e0ec71a 100644
--- a/app-emacs/org-mode/ChangeLog
+++ b/app-emacs/org-mode/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emacs/org-mode
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/org-mode/ChangeLog,v 1.81 2009/10/03 20:11:56 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/org-mode/ChangeLog,v 1.82 2009/10/26 13:46:53 fauli Exp $
+
+*org-mode-6.32 (26 Oct 2009)
+
+ 26 Oct 2009; Christian Faulhammer <fauli@gentoo.org>
+ +org-mode-6.32.ebuild:
+ version bump
03 Oct 2009; Christian Faulhammer <fauli@gentoo.org>
-org-mode-6.30.ebuild:
diff --git a/app-emacs/org-mode/org-mode-6.32.ebuild b/app-emacs/org-mode/org-mode-6.32.ebuild
new file mode 100644
index 000000000000..9ad72d83f286
--- /dev/null
+++ b/app-emacs/org-mode/org-mode-6.32.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/org-mode/org-mode-6.32.ebuild,v 1.1 2009/10/26 13:46:53 fauli Exp $
+
+inherit elisp
+
+DESCRIPTION="An Emacs mode for notes and project planning"
+HOMEPAGE="http://www.orgmode.org/"
+SRC_URI="http://orgmode.org/org-${PV}.tar.gz"
+
+LICENSE="GPL-3 FDL-1.3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+
+S="${WORKDIR}/org-${PV}"
+SITEFILE="51${PN}-gentoo.el"
+
+src_compile() {
+ # remove autoload file to make sure that it is regenerated with
+ # the right Emacs version
+ rm -f lisp/org-install.el
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake \
+ prefix="${D}/usr" \
+ lispdir="${D}${SITELISP}/${PN}" \
+ infodir="${D}/usr/share/info" \
+ install || die "emake install failed"
+
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+
+ mv doc/org doc/org.info
+ doinfo doc/org.info || die "doinfo failed"
+ dodoc README ChangeLog Changes.org doc/org.pdf doc/orgcard.pdf \
+ || die "dodoc failed"
+}