summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-31 02:12:18 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-31 02:12:18 +0000
commit4ba1ff01d1332552fb948ffbe92a877e74bacfc9 (patch)
tree449c8ab8df0de8f9e34da19cb0fd491f2948f552 /app-emulation/XWine
parentAnother commit for the QA. (Manifest recommit) (diff)
downloadgentoo-2-4ba1ff01d1332552fb948ffbe92a877e74bacfc9.tar.gz
gentoo-2-4ba1ff01d1332552fb948ffbe92a877e74bacfc9.tar.bz2
gentoo-2-4ba1ff01d1332552fb948ffbe92a877e74bacfc9.zip
Fix wine detection bug #67008 by Schrangl Lukas.
Diffstat (limited to 'app-emulation/XWine')
-rw-r--r--app-emulation/XWine/ChangeLog9
-rw-r--r--app-emulation/XWine/XWine-0.3.2-r1.ebuild44
-rw-r--r--app-emulation/XWine/files/0.3.2-missing-paren.patch11
-rw-r--r--app-emulation/XWine/files/0.3.2-wine-update.patch16
-rw-r--r--app-emulation/XWine/files/digest-XWine-0.3.2-r11
5 files changed, 80 insertions, 1 deletions
diff --git a/app-emulation/XWine/ChangeLog b/app-emulation/XWine/ChangeLog
index 310fc47a0a1e..896b8f98f679 100644
--- a/app-emulation/XWine/ChangeLog
+++ b/app-emulation/XWine/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emulation/XWine
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/XWine/ChangeLog,v 1.11 2004/06/24 22:37:59 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/XWine/ChangeLog,v 1.12 2004/10/31 02:12:18 vapier Exp $
+
+*XWine-0.3.2-r1 (30 Oct 2004)
+
+ 30 Oct 2004; Mike Frysinger <vapier@gentoo.org>
+ +files/0.3.2-missing-paren.patch, +files/0.3.2-wine-update.patch,
+ +XWine-0.3.2-r1.ebuild:
+ Fix wine detection bug #67008 by Schrangl Lukas.
20 Nov 2003; Alex Veber <coronalvr@gentoo.org> XWine-0.3.2.ebuild:
fix for
diff --git a/app-emulation/XWine/XWine-0.3.2-r1.ebuild b/app-emulation/XWine/XWine-0.3.2-r1.ebuild
new file mode 100644
index 000000000000..9654b82da016
--- /dev/null
+++ b/app-emulation/XWine/XWine-0.3.2-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/XWine/XWine-0.3.2-r1.ebuild,v 1.1 2004/10/31 02:12:18 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="GTK+ frontend for Wine"
+HOMEPAGE="http://darken33.free.fr/"
+SRC_URI="http://darken33.free.fr/logiciels/${P}_en.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="nls"
+
+DEPEND="=x11-libs/gtk+-1*
+ sys-devel/bison
+ >=gnome-base/gnome-libs-1.4.2
+ =gnome-base/orbit-0*
+ nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/${P}_en
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-wine-update.patch
+ epatch ${FILESDIR}/${PV}-missing-paren.patch
+ make distclean || die "distclean"
+ sed -i \
+ -e 's: /usr/share/: $(DESTDIR)/usr/share/:g' \
+ -e "s:/doc/\$(PACKAGE):/doc/${PF}:g" \
+ Makefile.in || die
+}
+
+src_compile() {
+ econf $(use_enable nls) || die
+ emake || die
+}
+
+src_install() {
+ dodir /usr/share/applications
+ make install DESTDIR="${D}" || die
+}
diff --git a/app-emulation/XWine/files/0.3.2-missing-paren.patch b/app-emulation/XWine/files/0.3.2-missing-paren.patch
new file mode 100644
index 000000000000..320cc28d431c
--- /dev/null
+++ b/app-emulation/XWine/files/0.3.2-missing-paren.patch
@@ -0,0 +1,11 @@
+--- src/interface.orig.c 2003-11-20 08:48:19.707832264 +0000
++++ src/interface.c 2003-11-20 08:48:49.577291416 +0000
+@@ -2798,7 +2798,7 @@
+ GtkWidget *BT_SYSTEM_OK;
+ GtkWidget *BT_SYSTEM_ANNUL;
+
+- W_WINE_SYSTEM = gnome_dialog_new (_("System Directories", NULL);
++ W_WINE_SYSTEM = gnome_dialog_new (_("System Directories"), NULL);
+ gtk_object_set_data (GTK_OBJECT (W_WINE_SYSTEM), "W_WINE_SYSTEM", W_WINE_SYSTEM);
+ GTK_WINDOW (W_WINE_SYSTEM)->type = GTK_WINDOW_DIALOG;
+ gtk_window_set_position (GTK_WINDOW (W_WINE_SYSTEM), GTK_WIN_POS_CENTER);
diff --git a/app-emulation/XWine/files/0.3.2-wine-update.patch b/app-emulation/XWine/files/0.3.2-wine-update.patch
new file mode 100644
index 000000000000..ca137bce9bc4
--- /dev/null
+++ b/app-emulation/XWine/files/0.3.2-wine-update.patch
@@ -0,0 +1,16 @@
+--- src/main.c.orig 2003-09-18 12:22:59.000000000 -0500
++++ src/main.c 2004-10-10 15:05:53.807531432 -0500
+@@ -62,10 +62,10 @@
+ /* Patch 2 de Mandrake */
+ /*******************************************************/
+ //Verif existence wine
+- if (system("wine -v >/dev/null 2>/dev/null")!=NULL)
++ if (system("wine --version >/dev/null 2>/dev/null")!=NULL)
+ {
+-// fprintf(stderr,"error: wine has to be installed...\n");
+- fprintf(stderr,"erreur: wine ne fonctionne pas correctement, ils est peut être mal installé...\n");
++ fprintf(stderr,"error: wine has to be installed...\n");
++// fprintf(stderr,"erreur: wine ne fonctionne pas correctement, ils est peut être mal installé...\n");
+ exit(1);
+ }
+
diff --git a/app-emulation/XWine/files/digest-XWine-0.3.2-r1 b/app-emulation/XWine/files/digest-XWine-0.3.2-r1
new file mode 100644
index 000000000000..c29311b57b1e
--- /dev/null
+++ b/app-emulation/XWine/files/digest-XWine-0.3.2-r1
@@ -0,0 +1 @@
+MD5 d25768e3088a07a0a2ea7f40d8c06752 XWine-0.3.2_en.tar.gz 984217