summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-08-24 17:00:14 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-08-24 17:00:14 +0000
commitdd6b6ecd646b584282697a5db4ccbbfe7a3b7c33 (patch)
tree2b1a1639a343c8b1bdab855af7a170ea75e047ea /app-emulation/advancemame
parentadjuste broken included config options file (diff)
downloadgentoo-2-dd6b6ecd646b584282697a5db4ccbbfe7a3b7c33.tar.gz
gentoo-2-dd6b6ecd646b584282697a5db4ccbbfe7a3b7c33.tar.bz2
gentoo-2-dd6b6ecd646b584282697a5db4ccbbfe7a3b7c33.zip
new mame emulator
Diffstat (limited to 'app-emulation/advancemame')
-rw-r--r--app-emulation/advancemame/ChangeLog10
-rw-r--r--app-emulation/advancemame/advancemame-0.61.1.ebuild88
-rw-r--r--app-emulation/advancemame/files/digest-advancemame-0.61.12
3 files changed, 100 insertions, 0 deletions
diff --git a/app-emulation/advancemame/ChangeLog b/app-emulation/advancemame/ChangeLog
new file mode 100644
index 000000000000..5c1c9bfc00af
--- /dev/null
+++ b/app-emulation/advancemame/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-emulation/advancemame
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/advancemame/ChangeLog,v 1.1 2002/08/24 17:00:13 azarah Exp $
+
+*advancemame-0.61.1 (24 Aug 2002)
+
+ 24 Aug 2002; Martin Schlemmer <azarah@gentoo.org> :
+
+ Initial version contributed by myself.
+
diff --git a/app-emulation/advancemame/advancemame-0.61.1.ebuild b/app-emulation/advancemame/advancemame-0.61.1.ebuild
new file mode 100644
index 000000000000..29d135dd34e4
--- /dev/null
+++ b/app-emulation/advancemame/advancemame-0.61.1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/advancemame/advancemame-0.61.1.ebuild,v 1.1 2002/08/24 17:00:14 azarah Exp $
+
+# This build we configure to explicitly use SDL, as it is very
+# difficult to get it working with fb or svgalib support. Anyway,
+# it do not look as good ;-)
+
+# Snapshot support
+SNAPSHOT="20020824"
+
+MY_PV="$(echo ${PV} | cut -d. -f1,2)"
+S="${WORKDIR}/advmame"
+DESCRIPTION="AdvanceMAME is a GNU/Linux port of the MAME emulator, with GUI menu."
+# Handle snapshots differently
+if [ -z "${SNAPSHOT}" ] ; then
+ SRC_URI="mirror://sourceforge/advancemame/${P}.zip"
+ MY_A="${P}.zip"
+else
+ SRC_URI="http://www.ibiblio.org/gentoo/distfiles/${PN}-${SNAPSHOT}.tar.bz2"
+ MY_A="${PN}-${SNAPSHOT}.tar.bz2"
+fi
+SRC_URI="${SRC_URI}
+ http://mbnet.fi/~gridle/mame${MY_PV/\.}s.zip
+ http://www.mame.net/zips/mame${MY_PV/\.}s.zip
+ http://roms.mame.dk/emu/mame${MY_PV/\.}s.zip"
+HOMEPAGE="http://advancemame.sourceforge.net/"
+
+LICENSE="GPL-2 xmame"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/x11
+ app-arch/unzip
+ media-libs/libsdl"
+
+
+src_unpack() {
+ unpack mame${MY_PV/\.}s.zip
+
+ mkdir -p ${S}
+
+ cd ${S}
+ # Unpack mame and advacemame
+ unzip -aa ${WORKDIR}/MAME.ZIP || die
+ # Handle snapshots differently
+ if [ -z "${SNAPSHOT}" ] ; then
+ unzip -aa -o ${DISTDIR}/${P}.zip || die
+ else
+ tar -jxf ${DISTDIR}/${PN}-${SNAPSHOT}.tar.bz2 || die
+ fi
+
+ # This one is from MAME.ZIP, and breaks things if present
+ rm -f makefile
+
+ cd ${S}/src
+ # Apply the advancemame patch to the mame sources
+ patch -p1 < ../advance/advmame.dif || die
+
+ # Fix manpage/doc install location
+ cp ${S}/advance/advance.mak ${S}/advance/advance.mak.orig
+ sed -e 's:$(PREFIX)/doc/advance:$(PREFIX)/share/doc/$(PF):g' \
+ -e 's:$(PREFIX)/man/man1:$(PREFIX)/share/man/man1:g' \
+ ${S}/advance/advance.mak.orig > ${S}/advance/advance.mak
+}
+
+src_compile() {
+ # Configure with explicit SDL support
+ econf --with-system=sdl || die
+
+ emake || die
+}
+
+src_install() {
+ # The install script do not create this one
+ dodir /usr/bin
+ make PREFIX=${D}/usr install || die
+
+ dodoc COPYING whatsnew.txt
+ dodoc docs/{ctrlr.txt,listinfo.txt,mame.txt}
+ # Zip the docs that was installed by 'make install'
+ gzip ${D}/usr/share/doc/${PF}/*.txt
+
+ # Move the html pages the the correct location
+ dodir /usr/share/doc/${PF}/html
+ mv ${D}/usr/share/doc/${PF}/*.html ${D}/usr/share/doc/${PF}/html
+}
+
diff --git a/app-emulation/advancemame/files/digest-advancemame-0.61.1 b/app-emulation/advancemame/files/digest-advancemame-0.61.1
new file mode 100644
index 000000000000..95c7b989eaec
--- /dev/null
+++ b/app-emulation/advancemame/files/digest-advancemame-0.61.1
@@ -0,0 +1,2 @@
+MD5 189bcf88588017461ed8eafa0c086f58 advancemame-20020824.tar.bz2 943470
+MD5 069ba445724b236b315b1706bedfdb30 mame061s.zip 6072159