summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2014-01-25 01:38:27 +0000
committerChris Reffett <creffett@gentoo.org>2014-01-25 01:38:27 +0000
commit4b09d97b94245bad39c8475eb8d6b32ae90897b5 (patch)
tree893275d99f76790aa80d8766d0c44d4c8a4dd435 /app-emulation/aranym
parentOnly enable Qt4 so far, bug 483648 (diff)
downloadgentoo-2-4b09d97b94245bad39c8475eb8d6b32ae90897b5.tar.gz
gentoo-2-4b09d97b94245bad39c8475eb8d6b32ae90897b5.tar.bz2
gentoo-2-4b09d97b94245bad39c8475eb8d6b32ae90897b5.zip
Remove old, remove extraneous || die calls
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 42618354)
Diffstat (limited to 'app-emulation/aranym')
-rw-r--r--app-emulation/aranym/ChangeLog8
-rw-r--r--app-emulation/aranym/aranym-0.9.10.ebuild48
-rw-r--r--app-emulation/aranym/aranym-0.9.11.ebuild48
-rw-r--r--app-emulation/aranym/aranym-0.9.14.ebuild10
4 files changed, 11 insertions, 103 deletions
diff --git a/app-emulation/aranym/ChangeLog b/app-emulation/aranym/ChangeLog
index 71117cc107c0..cb1acaca90eb 100644
--- a/app-emulation/aranym/ChangeLog
+++ b/app-emulation/aranym/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/aranym
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/aranym/ChangeLog,v 1.22 2013/08/07 15:23:17 armin76 Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/aranym/ChangeLog,v 1.23 2014/01/25 01:38:27 creffett Exp $
+
+ 25 Jan 2014; Chris Reffett <creffett@gentoo.org> -aranym-0.9.10.ebuild,
+ -aranym-0.9.11.ebuild, aranym-0.9.14.ebuild:
+ Remove old, remove extraneous || die calls
07 Aug 2013; Raúl Porcel <armin76@gentoo.org> aranym-0.9.14.ebuild:
add media-libs/libsdl dep
diff --git a/app-emulation/aranym/aranym-0.9.10.ebuild b/app-emulation/aranym/aranym-0.9.10.ebuild
deleted file mode 100644
index 21e91feba570..000000000000
--- a/app-emulation/aranym/aranym-0.9.10.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/aranym/aranym-0.9.10.ebuild,v 1.1 2010/09/01 15:00:03 xmw Exp $
-
-EAPI=2
-
-inherit flag-o-matic eutils
-
-DESCRIPTION="Atari Running on Any Machine, a VM running Atari ST/TT/Falcon OS and TOS/GEM applications"
-HOMEPAGE="http://aranym.sourceforge.net/"
-SRC_URI="mirror://sourceforge/aranym/${P}.tar.gz
- mirror://sourceforge/aranym/afros812.zip"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="opengl"
-
-RDEPEND="media-libs/libsdl
- games-emulation/emutos
- opengl? ( virtual/opengl )"
-DEPEND="${RDEPEND}
- app-arch/unzip"
-
-src_configure() {
- filter-flags -mpowerpc-gfxopt
-
- local myconf=""
- if [[ ${ARCH} == x86 ]]; then
- myconf="${myconf} --enable-jit-compiler"
- fi
-
- econf $(use_enable opengl) ${myconf}
-}
-
-src_install() {
- emake DESTDIR="${D}" INSTALL_PROGRAM="install" install || die "installation failed"
-
- insinto /usr/share/${PN}
- doins -r "${WORKDIR}"/afros || die
-
- dodoc "${D}"/usr/share/doc/${PN}/* || die
- rm -r "${D}"/usr/share/doc/${PN} || die
-}
-
-pkg_postinst() {
- elog "To run ARAnyM with AFROS type: aranym --config /usr/share/aranym/afros/config"
-}
diff --git a/app-emulation/aranym/aranym-0.9.11.ebuild b/app-emulation/aranym/aranym-0.9.11.ebuild
deleted file mode 100644
index 345ba9ae9108..000000000000
--- a/app-emulation/aranym/aranym-0.9.11.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/aranym/aranym-0.9.11.ebuild,v 1.1 2013/01/30 05:39:21 patrick Exp $
-
-EAPI=5
-
-inherit flag-o-matic eutils
-
-DESCRIPTION="Atari Running on Any Machine, a VM running Atari ST/TT/Falcon OS and TOS/GEM applications"
-HOMEPAGE="http://aranym.sourceforge.net/"
-SRC_URI="mirror://sourceforge/aranym/${P}.tar.gz
- mirror://sourceforge/aranym/afros812.zip"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="opengl"
-
-RDEPEND="media-libs/libsdl[X]
- games-emulation/emutos
- opengl? ( virtual/opengl )"
-DEPEND="${RDEPEND}
- app-arch/unzip"
-
-src_configure() {
- filter-flags -mpowerpc-gfxopt
-
- local myconf=""
- if [[ ${ARCH} == x86 ]]; then
- myconf="${myconf} --enable-jit-compiler"
- fi
-
- econf $(use_enable opengl) ${myconf}
-}
-
-src_install() {
- emake DESTDIR="${D}" INSTALL_PROGRAM="install" install || die "installation failed"
-
- insinto /usr/share/${PN}
- doins -r "${WORKDIR}"/afros || die
-
- dodoc "${D}"/usr/share/doc/${PN}/* || die
- rm -r "${D}"/usr/share/doc/${PN} || die
-}
-
-pkg_postinst() {
- elog "To run ARAnyM with AFROS type: aranym --config /usr/share/aranym/afros/config"
-}
diff --git a/app-emulation/aranym/aranym-0.9.14.ebuild b/app-emulation/aranym/aranym-0.9.14.ebuild
index eb7ca5ab29b1..28247a65c1e1 100644
--- a/app-emulation/aranym/aranym-0.9.14.ebuild
+++ b/app-emulation/aranym/aranym-0.9.14.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/aranym/aranym-0.9.14.ebuild,v 1.2 2013/08/07 15:23:17 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/aranym/aranym-0.9.14.ebuild,v 1.3 2014/01/25 01:38:27 creffett Exp $
EAPI=5
@@ -45,12 +45,12 @@ src_configure() {
}
src_install() {
- emake DESTDIR="${D}" INSTALL_PROGRAM="install" install || die "installation failed"
+ emake DESTDIR="${D}" INSTALL_PROGRAM="install" install
insinto /usr/share/${PN}
- doins -r "${WORKDIR}"/afros || die
+ doins -r "${WORKDIR}"/afros
- dodoc "${D}"/usr/share/doc/${PN}/* || die
+ dodoc "${D}"/usr/share/doc/${PN}/*
rm -r "${D}"/usr/share/doc/${PN} || die
}