summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Holm <dholm@gentoo.org>2005-07-20 14:14:04 +0000
committerDavid Holm <dholm@gentoo.org>2005-07-20 14:14:04 +0000
commita123fa0b5c0ee7e9788b4ff27ee2b71c32933733 (patch)
treeff36b5a23c0e919b0aeb3d2376c791502acd81a7 /app-emulation/aranym
parentRewritten the virtual-domain-outgoing-IP-address patch, enhanced the ebuilds ... (diff)
downloadgentoo-2-a123fa0b5c0ee7e9788b4ff27ee2b71c32933733.tar.gz
gentoo-2-a123fa0b5c0ee7e9788b4ff27ee2b71c32933733.tar.bz2
gentoo-2-a123fa0b5c0ee7e9788b4ff27ee2b71c32933733.zip
Added compilation fix (Bug #99634)
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'app-emulation/aranym')
-rw-r--r--app-emulation/aranym/ChangeLog7
-rw-r--r--app-emulation/aranym/aranym-0.9.0_beta2.ebuild4
-rw-r--r--app-emulation/aranym/files/aranym-0.9.0_beta2-fix.patch19
3 files changed, 28 insertions, 2 deletions
diff --git a/app-emulation/aranym/ChangeLog b/app-emulation/aranym/ChangeLog
index 5d177b9bbb4d..0584f7b420c3 100644
--- a/app-emulation/aranym/ChangeLog
+++ b/app-emulation/aranym/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/aranym
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/aranym/ChangeLog,v 1.7 2005/07/20 11:16:56 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/aranym/ChangeLog,v 1.8 2005/07/20 14:14:04 dholm Exp $
+
+ 20 Jul 2005; David Holm <dholm@gentoo.org>
+ +files/aranym-0.9.0_beta2-fix.patch, aranym-0.9.0_beta2.ebuild:
+ Added fix submitted by Nickolay Kolchin-Semyonov <nbkolchin (at) yandex
+ (dot) ru> (Bug #99634)
*aranym-0.9.0 (20 Jul 2005)
diff --git a/app-emulation/aranym/aranym-0.9.0_beta2.ebuild b/app-emulation/aranym/aranym-0.9.0_beta2.ebuild
index 14b1e965dae0..aa502a3bb1a7 100644
--- a/app-emulation/aranym/aranym-0.9.0_beta2.ebuild
+++ b/app-emulation/aranym/aranym-0.9.0_beta2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/aranym/aranym-0.9.0_beta2.ebuild,v 1.2 2005/06/28 05:26:34 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/aranym/aranym-0.9.0_beta2.ebuild,v 1.3 2005/07/20 14:14:04 dholm Exp $
inherit flag-o-matic eutils
@@ -25,6 +25,8 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${PN}-${MY_PV}.tar.gz
+ cd ${S}
+ epatch ${FILESDIR}/${P}-fix.patch
}
src_compile() {
diff --git a/app-emulation/aranym/files/aranym-0.9.0_beta2-fix.patch b/app-emulation/aranym/files/aranym-0.9.0_beta2-fix.patch
new file mode 100644
index 000000000000..5b5f3d5e2ffa
--- /dev/null
+++ b/app-emulation/aranym/files/aranym-0.9.0_beta2-fix.patch
@@ -0,0 +1,19 @@
+diff -Naur aranym-0.9.0.orig/src/natfeat/nfcdrom_linux.cpp aranym-0.9.0/src/natfeat/nfcdrom_linux.cpp
+--- aranym-0.9.0.orig/src/natfeat/nfcdrom_linux.cpp 2005-07-20 14:05:13.011801440 +0200
++++ aranym-0.9.0/src/natfeat/nfcdrom_linux.cpp 2005-07-20 14:06:10.331087584 +0200
+@@ -18,7 +18,6 @@
+ Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ */
+
+-#include <linux/cdrom.h>
+
+ #include <SDL_cdrom.h>
+ #include <SDL_endian.h>
+@@ -31,6 +30,7 @@
+
+ #define DEBUG 0
+ #include "debug.h"
++#include <linux/cdrom.h>
+
+ /*--- Defines ---*/
+