summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-02-20 22:07:23 +0000
committerMike Frysinger <vapier@gentoo.org>2005-02-20 22:07:23 +0000
commit0f8ff2c440e7fbc392440a46a10bc0c6a759e6c6 (patch)
treed042ccfd6658df935dd36ce13af32f47a9db8cf5 /app-emulation/crossover-office-bin
parentEnable compressed folder support via --enable-compressed (diff)
downloadgentoo-2-0f8ff2c440e7fbc392440a46a10bc0c6a759e6c6.tar.gz
gentoo-2-0f8ff2c440e7fbc392440a46a10bc0c6a759e6c6.tar.bz2
gentoo-2-0f8ff2c440e7fbc392440a46a10bc0c6a759e6c6.zip
make sure perl is built with USE=ithreads #82706
(Portage version: 2.0.51-r15)
Diffstat (limited to 'app-emulation/crossover-office-bin')
-rw-r--r--app-emulation/crossover-office-bin/crossover-office-bin-4.1.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/app-emulation/crossover-office-bin/crossover-office-bin-4.1.ebuild b/app-emulation/crossover-office-bin/crossover-office-bin-4.1.ebuild
index d9f3c7e04d23..874713e68e06 100644
--- a/app-emulation/crossover-office-bin/crossover-office-bin-4.1.ebuild
+++ b/app-emulation/crossover-office-bin/crossover-office-bin-4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/crossover-office-bin/crossover-office-bin-4.1.ebuild,v 1.2 2005/01/01 14:09:10 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/crossover-office-bin/crossover-office-bin-4.1.ebuild,v 1.3 2005/02/20 22:07:23 vapier Exp $
inherit eutils
@@ -24,6 +24,11 @@ pkg_nofetch() {
einfo "and place ${A} in ${DISTDIR}"
}
+pkg_setup() {
+ ! built_with_use dev-lang/perl ithreads \
+ && die "you need to have perl built with USE=ithreads"
+}
+
src_unpack() {
unpack_makeself
}