summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2009-09-29 16:00:39 +0000
committerVlastimil Babka <caster@gentoo.org>2009-09-29 16:00:39 +0000
commit569fde323b3f1b8b40c0ae73762985566d1acd18 (patch)
treecc83d371fa81095a03fc93713ab211afbb04515b /app-emulation/emul-linux-x86-java
parentVersion bump. (diff)
downloadgentoo-2-569fde323b3f1b8b40c0ae73762985566d1acd18.tar.gz
gentoo-2-569fde323b3f1b8b40c0ae73762985566d1acd18.tar.bz2
gentoo-2-569fde323b3f1b8b40c0ae73762985566d1acd18.zip
Version bump.
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/emul-linux-x86-java')
-rw-r--r--app-emulation/emul-linux-x86-java/ChangeLog8
-rw-r--r--app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.5.0.21.ebuild100
2 files changed, 107 insertions, 1 deletions
diff --git a/app-emulation/emul-linux-x86-java/ChangeLog b/app-emulation/emul-linux-x86-java/ChangeLog
index 668e237dc31f..e7e2cf76bd5e 100644
--- a/app-emulation/emul-linux-x86-java/ChangeLog
+++ b/app-emulation/emul-linux-x86-java/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/emul-linux-x86-java
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-java/ChangeLog,v 1.77 2009/08/18 10:11:50 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-java/ChangeLog,v 1.78 2009/09/29 16:00:39 caster Exp $
+
+*emul-linux-x86-java-1.5.0.21 (29 Sep 2009)
+
+ 29 Sep 2009; Vlastimil Babka <caster@gentoo.org>
+ +emul-linux-x86-java-1.5.0.21.ebuild:
+ Version bump.
*emul-linux-x86-java-1.6.0.16 (18 Aug 2009)
diff --git a/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.5.0.21.ebuild b/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.5.0.21.ebuild
new file mode 100644
index 000000000000..1fc1db79f284
--- /dev/null
+++ b/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.5.0.21.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.5.0.21.ebuild,v 1.1 2009/09/29 16:00:39 caster Exp $
+
+inherit versionator pax-utils eutils java-vm-2
+
+UPDATE="$(get_version_component_range 4)"
+UPDATE="${UPDATE#0}"
+MY_PV="$(get_version_component_range 2-3)u${UPDATE}"
+
+At="jdk-${MY_PV}-dlj-linux-i586.bin"
+DESCRIPTION="Sun's Java SE Runtime Environment (32bit)"
+HOMEPAGE="http://java.sun.com/j2se/1.5.0/"
+SRC_URI="http://download.java.net/dlj/binaries/${At}"
+
+SLOT="1.5"
+LICENSE="dlj-1.1"
+KEYWORDS="-* ~amd64"
+RESTRICT="strip"
+IUSE="X alsa nsplugin"
+
+JAVA_VM_NO_GENERATION1=true
+
+RDEPEND="alsa? ( app-emulation/emul-linux-x86-soundlibs )
+ X? ( app-emulation/emul-linux-x86-xlibs )"
+
+JAVA_PROVIDE="jdbc-stdext jdbc-rowset"
+
+QA_TEXTRELS_amd64="opt/${P}/lib/i386/motif21/libmawt.so
+ opt/${P}/lib/i386/libdeploy.so"
+QA_DT_HASH="opt/${P}/.*"
+
+src_unpack() {
+ mkdir bundled-jdk
+ cd bundled-jdk
+ sh "${DISTDIR}"/${At} --accept-license --unpack || die "Failed to unpack"
+
+ cd ..
+ bash "${FILESDIR}"/construct.sh bundled-jdk sun-jdk-${PV} ${P} || die "construct.sh failed"
+}
+
+src_compile() {
+ # Set PaX markings on all JDK/JRE executables to allow code-generation on
+ # the heap by the JIT compiler. This has to be done before CDS - #215225
+ pax-mark m $(list-paxables "${S}"/bin/*)
+
+ # see bug #207282
+ einfo "Creating the Class Data Sharing archives"
+ "${S}"/bin/java -client -Xshare:dump || die
+}
+
+src_install() {
+ dodir /opt/${P}
+ cp -pPR bin lib man javaws plugin "${D}/opt/${P}/" || die "failed to copy"
+
+ dodoc CHANGES README THIRDPARTYLICENSEREADME.txt || die
+ dohtml Welcome.html || die
+
+ if use nsplugin; then
+ local plugin_dir="ns7-gcc29"
+ if has_version '>=sys-devel/gcc-3' ; then
+ plugin_dir="ns7"
+ fi
+
+ install_mozilla_plugin /opt/${P}/plugin/i386/$plugin_dir/libjavaplugin_oji.so
+ fi
+
+ # FIXME figure out how to handle the control pannel conflict with
+ # sun-jdk-bin
+
+ # install control panel for Gnome/KDE
+# sed -e "s/INSTALL_DIR\/JRE_NAME_VERSION/\/opt\/${P}\/jre/" \
+# -e "s/\(Name=Java\)/\1 Control Panel ${SLOT}/" \
+# ${D}/opt/${P}/plugin/desktop/sun_java.desktop > \
+# ${T}/sun_java-${SLOT}.desktop
+
+# domenu ${T}/sun_java-${SLOT}.desktop
+
+ set_java_env
+ java-vm_revdep-mask
+}
+
+pkg_postinst() {
+ # Set as default VM if none exists
+ java-vm-2_pkg_postinst
+
+ if ! use X; then
+ local xwarn="X11 libraries and/or"
+ fi
+
+ echo
+ ewarn "Some parts of Sun's JDK require ${xwarn} virtual/lpr to be installed."
+ ewarn "Be careful which Java libraries you attempt to use."
+
+ echo
+ elog "Beginning with 1.5.0.10 the hotspot vm can use epoll"
+ elog "The epoll-based implementation of SelectorProvider is not selected by"
+ elog "default."
+ elog "Use java -Djava.nio.channels.spi.SelectorProvider=sun.nio.ch.EPollSelectorProvider"
+}