summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-01-03 13:25:12 +0000
committerPacho Ramos <pacho@gentoo.org>2010-01-03 13:25:12 +0000
commit9aa758be2843446008a96c656dc158fec3cbae14 (patch)
tree9b150d9642b6044ba663d768beda9e2ccd70f4e3 /app-emulation/emul-linux-x86-soundlibs
parentcopyright fixes (diff)
downloadgentoo-2-9aa758be2843446008a96c656dc158fec3cbae14.tar.gz
gentoo-2-9aa758be2843446008a96c656dc158fec3cbae14.tar.bz2
gentoo-2-9aa758be2843446008a96c656dc158fec3cbae14.zip
Fix unpack failure, bug 299436
(Portage version: 2.1.7.15/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/emul-linux-x86-soundlibs')
-rw-r--r--app-emulation/emul-linux-x86-soundlibs/ChangeLog7
-rw-r--r--app-emulation/emul-linux-x86-soundlibs/emul-linux-x86-soundlibs-20091231.ebuild14
2 files changed, 12 insertions, 9 deletions
diff --git a/app-emulation/emul-linux-x86-soundlibs/ChangeLog b/app-emulation/emul-linux-x86-soundlibs/ChangeLog
index e6f813e5c742..a73e711ba715 100644
--- a/app-emulation/emul-linux-x86-soundlibs/ChangeLog
+++ b/app-emulation/emul-linux-x86-soundlibs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/emul-linux-x86-soundlibs
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-soundlibs/ChangeLog,v 1.50 2010/01/01 21:31:38 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-soundlibs/ChangeLog,v 1.51 2010/01/03 13:25:12 pacho Exp $
+
+ 03 Jan 2010; Pacho Ramos <pacho@gentoo.org>
+ emul-linux-x86-soundlibs-20091231.ebuild:
+ Fix unpack failure when alsa disabled, thanks to Yegle for reporting it in
+ bug 299436
01 Jan 2010; Pacho Ramos <pacho@gentoo.org>
-emul-linux-x86-soundlibs-2.5-r2.ebuild,
diff --git a/app-emulation/emul-linux-x86-soundlibs/emul-linux-x86-soundlibs-20091231.ebuild b/app-emulation/emul-linux-x86-soundlibs/emul-linux-x86-soundlibs-20091231.ebuild
index ca4eebe1f5aa..a341196791ac 100644
--- a/app-emulation/emul-linux-x86-soundlibs/emul-linux-x86-soundlibs-20091231.ebuild
+++ b/app-emulation/emul-linux-x86-soundlibs/emul-linux-x86-soundlibs-20091231.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-soundlibs/emul-linux-x86-soundlibs-20091231.ebuild,v 1.1 2009/12/31 12:07:57 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-soundlibs/emul-linux-x86-soundlibs-20091231.ebuild,v 1.2 2010/01/03 13:25:12 pacho Exp $
EAPI=1
inherit emul-linux-x86
@@ -16,14 +16,12 @@ QA_DT_HASH="usr/lib32/.*"
src_unpack() {
_ALLOWED="${S}/etc/env.d"
-
- if use alsa; then
- _ALLOWED="${_ALLOWED}|${S}/usr/bin/aoss"
- fi
-
+ use alsa && _ALLOWED="${_ALLOWED}|${S}/usr/bin/aoss"
ALLOWED="(${_ALLOWED})"
emul-linux-x86_src_unpack
- mv -f "${S}"/usr/bin/aoss{,32} || die
+ if use alsa; then
+ mv -f "${S}"/usr/bin/aoss{,32} || die
+ fi
}