summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Hanselmann <hansmi@gentoo.org>2007-11-23 12:45:00 +0000
committerMichael Hanselmann <hansmi@gentoo.org>2007-11-23 12:45:00 +0000
commit5b2cc6efbf60cda7d620e7aed7f074a7a10fe89d (patch)
treebcaab4de6e975e05e1c431881e791047c8eca034 /app-emulation/ganeti
parentStable on x86 (diff)
downloadgentoo-2-5b2cc6efbf60cda7d620e7aed7f074a7a10fe89d.tar.gz
gentoo-2-5b2cc6efbf60cda7d620e7aed7f074a7a10fe89d.tar.bz2
gentoo-2-5b2cc6efbf60cda7d620e7aed7f074a7a10fe89d.zip
Add missing init script.
(Portage version: 2.1.3.19)
Diffstat (limited to 'app-emulation/ganeti')
-rw-r--r--app-emulation/ganeti/ChangeLog8
-rw-r--r--app-emulation/ganeti/files/digest-ganeti-1.2_beta2-r1 (renamed from app-emulation/ganeti/files/digest-ganeti-1.2_beta2)0
-rw-r--r--app-emulation/ganeti/files/ganeti.initd56
-rw-r--r--app-emulation/ganeti/ganeti-1.2_beta2-r1.ebuild (renamed from app-emulation/ganeti/ganeti-1.2_beta2.ebuild)2
4 files changed, 64 insertions, 2 deletions
diff --git a/app-emulation/ganeti/ChangeLog b/app-emulation/ganeti/ChangeLog
index fea0f43bc75a..51318c5e1422 100644
--- a/app-emulation/ganeti/ChangeLog
+++ b/app-emulation/ganeti/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/inspircd
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/ChangeLog,v 1.1 2007/11/23 02:03:39 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/ChangeLog,v 1.2 2007/11/23 12:44:59 hansmi Exp $
+
+*ganeti-1.2_beta2-r1 (23 Nov 2007)
+
+ 23 Nov 2007; Michael Hanselmann <hansmi@gentoo.org> +files/ganeti.initd,
+ -ganeti-1.2_beta2.ebuild, +ganeti-1.2_beta2-r1.ebuild:
+ Add missing init script.
*ganeti-1.2_beta2 (23 Nov 2007)
diff --git a/app-emulation/ganeti/files/digest-ganeti-1.2_beta2 b/app-emulation/ganeti/files/digest-ganeti-1.2_beta2-r1
index a1a276b2d8c9..a1a276b2d8c9 100644
--- a/app-emulation/ganeti/files/digest-ganeti-1.2_beta2
+++ b/app-emulation/ganeti/files/digest-ganeti-1.2_beta2-r1
diff --git a/app-emulation/ganeti/files/ganeti.initd b/app-emulation/ganeti/files/ganeti.initd
new file mode 100644
index 000000000000..a6c9520491bb
--- /dev/null
+++ b/app-emulation/ganeti/files/ganeti.initd
@@ -0,0 +1,56 @@
+#!/sbin/runscript
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/files/ganeti.initd,v 1.1 2007/11/23 12:45:00 hansmi Exp $
+
+depend() {
+ need localmount xend drbd
+ after bootmisc
+}
+
+checkconfig() {
+ for fname in /var/lib/ganeti/ssconf_node_pass /var/lib/ganeti/server.pem
+ do
+ if [[ ! -f "$fname" ]]
+ then
+ eerror "Config file $fname not found, will not run."
+ return 1
+ fi
+ done
+
+ return 0
+}
+
+start() {
+ checkconfig || return 1
+
+ ebegin "Starting ganeti-master"
+ /usr/sbin/ganeti-master start
+ ret=$?
+ eend ${ret}
+ [[ "${ret}" != 0 ]] && return 1
+
+ ebegin "Starting ganeti-noded"
+ start-stop-daemon --start --quiet --exec /usr/sbin/ganeti-noded
+ ret=$?
+ eend ${ret}
+ [[ "${ret}" != 0 ]] && return 1
+
+ return 0
+}
+
+stop() {
+ ebegin "Stopping ganeti-noded"
+ start-stop-daemon --stop --quiet --name ganeti-noded
+ ret=$?
+ eend ${ret}
+ [[ "${ret}" != 0 ]] && return 1
+
+ ebegin "Stopping ganeti-master"
+ /usr/sbin/ganeti-master start
+ ret=$?
+ eend ${ret}
+ [[ "${ret}" != 0 ]] && return 1
+
+ return 0
+}
diff --git a/app-emulation/ganeti/ganeti-1.2_beta2.ebuild b/app-emulation/ganeti/ganeti-1.2_beta2-r1.ebuild
index 514f14d2ae77..84ed22e56a02 100644
--- a/app-emulation/ganeti/ganeti-1.2_beta2.ebuild
+++ b/app-emulation/ganeti/ganeti-1.2_beta2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/ganeti-1.2_beta2.ebuild,v 1.1 2007/11/23 02:03:39 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/ganeti-1.2_beta2-r1.ebuild,v 1.1 2007/11/23 12:44:59 hansmi Exp $
NEED_PYTHON=2.4