summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLance Albertson <ramereth@gentoo.org>2012-05-12 08:10:23 +0000
committerLance Albertson <ramereth@gentoo.org>2012-05-12 08:10:23 +0000
commit648ddf64e8a033d0ff17e25bae1b006089e7a564 (patch)
tree599883cdb102789ecd24378d42844fef6417d71c /app-emulation/ganeti
parent[bump] dev-perl/Plack-0.998.800 (diff)
downloadgentoo-2-648ddf64e8a033d0ff17e25bae1b006089e7a564.tar.gz
gentoo-2-648ddf64e8a033d0ff17e25bae1b006089e7a564.tar.bz2
gentoo-2-648ddf64e8a033d0ff17e25bae1b006089e7a564.zip
Version bump, cleanup, lots-o-bugfixes
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/ganeti')
-rw-r--r--app-emulation/ganeti/ChangeLog16
-rw-r--r--app-emulation/ganeti/files/ganeti-2.1.initd46
-rw-r--r--app-emulation/ganeti/files/ganeti.confd6
-rw-r--r--app-emulation/ganeti/ganeti-2.4.3.ebuild91
-rw-r--r--app-emulation/ganeti/ganeti-2.4.4.ebuild91
-rw-r--r--app-emulation/ganeti/ganeti-2.5.0_rc6.ebuild124
-rw-r--r--app-emulation/ganeti/ganeti-2.5.1.ebuild (renamed from app-emulation/ganeti/ganeti-2.5.0_rc5.ebuild)10
7 files changed, 65 insertions, 319 deletions
diff --git a/app-emulation/ganeti/ChangeLog b/app-emulation/ganeti/ChangeLog
index 195426332ee8..a923d342df76 100644
--- a/app-emulation/ganeti/ChangeLog
+++ b/app-emulation/ganeti/ChangeLog
@@ -1,6 +1,20 @@
# ChangeLog for app-emulation/ganeti
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/ChangeLog,v 1.58 2012/04/05 14:55:17 sping Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/ChangeLog,v 1.59 2012/05/12 08:10:23 ramereth Exp $
+
+*ganeti-2.5.1 (12 May 2012)
+
+ 12 May 2012; Lance Albertson <ramereth@gentoo.org> files/ganeti-2.1.initd,
+ -ganeti-2.4.3.ebuild, -ganeti-2.4.4.ebuild, -ganeti-2.5.0_rc5.ebuild,
+ -ganeti-2.5.0_rc6.ebuild, +ganeti-2.5.1.ebuild, files/ganeti.confd:
+ Version bump, cleanup, lots-o-bugfixes
+
+ Fixed #371759, #372581 with an updated init script which is hopefully
+ smarter.
+ Fixed #415321 by checking for new path for kvm binary. Fixed #398279 by
+ adding
+ logger to the need depend in the init script. Added support for giving
+ args to noded and confd.
*ganeti-2.5.0_rc6 (05 Apr 2012)
diff --git a/app-emulation/ganeti/files/ganeti-2.1.initd b/app-emulation/ganeti/files/ganeti-2.1.initd
index 8b84e2f9a6dc..ed890d81c71c 100644
--- a/app-emulation/ganeti/files/ganeti-2.1.initd
+++ b/app-emulation/ganeti/files/ganeti-2.1.initd
@@ -1,10 +1,10 @@
#!/sbin/runscript
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/files/ganeti-2.1.initd,v 1.4 2011/08/09 06:57:04 ramereth Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/files/ganeti-2.1.initd,v 1.5 2012/05/12 08:10:23 ramereth Exp $
depend() {
- need localmount
+ need localmount logger
after bootmisc
}
@@ -50,24 +50,56 @@ maybe_do() {
fi
}
+get_master_node() {
+ MASTER_NODE="$(gnt-cluster getmaster)"
+ NODE_HOSTNAME="$(hostname -f)"
+ if [ "$MASTER_NODE" == "$NODE_HOSTNAME" ] ; then
+ MASTER=1
+ else
+ MASTER=0
+ fi
+}
+
start_all() {
check_config
+ get_master_node
for i in $($DAEMON_UTIL list-start-daemons); do \
+ GANETI_START_OPTS="${GANETI_OPTS}"
case "${i}" in
ganeti-masterd)
- GANETI_OPTS="${GANETI_OPTS} ${GANETI_MASTERD_OPTS}"
+ GANETI_OPTS="${GANETI_START_OPTS} ${GANETI_MASTERD_OPTS}"
;;
ganeti-rapid)
- GANETI_OPTS="${GANETI_OPTS} ${GANETI_RAPI_OPTS}"
+ GANETI_OPTS="${GANETI_START_OPTS} ${GANETI_RAPI_OPTS}"
+ ;;
+ ganeti-noded)
+ GANETI_OPTS="${GANETI_START_OPTS} ${GANETI_NODED_OPTS}"
+ ;;
+ ganeti-confd)
+ GANETI_OPTS="${GANETI_START_OPTS} ${GANETI_CONFD_OPTS}"
;;
esac
- maybe_do "${1}" start_action ${i} ${GANETI_OPTS}
+ # Don't start if not master
+ if [ $MASTER = 0 -a $i = "ganeti-masterd" ] ; then
+ continue
+ elif [ $MASTER = 0 -a $i = "ganeti-rapi" ] ; then
+ continue
+ else
+ maybe_do "${1}" start_action ${i} ${GANETI_OPTS}
+ fi
done
}
stop_all() {
+ get_master_node
for i in $($DAEMON_UTIL list-stop-daemons) ; do \
- maybe_do "${1}" stop_action ${i}
+ if [ $MASTER = 0 -a $i = "ganeti-masterd" ] ; then
+ continue
+ elif [ $MASTER = 0 -a $i = "ganeti-rapi" ] ; then
+ continue
+ else
+ maybe_do "${1}" stop_action ${i} ${GANETI_OPTS}
+ fi
done
}
diff --git a/app-emulation/ganeti/files/ganeti.confd b/app-emulation/ganeti/files/ganeti.confd
index b79a27815c12..3b71d7ee44a8 100644
--- a/app-emulation/ganeti/files/ganeti.confd
+++ b/app-emulation/ganeti/files/ganeti.confd
@@ -8,3 +8,9 @@
# Options to pass to ganeti-rapi
# GANETI_RAPI_OPTS=""
+
+# Options to pass to ganeti-noded
+# GANETI_NODED_OPTS=""
+
+# Options to pass to ganeti-confd
+# GANETI_CONFD_OPTS=""
diff --git a/app-emulation/ganeti/ganeti-2.4.3.ebuild b/app-emulation/ganeti/ganeti-2.4.3.ebuild
deleted file mode 100644
index 8f0a1af72dca..000000000000
--- a/app-emulation/ganeti/ganeti-2.4.3.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/ganeti-2.4.3.ebuild,v 1.4 2012/03/09 04:48:43 ramereth Exp $
-
-EAPI=2
-
-inherit eutils confutils bash-completion-r1
-
-MY_PV="${PV/_rc/~rc}"
-#MY_PV="${PV/_beta/~beta}"
-MY_P="${PN}-${MY_PV}"
-DESCRIPTION="Ganeti is a virtual server management software tool"
-HOMEPAGE="http://code.google.com/p/ganeti/"
-SRC_URI="http://ganeti.googlecode.com/files/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="kvm xen drbd +filestorage syslog ipv6"
-
-S="${WORKDIR}/${MY_P}"
-
-DEPEND="xen? ( >=app-emulation/xen-3.0 )
- kvm? ( app-emulation/qemu-kvm )
- drbd? ( >=sys-cluster/drbd-8.3 )
- ipv6? ( net-misc/ndisc6 )
- dev-libs/openssl
- dev-python/paramiko
- dev-python/pyopenssl
- dev-python/pyparsing
- dev-python/pycurl
- dev-python/pyinotify
- dev-python/simplejson
- net-analyzer/arping
- net-misc/bridge-utils
- net-misc/curl[ssl]
- net-misc/openssh
- net-misc/socat
- sys-apps/iproute2
- sys-fs/lvm2
- >=sys-apps/baselayout-2.0"
-RDEPEND="${DEPEND}
- !<app-emulation/ganeti-htools-0.3"
-
-pkg_setup () {
- confutils_require_any kvm xen
-}
-
-src_prepare () {
- epatch "${FILESDIR}/${PN}-fix-start-stop.patch"
-}
-
-src_configure () {
- local myconf
- if use filestorage ; then
- myconf="--with-file-storage-dir=/var/lib/ganeti-storage/file"
- else
- myconf="--with-file-storage-dir=no"
- fi
- econf --localstatedir=/var \
- --docdir=/usr/share/doc/${P} \
- --with-ssh-initscript=/etc/init.d/sshd \
- --with-export-dir=/var/lib/ganeti-storage/export \
- --with-os-search-path=/usr/share/ganeti/os \
- $(use_enable syslog) \
- ${myconf}
-}
-
-src_install () {
- emake DESTDIR="${D}" install || die "emake install failed"
- newinitd "${FILESDIR}"/ganeti-2.1.initd ganeti
- newconfd "${FILESDIR}"/ganeti.confd ganeti
- use kvm && newinitd "${FILESDIR}"/ganeti-kvm-poweroff.initd ganeti-kvm-poweroff
- use kvm && newconfd "${FILESDIR}"/ganeti-kvm-poweroff.confd ganeti-kvm-poweroff
- newbashcomp doc/examples/bash_completion ganeti
- dodoc INSTALL UPGRADE NEWS README doc/*.rst
- rm -rf "${D}"/usr/share/doc/ganeti
- docinto examples
- #dodoc doc/examples/{basic-oob,ganeti.cron,gnt-config-backup}
- dodoc doc/examples/{ganeti.cron,gnt-config-backup}
- docinto examples/hooks
- dodoc doc/examples/hooks/{ipsec,ethers}
-
- keepdir /var/{lib,log,run}/ganeti/
- keepdir /usr/share/ganeti/os/
- keepdir /var/lib/ganeti-storage/{export,file}/
-}
-
-pkg_postinst () {
- bash-completion_pkg_postinst
-}
diff --git a/app-emulation/ganeti/ganeti-2.4.4.ebuild b/app-emulation/ganeti/ganeti-2.4.4.ebuild
deleted file mode 100644
index 6852f9a31608..000000000000
--- a/app-emulation/ganeti/ganeti-2.4.4.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/ganeti-2.4.4.ebuild,v 1.2 2012/03/09 04:48:43 ramereth Exp $
-
-EAPI=2
-
-inherit eutils confutils bash-completion-r1
-
-MY_PV="${PV/_rc/~rc}"
-#MY_PV="${PV/_beta/~beta}"
-MY_P="${PN}-${MY_PV}"
-DESCRIPTION="Ganeti is a virtual server management software tool"
-HOMEPAGE="http://code.google.com/p/ganeti/"
-SRC_URI="http://ganeti.googlecode.com/files/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="kvm xen drbd +filestorage syslog ipv6"
-
-S="${WORKDIR}/${MY_P}"
-
-DEPEND="xen? ( >=app-emulation/xen-3.0 )
- kvm? ( app-emulation/qemu-kvm )
- drbd? ( >=sys-cluster/drbd-8.3 )
- ipv6? ( net-misc/ndisc6 )
- dev-libs/openssl
- dev-python/paramiko
- dev-python/pyopenssl
- dev-python/pyparsing
- dev-python/pycurl
- dev-python/pyinotify
- dev-python/simplejson
- net-analyzer/arping
- net-misc/bridge-utils
- net-misc/curl[ssl]
- net-misc/openssh
- net-misc/socat
- sys-apps/iproute2
- sys-fs/lvm2
- >=sys-apps/baselayout-2.0"
-RDEPEND="${DEPEND}
- !<app-emulation/ganeti-htools-0.3"
-
-pkg_setup () {
- confutils_require_any kvm xen
-}
-
-src_prepare () {
- epatch "${FILESDIR}/${PN}-fix-start-stop.patch"
-}
-
-src_configure () {
- local myconf
- if use filestorage ; then
- myconf="--with-file-storage-dir=/var/lib/ganeti-storage/file"
- else
- myconf="--with-file-storage-dir=no"
- fi
- econf --localstatedir=/var \
- --docdir=/usr/share/doc/${P} \
- --with-ssh-initscript=/etc/init.d/sshd \
- --with-export-dir=/var/lib/ganeti-storage/export \
- --with-os-search-path=/usr/share/ganeti/os \
- $(use_enable syslog) \
- ${myconf}
-}
-
-src_install () {
- emake DESTDIR="${D}" install || die "emake install failed"
- newinitd "${FILESDIR}"/ganeti-2.1.initd ganeti
- newconfd "${FILESDIR}"/ganeti.confd ganeti
- use kvm && newinitd "${FILESDIR}"/ganeti-kvm-poweroff.initd ganeti-kvm-poweroff
- use kvm && newconfd "${FILESDIR}"/ganeti-kvm-poweroff.confd ganeti-kvm-poweroff
- newbashcomp doc/examples/bash_completion ganeti
- dodoc INSTALL UPGRADE NEWS README doc/*.rst
- rm -rf "${D}"/usr/share/doc/ganeti
- docinto examples
- #dodoc doc/examples/{basic-oob,ganeti.cron,gnt-config-backup}
- dodoc doc/examples/{ganeti.cron,gnt-config-backup}
- docinto examples/hooks
- dodoc doc/examples/hooks/{ipsec,ethers}
-
- keepdir /var/{lib,log,run}/ganeti/
- keepdir /usr/share/ganeti/os/
- keepdir /var/lib/ganeti-storage/{export,file}/
-}
-
-pkg_postinst () {
- bash-completion_pkg_postinst
-}
diff --git a/app-emulation/ganeti/ganeti-2.5.0_rc6.ebuild b/app-emulation/ganeti/ganeti-2.5.0_rc6.ebuild
deleted file mode 100644
index cd4b035e6f11..000000000000
--- a/app-emulation/ganeti/ganeti-2.5.0_rc6.ebuild
+++ /dev/null
@@ -1,124 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/ganeti-2.5.0_rc6.ebuild,v 1.1 2012/04/05 14:55:17 sping Exp $
-
-EAPI="4"
-
-inherit eutils confutils bash-completion-r1
-
-MY_PV="${PV/_rc/~rc}"
-#MY_PV="${PV/_beta/~beta}"
-MY_P="${PN}-${MY_PV}"
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://git.ganeti.org/ganeti.git"
- inherit git-2
- KEYWORDS=""
- # you will need to pull in the haskell overlay for pandoc
- GIT_DEPEND="app-text/pandoc
- dev-python/docutils
- dev-python/sphinx
- media-libs/gd[fontconfig,jpeg,png,truetype]
- media-gfx/graphviz
- media-fonts/urw-fonts"
-else
- SRC_URI="http://ganeti.googlecode.com/files/${MY_P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-DESCRIPTION="Ganeti is a virtual server management software tool"
-HOMEPAGE="http://code.google.com/p/ganeti/"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="kvm xen lxc drbd +filestorage sharedstorage htools syslog ipv6"
-
-S="${WORKDIR}/${MY_P}"
-
-DEPEND="xen? ( >=app-emulation/xen-3.0 )
- kvm? ( app-emulation/qemu-kvm )
- lxc? ( app-emulation/lxc )
- drbd? ( >=sys-cluster/drbd-8.3 )
- ipv6? ( net-misc/ndisc6 )
- htools? (
- >=dev-lang/ghc-6.10
- dev-haskell/json
- dev-haskell/curl
- dev-haskell/network
- dev-haskell/parallel )
- dev-libs/openssl
- dev-python/paramiko
- dev-python/pyopenssl
- >=dev-python/pyparsing-1.4.6
- dev-python/pycurl
- dev-python/pyinotify
- dev-python/simplejson
- net-analyzer/arping
- net-misc/bridge-utils
- net-misc/curl[ssl]
- net-misc/openssh
- net-misc/socat
- sys-apps/iproute2
- sys-fs/lvm2
- >=sys-apps/baselayout-2.0
- ${GIT_DEPEND}"
-RDEPEND="${DEPEND}
- !app-emulation/ganeti-htools"
-
-pkg_setup () {
- confutils_require_any kvm xen lxc
-}
-
-src_prepare() {
- if [[ ${PV} == "9999" ]] ; then
- ./autogen.sh
- fi
- epatch "${FILESDIR}/${PN}-fix-start-stop.patch"
-}
-
-src_configure () {
- local myconf
- if use filestorage ; then
- myconf="--with-file-storage-dir=/var/lib/ganeti-storage/file"
- else
- myconf="--with-file-storage-dir=no"
- fi
- if use sharedstorage ; then
- myconf="--with-shared-file-storage-dir=/var/lib/ganeti-storage/shared"
- else
- myconf="--with-shared-file-storage-dir=no"
- fi
- econf --localstatedir=/var \
- --docdir=/usr/share/doc/${P} \
- --with-ssh-initscript=/etc/init.d/sshd \
- --with-export-dir=/var/lib/ganeti-storage/export \
- --with-os-search-path=/usr/share/ganeti/os \
- $(use_enable syslog) \
- $(use_enable htools) \
- $(use_enable htools htools-rapi) \
- ${myconf}
-}
-
-src_install () {
- emake DESTDIR="${D}" install || die "emake install failed"
- newinitd "${FILESDIR}"/ganeti-2.1.initd ganeti
- newconfd "${FILESDIR}"/ganeti.confd ganeti
- use kvm && newinitd "${FILESDIR}"/ganeti-kvm-poweroff.initd ganeti-kvm-poweroff
- use kvm && newconfd "${FILESDIR}"/ganeti-kvm-poweroff.confd ganeti-kvm-poweroff
- newbashcomp doc/examples/bash_completion ganeti
- dodoc INSTALL UPGRADE NEWS README doc/*.rst
- rm -rf "${D}"/usr/share/doc/ganeti
- docinto examples
- #dodoc doc/examples/{basic-oob,ganeti.cron,gnt-config-backup}
- dodoc doc/examples/{ganeti.cron,gnt-config-backup}
- docinto examples/hooks
- dodoc doc/examples/hooks/{ipsec,ethers}
-
- keepdir /var/{lib,log,run}/ganeti/
- keepdir /usr/share/ganeti/os/
- keepdir /var/lib/ganeti-storage/{export,file,shared}/
-}
-
-pkg_postinst () {
- bash-completion_pkg_postinst
-}
diff --git a/app-emulation/ganeti/ganeti-2.5.0_rc5.ebuild b/app-emulation/ganeti/ganeti-2.5.1.ebuild
index 6a83b4eac3f4..f2f4f4119d53 100644
--- a/app-emulation/ganeti/ganeti-2.5.0_rc5.ebuild
+++ b/app-emulation/ganeti/ganeti-2.5.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/ganeti-2.5.0_rc5.ebuild,v 1.1 2012/03/09 04:48:43 ramereth Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/ganeti-2.5.1.ebuild,v 1.1 2012/05/12 08:10:23 ramereth Exp $
EAPI="4"
@@ -61,6 +61,7 @@ DEPEND="xen? ( >=app-emulation/xen-3.0 )
sys-apps/iproute2
sys-fs/lvm2
>=sys-apps/baselayout-2.0
+ >=dev-lang/python-2.6
${GIT_DEPEND}"
RDEPEND="${DEPEND}
!app-emulation/ganeti-htools"
@@ -88,6 +89,9 @@ src_configure () {
else
myconf="--with-shared-file-storage-dir=no"
fi
+ if use kvm && [ -f /usr/bin/qemu-kvm ] ; then
+ myconf="--with-kvm-path=/usr/bin/qemu-kvm"
+ fi
econf --localstatedir=/var \
--docdir=/usr/share/doc/${P} \
--with-ssh-initscript=/etc/init.d/sshd \
@@ -118,7 +122,3 @@ src_install () {
keepdir /usr/share/ganeti/os/
keepdir /var/lib/ganeti-storage/{export,file,shared}/
}
-
-pkg_postinst () {
- bash-completion_pkg_postinst
-}