summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2005-06-26 11:00:59 +0000
committerDaniel Black <dragonheart@gentoo.org>2005-06-26 11:00:59 +0000
commit6202480b24a7166dc1eadabe42af361fae45ffed (patch)
treeb12b2f11066026618b0706e2d2414cba1df674c5 /app-emulation/libdsk
parentcompile fixes for amd64 (see bug #93535) (diff)
downloadgentoo-2-6202480b24a7166dc1eadabe42af361fae45ffed.tar.gz
gentoo-2-6202480b24a7166dc1eadabe42af361fae45ffed.tar.bz2
gentoo-2-6202480b24a7166dc1eadabe42af361fae45ffed.zip
version bump
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'app-emulation/libdsk')
-rw-r--r--app-emulation/libdsk/ChangeLog8
-rw-r--r--app-emulation/libdsk/Manifest3
-rw-r--r--app-emulation/libdsk/files/digest-libdsk-1.1.41
-rw-r--r--app-emulation/libdsk/files/libdsk-1.1.4-destdirfix.patch11
-rw-r--r--app-emulation/libdsk/libdsk-1.1.4.ebuild40
5 files changed, 62 insertions, 1 deletions
diff --git a/app-emulation/libdsk/ChangeLog b/app-emulation/libdsk/ChangeLog
index a266d6e4202a..d2d82be5dac2 100644
--- a/app-emulation/libdsk/ChangeLog
+++ b/app-emulation/libdsk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/libdsk
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/libdsk/ChangeLog,v 1.7 2005/05/21 10:45:52 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libdsk/ChangeLog,v 1.8 2005/06/26 11:00:59 dragonheart Exp $
+
+*libdsk-1.1.4 (26 Jun 2005)
+
+ 26 Jun 2005; Daniel Black <dragonheart@gentoo.org>
+ +files/libdsk-1.1.4-destdirfix.patch, +libdsk-1.1.4.ebuild:
+ version bump
21 May 2005; Simon Stelling <blubb@gentoo.org> libdsk-1.1.0.ebuild:
added ~amd64 keyword
diff --git a/app-emulation/libdsk/Manifest b/app-emulation/libdsk/Manifest
index 002eaa2a2818..66cc99eea13a 100644
--- a/app-emulation/libdsk/Manifest
+++ b/app-emulation/libdsk/Manifest
@@ -1,4 +1,7 @@
MD5 d0dcd814ed1aaa7b21721bde2702229b ChangeLog 758
MD5 e8fd165188427455ff367b4fc471d175 libdsk-1.1.0.ebuild 698
MD5 1652522405f5936eb29776ef8d5ffa5b metadata.xml 310
+MD5 176eac134af3246d0a3368d6208edd7d libdsk-1.1.4.ebuild 912
MD5 ec130e196a8c6b8a6aa58f027e03678a files/digest-libdsk-1.1.0 64
+MD5 d2d118e767c2ff9f01e98f02b4e43cdf files/digest-libdsk-1.1.4 64
+MD5 57f6d0ef6a15482c84932239633bcbee files/libdsk-1.1.4-destdirfix.patch 509
diff --git a/app-emulation/libdsk/files/digest-libdsk-1.1.4 b/app-emulation/libdsk/files/digest-libdsk-1.1.4
new file mode 100644
index 000000000000..5e3876f99263
--- /dev/null
+++ b/app-emulation/libdsk/files/digest-libdsk-1.1.4
@@ -0,0 +1 @@
+MD5 41cecf4269acde87f1ffeecb6a0965f9 libdsk-1.1.4.tar.gz 711701
diff --git a/app-emulation/libdsk/files/libdsk-1.1.4-destdirfix.patch b/app-emulation/libdsk/files/libdsk-1.1.4-destdirfix.patch
new file mode 100644
index 000000000000..31449d256452
--- /dev/null
+++ b/app-emulation/libdsk/files/libdsk-1.1.4-destdirfix.patch
@@ -0,0 +1,11 @@
+--- lib/Makefile.in.orig 2005-06-26 20:48:09.000000000 +1000
++++ lib/Makefile.in 2005-06-26 20:48:50.000000000 +1000
+@@ -484,7 +484,7 @@
+
+ install-exec-local:
+ $(mkinstalldirs) $(libdir)
+- if test x@LIBDSKJAR@ = x; then true; else $(INSTALL_DATA) @LIBDSKJAR@ $(libdir); fi
++ if test x@LIBDSKJAR@ = x; then true; else $(INSTALL_DATA) @LIBDSKJAR@ $(DESTDIR)/$(libdir); fi
+
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/app-emulation/libdsk/libdsk-1.1.4.ebuild b/app-emulation/libdsk/libdsk-1.1.4.ebuild
new file mode 100644
index 000000000000..459a59cdcfa4
--- /dev/null
+++ b/app-emulation/libdsk/libdsk-1.1.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libdsk/libdsk-1.1.4.ebuild,v 1.1 2005/06/26 11:00:59 dragonheart Exp $
+
+inherit eutils
+
+DESCRIPTION="Disk emulation library"
+HOMEPAGE="http://www.seasip.demon.co.uk/Unix/LibDsk/"
+SRC_URI="http://www.seasip.demon.co.uk/Unix/LibDsk/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="java"
+KEYWORDS="~x86 ~ppc ~amd64"
+
+DEPEND="sys-libs/zlib
+ app-arch/bzip2
+ java? ( virtual/jdk dev-java/java-config )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-destdirfix.patch
+}
+
+src_compile() {
+ econf \
+ --with-zlib \
+ --with-bzlib \
+ --enable-floppy \
+ $(use_with java jni) \
+ --with-java-prefix=$(java-config -O) \
+ || die
+ emake || die "libdsk make failed!"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die
+ dodoc ChangeLog README TODO doc/libdsk.*
+}