summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2012-03-07 15:38:15 +0000
committerDoug Goldstein <cardoe@gentoo.org>2012-03-07 15:38:15 +0000
commit1a3457c87b2e1e87c3ef41f183dd80ed60a158c5 (patch)
tree03dfcded4ceb632d45fc7d386b709a089e24ab75 /app-emulation/libvirt-glib
parentfix typo with non-multilib archs (diff)
downloadgentoo-2-1a3457c87b2e1e87c3ef41f183dd80ed60a158c5.tar.gz
gentoo-2-1a3457c87b2e1e87c3ef41f183dd80ed60a158c5.tar.bz2
gentoo-2-1a3457c87b2e1e87c3ef41f183dd80ed60a158c5.zip
Version bump.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/libvirt-glib')
-rw-r--r--app-emulation/libvirt-glib/ChangeLog7
-rw-r--r--app-emulation/libvirt-glib/libvirt-glib-0.0.6.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/app-emulation/libvirt-glib/ChangeLog b/app-emulation/libvirt-glib/ChangeLog
index efa027ff0021..34b105c7fb7e 100644
--- a/app-emulation/libvirt-glib/ChangeLog
+++ b/app-emulation/libvirt-glib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/libvirt-glib
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt-glib/ChangeLog,v 1.7 2012/01/16 21:44:37 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt-glib/ChangeLog,v 1.8 2012/03/07 15:38:15 cardoe Exp $
+
+*libvirt-glib-0.0.6 (07 Mar 2012)
+
+ 07 Mar 2012; Doug Goldstein <cardoe@gentoo.org> +libvirt-glib-0.0.6.ebuild:
+ Version bump.
16 Jan 2012; Nirbheek Chauhan <nirbheek@gentoo.org>
-libvirt-glib-0.0.1.ebuild, -libvirt-glib-0.0.3.ebuild:
diff --git a/app-emulation/libvirt-glib/libvirt-glib-0.0.6.ebuild b/app-emulation/libvirt-glib/libvirt-glib-0.0.6.ebuild
new file mode 100644
index 000000000000..41b966e60374
--- /dev/null
+++ b/app-emulation/libvirt-glib/libvirt-glib-0.0.6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt-glib/libvirt-glib-0.0.6.ebuild,v 1.1 2012/03/07 15:38:15 cardoe Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 python
+
+DESCRIPTION="GLib and GObject mappings for libvirt"
+HOMEPAGE="http://libvirt.org/git/?p=libvirt-glib.git"
+SRC_URI="ftp://libvirt.org/libvirt/glib/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc +introspection python +vala"
+REQUIRED_USE="vala? ( introspection )"
+
+# 0.9.8 is needed for VIR_DOMAIN_EVENT_SHUTDOWN
+RDEPEND="
+ dev-libs/libxml2:2
+ >=app-emulation/libvirt-0.9.8
+ >=dev-libs/glib-2.10:2
+ introspection? ( >=dev-libs/gobject-introspection-0.10.8 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1.10 )
+ vala? ( dev-lang/vala:0.14 )"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog NEWS README"
+ G2CONF="--disable-test-coverage
+ VAPIGEN=$(type -P vapigen-0.14)
+ $(use_enable introspection)
+ $(use_enable vala)
+ $(use_with python)"
+
+ python_set_active_version 2
+ python_pkg_setup
+}