summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-08-01 03:17:51 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-08-01 03:17:51 +0000
commit7b870e74eabfaee5bf731fe1e6c56b74aa6fdbc2 (patch)
tree0903fff5ba8329e4d2fa83ec78b399712f788ff7 /app-emulation/lxc
parentDrop hppa STAGE1_CFLAGS hack (bug #326539). (diff)
downloadgentoo-2-7b870e74eabfaee5bf731fe1e6c56b74aa6fdbc2.tar.gz
gentoo-2-7b870e74eabfaee5bf731fe1e6c56b74aa6fdbc2.tar.bz2
gentoo-2-7b870e74eabfaee5bf731fe1e6c56b74aa6fdbc2.zip
Version bump, add the long-requested init script (protected with a USE=vanilla for those preferring not to have it).
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/lxc')
-rw-r--r--app-emulation/lxc/ChangeLog9
-rw-r--r--app-emulation/lxc/files/lxc.initd67
-rw-r--r--app-emulation/lxc/lxc-0.7.2.ebuild107
-rw-r--r--app-emulation/lxc/metadata.xml10
4 files changed, 192 insertions, 1 deletions
diff --git a/app-emulation/lxc/ChangeLog b/app-emulation/lxc/ChangeLog
index c578f0bb562b..1f7c68870a8d 100644
--- a/app-emulation/lxc/ChangeLog
+++ b/app-emulation/lxc/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emulation/lxc
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/lxc/ChangeLog,v 1.13 2010/06/28 00:00:08 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/lxc/ChangeLog,v 1.14 2010/08/01 03:17:50 flameeyes Exp $
+
+*lxc-0.7.2 (01 Aug 2010)
+
+ 01 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org> +lxc-0.7.2.ebuild,
+ +files/lxc.initd, metadata.xml:
+ Version bump, add the long-requested init script (protected with a
+ USE=vanilla for those preferring not to have it).
*lxc-0.7.1 (28 Jun 2010)
diff --git a/app-emulation/lxc/files/lxc.initd b/app-emulation/lxc/files/lxc.initd
new file mode 100644
index 000000000000..99706980cb2d
--- /dev/null
+++ b/app-emulation/lxc/files/lxc.initd
@@ -0,0 +1,67 @@
+#!/sbin/runscript
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/lxc/files/lxc.initd,v 1.1 2010/08/01 03:17:51 flameeyes Exp $
+
+CONTAINER=${SVCNAME#*.}
+CONFIGFILE=${CONFIGFILE:-/etc/lxc/${CONTAINER}.conf}
+
+depend() {
+ need net.lo localmount
+}
+
+checkconfig() {
+ if [ ${CONTAINER} = ${SVCNAME} ]; then
+ eerror "You have to create an init script for each container:"
+ eerror " ln -s lxc /etc/init.d/lxc.container"
+ return 1
+ fi
+}
+
+rootpath() {
+ sed -n -e 's:^[ \t]*lxc.rootfs[ \t]*=[ \t]*\(.*\)$:\1:p' ${CONFIGFILE}
+}
+
+start() {
+ checkconfig || return 1
+
+ rm /var/log/lxc/${CONTAINER}.log
+
+ # Check the format of our init and the chroot's init, to see if we
+ # have to use linux32 or linux64…
+ case $(scanelf -BF '%M#f' /sbin/init $(rootpath)/sbin/init | tr '\n' ':') in
+ ELFCLASS64:ELFCLASS64:) setarch=;;
+ ELFCLASS32:ELFCLASS32:) setarch=;;
+ ELFCLASS32:ELFCLASS64:) setarch=linux64;;
+ ELFCLASS64:ELFCLASS32:) setarch=linux32;;
+ esac
+
+ mkdir -p /var/log/lxc
+
+ ebegin "Starting ${CONTAINER}"
+ ${setarch} lxc-start -n ${CONTAINER} -f ${CONFIGFILE} -d -o /var/log/lxc/${CONTAINER}.log
+ eend $?
+}
+
+stop() {
+ checkconfig || return 1
+
+ local init_pid=$(head -n1 /cgroup/${CONTAINER}/tasks)
+
+ ebegin "Shutting down system in ${CONTAINER}"
+ kill -INT ${init_pid}
+ eend $?
+
+ sleep 15
+
+ missingprocs=$(pgrep -P ${init_pid})
+
+ if [ -n "${missingprocs}" ]; then
+ ewarn "Something failed to properly shut down in ${CONTAINER}"
+ fi
+
+ ebegin "Stopping ${CONTAINER}"
+ lxc-stop -n ${CONTAINER}
+ eend $?
+}
+
diff --git a/app-emulation/lxc/lxc-0.7.2.ebuild b/app-emulation/lxc/lxc-0.7.2.ebuild
new file mode 100644
index 000000000000..ccf6066c7099
--- /dev/null
+++ b/app-emulation/lxc/lxc-0.7.2.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/lxc/lxc-0.7.2.ebuild,v 1.1 2010/08/01 03:17:50 flameeyes Exp $
+
+EAPI="2"
+
+inherit eutils linux-info versionator base
+
+DESCRIPTION="LinuX Containers userspace utilities"
+HOMEPAGE="http://lxc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE="doc examples vanilla"
+
+RDEPEND="sys-libs/libcap"
+
+DEPEND="${RDEPEND}
+ doc? ( app-text/docbook-sgml-utils )
+ >=sys-kernel/linux-headers-2.6.29"
+
+# For init script, so protect with vanilla, they are not strictly
+# needed.
+RDEPEND="${RDEPEND}
+ vanilla? (
+ sys-apps/util-linux
+ app-misc/pax-utils
+ )"
+
+CONFIG_CHECK="~CGROUPS
+ ~CGROUP_NS ~CPUSETS ~CGROUP_CPUACCT
+ ~RESOURCE_COUNTERS ~CGROUP_MEM_RES_CTLR
+ ~CGROUP_SCHED
+
+ ~NAMESPACES
+ ~IPC_NS ~USER_NS ~PID_NS
+
+ ~DEVPTS_MULTIPLE_INSTANCES
+ ~CGROUP_FREEZER
+ ~UTS_NS ~NET_NS
+ ~VETH ~MACVLAN"
+
+ERROR_DEVPTS_MULTIPLE_INSTANCES="CONFIG_DEVPTS_MULTIPLE_INSTANCES: needed for pts inside container"
+
+ERROR_CGROUP_FREEZER="CONFIG_CGROUP_FREEZER: needed to freeze containers"
+
+ERROR_UTS_NS="CONFIG_UTS_NS: needed to unshare hostnames and uname info"
+ERROR_NET_NS="CONFIG_NET_NS: needed for unshared network"
+
+ERROR_VETH="CONFIG_VETH: needed for internal (inter-container) networking"
+ERROR_MACVLAN="CONFIG_MACVLAN: needed for internal (inter-container) networking"
+
+src_configure() {
+ econf \
+ --localstatedir=/var \
+ --bindir=/usr/sbin \
+ --docdir=/usr/share/doc/${PF} \
+ --with-config-path=/etc/lxc \
+ $(use_enable doc) \
+ $(use_enable examples) \
+ || die "configure failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+
+ dodoc AUTHORS CONTRIBUTING MAINTAINERS \
+ NEWS TODO README doc/FAQ.txt || die "dodoc failed"
+
+ # If the documentation is going to be rebuilt, the Makefiles will
+ # install the man pages themselves; if we're not going to, we
+ # still need to install them, as they are provided with the
+ # tarball in recent versions.
+ if ! use doc; then
+ doman doc/*.{1,5,7} || die
+ fi
+
+ rm -r "${D}"/usr/sbin/lxc-{setcap,ls} \
+ "${D}"/usr/share/man/man1/lxc-ls.1 \
+ || die "unable to remove extraenous content"
+
+ keepdir /etc/lxc
+
+ find "${D}" -name '*.la' -delete
+
+ use vanilla && return 0
+
+ # Gentoo-specific additions!
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+}
+
+pkg_postinst() {
+ if ! use vanilla; then
+ elog "There is an init script provided with the package now; no documentation"
+ elog "is currently available though, so please check out /etc/init.d/lxc ."
+ elog "You _should_ only need to symlink it to /etc/init.d/lxc.configname"
+ elog "to start the container defined into /etc/lxc/configname.conf ."
+ elog "For further information about LXC development see"
+ elog "http://blog.flameeyes.eu/tag/lxc" # remove once proper doc is available
+ elog ""
+ fi
+ ewarn "To use the lxc-debian and lxc-fedora commands, you need respectively"
+ ewarn "dev-util/debootstrap and sys-apps/yum."
+}
diff --git a/app-emulation/lxc/metadata.xml b/app-emulation/lxc/metadata.xml
index 5865a9b99939..694fd72ce5d0 100644
--- a/app-emulation/lxc/metadata.xml
+++ b/app-emulation/lxc/metadata.xml
@@ -8,4 +8,14 @@
<maintainer>
<email>dev-zero@gentoo.org</email>
</maintainer>
+
+ <use>
+ <flag name="vanilla">
+ Avoid adding Gentoo Linux-specific modifications, which include
+ the custom init script. This is present as a flag to avoid
+ forcing dependencies over users that might not want have them
+ around as they use LXC in contexts where the init script is not
+ useful.
+ </flag>
+ </use>
</pkgmetadata>