summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVadim Kuznetsov <vadimk@gentoo.org>2009-08-23 23:22:05 +0000
committerVadim Kuznetsov <vadimk@gentoo.org>2009-08-23 23:22:05 +0000
commit0714b897037ae713d0ac4db1738dd0cf0d5db7cc (patch)
tree4c71fef17d0129bc6eaac7aa1d33fd9f650f439f /app-emulation/open-vm-tools
parentremove quotes from Martin Piskernig as his request (bug #282420) (diff)
downloadgentoo-2-0714b897037ae713d0ac4db1738dd0cf0d5db7cc.tar.gz
gentoo-2-0714b897037ae713d0ac4db1738dd0cf0d5db7cc.tar.bz2
gentoo-2-0714b897037ae713d0ac4db1738dd0cf0d5db7cc.zip
clean up old ebuilds
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/open-vm-tools')
-rw-r--r--app-emulation/open-vm-tools/ChangeLog8
-rw-r--r--app-emulation/open-vm-tools/open-vm-tools-0.0.20080515.93241.ebuild147
-rw-r--r--app-emulation/open-vm-tools/open-vm-tools-0.0.20080808.109361-r1.ebuild126
-rw-r--r--app-emulation/open-vm-tools/open-vm-tools-0.0.20081223.137496.ebuild124
4 files changed, 7 insertions, 398 deletions
diff --git a/app-emulation/open-vm-tools/ChangeLog b/app-emulation/open-vm-tools/ChangeLog
index 1faae48324dc..85593ae9cacb 100644
--- a/app-emulation/open-vm-tools/ChangeLog
+++ b/app-emulation/open-vm-tools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/open-vm-tools
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools/ChangeLog,v 1.23 2009/07/24 23:12:56 vadimk Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools/ChangeLog,v 1.24 2009/08/23 23:22:05 vadimk Exp $
+
+ 23 Aug 2009; Vadim Kuznetsov vadimk@gentoo.org
+ -open-vm-tools-0.0.20080515.93241.ebuild,
+ -open-vm-tools-0.0.20080808.109361-r1.ebuild,
+ -open-vm-tools-0.0.20081223.137496.ebuild:
+ clean up old ebuilds
*open-vm-tools-0.0.20090722.179896 (24 Jul 2009)
diff --git a/app-emulation/open-vm-tools/open-vm-tools-0.0.20080515.93241.ebuild b/app-emulation/open-vm-tools/open-vm-tools-0.0.20080515.93241.ebuild
deleted file mode 100644
index 6daa30a2087b..000000000000
--- a/app-emulation/open-vm-tools/open-vm-tools-0.0.20080515.93241.ebuild
+++ /dev/null
@@ -1,147 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools/open-vm-tools-0.0.20080515.93241.ebuild,v 1.1 2008/07/06 19:41:28 ikelos Exp $
-
-inherit pam eutils linux-mod autotools versionator
-
-MY_DATE="$(get_version_component_range 3)"
-MY_BUILD="$(get_version_component_range 4)"
-MY_PV="${MY_DATE:0:4}.${MY_DATE:4:2}.${MY_DATE:6:2}-${MY_BUILD}"
-MY_P="${PN}-${MY_PV}"
-
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="Opensourced tools for VMware guests"
-HOMEPAGE="http://open-vm-tools.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-IUSE="X xinerama icu"
-DEPEND="
- virtual/linux-sources
- sys-apps/ethtool
- X? (
- x11-libs/libX11
- x11-libs/gtk+
- )
- xinerama? (
- x11-libs/libXinerama
- )
- !app-emulation/vmware-workstation-tools
- !app-emulation/vmware-server-tools
- !app-emulation/vmware-esx-tools
- sys-process/procps
- dev-libs/libdnet
- icu? ( dev-libs/icu )
- "
-
-RDEPEND="${DEPEND/virtual\/linux\-sources/}
- virtual/pam
- X? (
- x11-base/xorg-server
- x11-drivers/xf86-video-vmware
- x11-drivers/xf86-input-vmmouse
- )
-"
-
-VMWARE_MOD_DIR="modules/linux"
-VMWARE_MODULE_LIST="vmblock vmhgfs vmsync vmmemctl vmxnet"
-
-pkg_setup() {
-
- linux-mod_pkg_setup
- MODULE_NAMES=""
- BUILD_TARGETS="auto-build HEADER_DIR=${KERNEL_DIR}/include BUILD_DIR=${KV_OUT_DIR}"
-
- for mod in ${VMWARE_MODULE_LIST};
- do
- if [[ "${mod}" == "vmxnet" ]];
- then
- MODTARGET="net"
- else
- MODTARGET="openvmtools"
- fi
- MODULE_NAMES="${MODULE_NAMES} ${mod}(${MODTARGET}:${S}/${VMWARE_MOD_DIR}/${mod})"
- done
-
- ewarn "If you're compiling for a hardened target, please use the hardened"
- ewarn "nopie compiler in the hardened profile (select it using gcc-config)."
- ewarn "For more details please see bug #200376, comment 18."
-
- enewgroup vmware
-
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/default-scripts.patch"
-
- eautoreconf
-}
-
-src_compile() {
- econf \
- $(use_with icu) \
- $(use_with X x) \
- $(use_enable xinerama multimon) \
- || die "Error: econf failed!"
-
- linux-mod_src_compile
-
- emake || die
-}
-
-src_install() {
-
- linux-mod_src_install
-
- pamd_mimic_system vmware-guestd auth account
-
- # Install the various tools
- cd "${S}"
- VMWARE_BIN_LIST="hgfsclient xferlogs"
- VMWARE_SBIN_LIST="guestd checkvm"
- if use X; then
- # Fix up the vmware-user tool's name
- mv vmware-user/vmware-user vmware-user/user
- mv vmware-user user
- VMWARE_BIN_LIST="${VMWARE_BIN_LIST} user toolbox"
- fi
- for i in ${VMWARE_BIN_LIST}; do
- newbin ${i}/${i} vmware-${i} || die "Failed installing ${i}"
- done
- for i in ${VMWARE_SBIN_LIST}; do
- newsbin ${i}/${i} vmware-${i} || die "Failed installing ${i}"
- done
-
- dolib libguestlib/.libs/libguestlib.{so.0.0.0,a}
-
- # Deal with the hgfsmounter
- into /
- newsbin hgfsmounter/hgfsmounter mount.vmhgfs
- fperms u+s /sbin/mount.vmhgfs
- ### FROM THIS POINT ON, into IS SET TO ${ROOT}/ not ${ROOT}/usr !!!
-
- # Install the /etc/ files
- exeinto /etc/vmware-tools
- doexe scripts/linux/*
- insinto /etc/vmware-tools
- doins "${FILESDIR}/tools.conf"
- # Only install this, when X is being used. Else it's useless waste of
- # ressources when checking continuously for processes that will never appear
- use X && doins "${FILESDIR}/xautostart.conf"
- newinitd "${FILESDIR}/open-vm.initd" vmware-tools
- newconfd "${FILESDIR}/open-vm.confd" vmware-tools
-
- if use X;
- then
- elog "To be able to use the drag'n'drop feature of VMware for file"
- elog "exchange, you need to do this:"
- elog " Add 'vmware-tools' to your default runlevel"
- elog " Add the users which should have access to this function"
- elog " to the group 'vmware'"
- fi
-}
diff --git a/app-emulation/open-vm-tools/open-vm-tools-0.0.20080808.109361-r1.ebuild b/app-emulation/open-vm-tools/open-vm-tools-0.0.20080808.109361-r1.ebuild
deleted file mode 100644
index ec5c6a390277..000000000000
--- a/app-emulation/open-vm-tools/open-vm-tools-0.0.20080808.109361-r1.ebuild
+++ /dev/null
@@ -1,126 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools/open-vm-tools-0.0.20080808.109361-r1.ebuild,v 1.3 2008/11/19 10:26:24 ikelos Exp $
-
-inherit pam eutils linux-mod versionator
-
-MY_DATE="$(get_version_component_range 3)"
-MY_BUILD="$(get_version_component_range 4)"
-MY_PV="${MY_DATE:0:4}.${MY_DATE:4:2}.${MY_DATE:6:2}-${MY_BUILD}"
-MY_P="${PN}-${MY_PV}"
-
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="Opensourced tools for VMware guests"
-HOMEPAGE="http://open-vm-tools.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-IUSE="X xinerama icu unity"
-DEPEND="
- virtual/linux-sources
- sys-apps/ethtool
- X? (
- x11-libs/libX11
- x11-libs/gtk+
- )
- unity? (
- x11-libs/libXScrnSaver
- dev-libs/uriparser
- )
- xinerama? (
- x11-libs/libXinerama
- )
- !app-emulation/vmware-workstation-tools
- !app-emulation/vmware-server-tools
- !app-emulation/vmware-esx-tools
- sys-process/procps
- dev-libs/libdnet
- icu? ( dev-libs/icu )
- "
-
-RDEPEND="${DEPEND/virtual\/linux\-sources/}
- virtual/pam
- X? (
- x11-base/xorg-server
- x11-drivers/xf86-video-vmware
- x11-drivers/xf86-input-vmmouse
- )
- unity? (
- x11-libs/libXScrnSaver
- dev-libs/uriparser
- )
-"
-
-VMWARE_MOD_DIR="modules/linux"
-VMWARE_MODULE_LIST="vmblock vmhgfs vmsync vmmemctl vmxnet"
-
-pkg_setup() {
-
- linux-mod_pkg_setup
- MODULE_NAMES=""
- BUILD_TARGETS="auto-build HEADER_DIR=${KERNEL_DIR}/include BUILD_DIR=${KV_OUT_DIR}"
-
- for mod in ${VMWARE_MODULE_LIST};
- do
- if [[ "${mod}" == "vmxnet" ]];
- then
- MODTARGET="net"
- else
- MODTARGET="openvmtools"
- fi
- MODULE_NAMES="${MODULE_NAMES} ${mod}(${MODTARGET}:${S}/${VMWARE_MOD_DIR}/${mod})"
- done
-
- ewarn "If you're compiling with a hardened toolchain, please use the"
- ewarn "hardenednopie gcc profile (see bug #200376, comment 18)."
-
- enewgroup vmware
-
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/default-scripts.patch"
-}
-
-src_compile() {
- econf \
- --without-kernel-modules \
- $(use_with icu) \
- $(use_with X x) \
- $(use_enable unity) \
- $(use_enable xinerama multimon) \
- || die "Error: econf failed!"
-
- linux-mod_src_compile
-
- emake || die
-}
-
-src_install() {
-
- linux-mod_src_install
-
- pamd_mimic_system vmware-guestd auth account
-
- emake install DESTDIR="${D}" || die "Failed to install"
-
- newinitd "${FILESDIR}/open-vm.initd" vmware-tools
- newconfd "${FILESDIR}/open-vm.confd" vmware-tools
-
- if use X;
- then
- exeinto /etc/X11/xinit/xinitrc.d
- doexe "${FILESDIR}/10-vmware-tools"
-
- elog "To be able to use the drag'n'drop feature of VMware for file"
- elog "exchange, you need to do this:"
- elog " Add 'vmware-tools' to your default runlevel"
- elog " Add the users which should have access to this function"
- elog " to the group 'vmware'"
- fi
-}
diff --git a/app-emulation/open-vm-tools/open-vm-tools-0.0.20081223.137496.ebuild b/app-emulation/open-vm-tools/open-vm-tools-0.0.20081223.137496.ebuild
deleted file mode 100644
index ce623a3022c3..000000000000
--- a/app-emulation/open-vm-tools/open-vm-tools-0.0.20081223.137496.ebuild
+++ /dev/null
@@ -1,124 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools/open-vm-tools-0.0.20081223.137496.ebuild,v 1.2 2009/01/25 13:19:44 ikelos Exp $
-
-inherit pam eutils linux-mod versionator
-
-MY_DATE="$(get_version_component_range 3)"
-MY_BUILD="$(get_version_component_range 4)"
-MY_PV="${MY_DATE:0:4}.${MY_DATE:4:2}.${MY_DATE:6:2}-${MY_BUILD}"
-MY_P="${PN}-${MY_PV}"
-
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="Opensourced tools for VMware guests"
-HOMEPAGE="http://open-vm-tools.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-IUSE="X xinerama icu unity"
-DEPEND="
- virtual/linux-sources
- sys-apps/ethtool
- X? (
- x11-libs/libX11
- x11-libs/gtk+
- )
- unity? (
- x11-libs/libXScrnSaver
- dev-libs/uriparser
- )
- xinerama? (
- x11-libs/libXinerama
- )
- !app-emulation/vmware-workstation-tools
- !app-emulation/vmware-server-tools
- !app-emulation/vmware-esx-tools
- sys-process/procps
- dev-libs/libdnet
- icu? ( dev-libs/icu )
- "
-
-RDEPEND="${DEPEND/virtual\/linux\-sources/}
- virtual/pam
- X? (
- x11-base/xorg-server
- x11-drivers/xf86-video-vmware
- x11-drivers/xf86-input-vmmouse
- )
- unity? (
- x11-libs/libXScrnSaver
- dev-libs/uriparser
- )
-"
-
-VMWARE_MOD_DIR="modules/linux"
-VMWARE_MODULE_LIST="vmblock vmhgfs vmsync vmmemctl vmxnet"
-
-pkg_setup() {
- use unity && ! use xinerama && \
- die 'The Unity USE flag requires USE="xinerama" as well'
-
- linux-mod_pkg_setup
- MODULE_NAMES=""
- BUILD_TARGETS="auto-build HEADER_DIR=${KERNEL_DIR}/include BUILD_DIR=${KV_OUT_DIR}"
-
- for mod in ${VMWARE_MODULE_LIST};
- do
- if [[ "${mod}" == "vmxnet" ]];
- then
- MODTARGET="net"
- else
- MODTARGET="openvmtools"
- fi
- MODULE_NAMES="${MODULE_NAMES} ${mod}(${MODTARGET}:${S}/${VMWARE_MOD_DIR}/${mod})"
- done
-
- enewgroup vmware
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/default-scripts.patch"
-}
-
-src_compile() {
- econf \
- --without-kernel-modules \
- $(use_with icu) \
- $(use_with X x) \
- $(use_enable unity) \
- $(use_enable xinerama multimon) \
- || die "Error: econf failed!"
-
- linux-mod_src_compile
-
- emake || die
-}
-
-src_install() {
-
- linux-mod_src_install
-
- pamd_mimic_system vmware-guestd auth account
-
- emake install DESTDIR="${D}" || die "Failed to install"
-
- newinitd "${FILESDIR}/open-vm.initd" vmware-tools
- newconfd "${FILESDIR}/open-vm.confd" vmware-tools
-
- if use X;
- then
- exeinto /etc/X11/xinit/xinitrc.d
- doexe "${FILESDIR}/10-vmware-tools"
-
- elog "To be able to use the drag'n'drop feature of VMware for file"
- elog "exchange, you need to do this:"
- elog " Add 'vmware-tools' to your default runlevel"
- elog " Add the users which should have access to this function"
- elog " to the group 'vmware'"
- fi
-}