summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Auty <ikelos@gentoo.org>2009-02-08 20:28:09 +0000
committerMike Auty <ikelos@gentoo.org>2009-02-08 20:28:09 +0000
commita27bf08695b31bfeec9c8d8b1d23968e918d17b4 (patch)
tree26ddf20cd8f973899fd3800915d1c530d3498a92 /app-emulation/open-vm-tools
parentRemoving ruby16 and ruby19 from USE_RUBY, minor cleanup (diff)
downloadgentoo-2-a27bf08695b31bfeec9c8d8b1d23968e918d17b4.tar.gz
gentoo-2-a27bf08695b31bfeec9c8d8b1d23968e918d17b4.tar.bz2
gentoo-2-a27bf08695b31bfeec9c8d8b1d23968e918d17b4.zip
Version bump, fixes bug 256678. Thanks to John Plesmid for the testing.
(Portage version: 2.2_rc23/cvs/Linux i686)
Diffstat (limited to 'app-emulation/open-vm-tools')
-rw-r--r--app-emulation/open-vm-tools/ChangeLog9
-rw-r--r--app-emulation/open-vm-tools/files/2.6.28.1-api-break.patch20
-rw-r--r--app-emulation/open-vm-tools/files/open-vm-tools.desktop7
-rw-r--r--app-emulation/open-vm-tools/open-vm-tools-0.0.20090121.142982.ebuild125
4 files changed, 160 insertions, 1 deletions
diff --git a/app-emulation/open-vm-tools/ChangeLog b/app-emulation/open-vm-tools/ChangeLog
index 1c3312c06140..54e0e6951973 100644
--- a/app-emulation/open-vm-tools/ChangeLog
+++ b/app-emulation/open-vm-tools/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emulation/open-vm-tools
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools/ChangeLog,v 1.14 2009/01/25 13:19:44 ikelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools/ChangeLog,v 1.15 2009/02/08 20:28:08 ikelos Exp $
+
+*open-vm-tools-0.0.20090121.142982 (08 Feb 2009)
+
+ 08 Feb 2009; Mike Auty <ikelos@gentoo.org>
+ +files/2.6.28.1-api-break.patch, +files/open-vm-tools.desktop,
+ +open-vm-tools-0.0.20090121.142982.ebuild:
+ Version bump, fixes bug 256678. Thanks to John Plesmid for the testing.
25 Jan 2009; Mike Auty <ikelos@gentoo.org>
open-vm-tools-0.0.20081223.137496.ebuild:
diff --git a/app-emulation/open-vm-tools/files/2.6.28.1-api-break.patch b/app-emulation/open-vm-tools/files/2.6.28.1-api-break.patch
new file mode 100644
index 000000000000..9eb6463c4b66
--- /dev/null
+++ b/app-emulation/open-vm-tools/files/2.6.28.1-api-break.patch
@@ -0,0 +1,20 @@
+diff --git a/modules/linux/vmhgfs/page.c b/modules/linux/vmhgfs/page.c
+index 4fc9b53..d4a5d26 100644
+--- a/modules/linux/vmhgfs/page.c
++++ b/modules/linux/vmhgfs/page.c
+@@ -864,7 +864,15 @@ HgfsWriteBegin(struct file *file, // IN: File to be written
+ unsigned pageTo = pos + len;
+ struct page *page;
+
++ /*
++ * AOP_FLAG_NOFS was defined in the same changeset that
++ * grab_cach_page_write_bring() was introduced.
++ */
++#ifdef AOP_FLAG_NOFS
++ page = grab_cache_page_write_begin(mapping, index, flags);
++#else
+ page = __grab_cache_page(mapping, index);
++#endif
+ if (page == NULL) {
+ return -ENOMEM;
+ }
diff --git a/app-emulation/open-vm-tools/files/open-vm-tools.desktop b/app-emulation/open-vm-tools/files/open-vm-tools.desktop
new file mode 100644
index 000000000000..2107a62e0be0
--- /dev/null
+++ b/app-emulation/open-vm-tools/files/open-vm-tools.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Encoding=UTF-8
+Type=Application
+Exec=vmware-user
+Name=VMware User Agent
+X-KDE-autostart-phase=1
+NoDisplay=true
diff --git a/app-emulation/open-vm-tools/open-vm-tools-0.0.20090121.142982.ebuild b/app-emulation/open-vm-tools/open-vm-tools-0.0.20090121.142982.ebuild
new file mode 100644
index 000000000000..6eee7666b92b
--- /dev/null
+++ b/app-emulation/open-vm-tools/open-vm-tools-0.0.20090121.142982.ebuild
@@ -0,0 +1,125 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools/open-vm-tools-0.0.20090121.142982.ebuild,v 1.1 2009/02/08 20:28:08 ikelos Exp $
+
+inherit pam eutils linux-mod versionator
+
+MY_DATE="$(get_version_component_range 3)"
+MY_BUILD="$(get_version_component_range 4)"
+MY_PV="${MY_DATE:0:4}.${MY_DATE:4:2}.${MY_DATE:6:2}-${MY_BUILD}"
+MY_P="${PN}-${MY_PV}"
+
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Opensourced tools for VMware guests"
+HOMEPAGE="http://open-vm-tools.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="X xinerama icu unity"
+DEPEND="
+ virtual/linux-sources
+ sys-apps/ethtool
+ X? (
+ x11-libs/libX11
+ x11-libs/gtk+
+ )
+ unity? (
+ x11-libs/libXScrnSaver
+ dev-libs/uriparser
+ )
+ xinerama? (
+ x11-libs/libXinerama
+ )
+ !app-emulation/vmware-workstation-tools
+ !app-emulation/vmware-server-tools
+ !app-emulation/vmware-esx-tools
+ sys-process/procps
+ dev-libs/libdnet
+ icu? ( dev-libs/icu )
+ "
+
+RDEPEND="${DEPEND/virtual\/linux\-sources/}
+ virtual/pam
+ X? (
+ x11-base/xorg-server
+ x11-drivers/xf86-video-vmware
+ x11-drivers/xf86-input-vmmouse
+ )
+ unity? (
+ x11-libs/libXScrnSaver
+ dev-libs/uriparser
+ )
+"
+
+VMWARE_MOD_DIR="modules/linux"
+VMWARE_MODULE_LIST="vmblock vmhgfs vmsync vmmemctl vmxnet"
+
+pkg_setup() {
+ use unity && ! use xinerama && \
+ die 'The Unity USE flag requires USE="xinerama" as well'
+
+ linux-mod_pkg_setup
+ MODULE_NAMES=""
+ BUILD_TARGETS="auto-build HEADER_DIR=${KERNEL_DIR}/include BUILD_DIR=${KV_OUT_DIR}"
+
+ for mod in ${VMWARE_MODULE_LIST};
+ do
+ if [[ "${mod}" == "vmxnet" ]];
+ then
+ MODTARGET="net"
+ else
+ MODTARGET="openvmtools"
+ fi
+ MODULE_NAMES="${MODULE_NAMES} ${mod}(${MODTARGET}:${S}/${VMWARE_MOD_DIR}/${mod})"
+ done
+
+ enewgroup vmware
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/2.6.28.1-api-break.patch"
+ epatch "${FILESDIR}/default-scripts.patch"
+}
+
+src_compile() {
+ econf \
+ --without-kernel-modules \
+ $(use_with icu) \
+ $(use_with X x) \
+ $(use_enable unity) \
+ $(use_enable xinerama multimon) \
+ || die "Error: econf failed!"
+
+ linux-mod_src_compile
+
+ emake || die
+}
+
+src_install() {
+
+ linux-mod_src_install
+
+ pamd_mimic_system vmware-guestd auth account
+
+ emake install DESTDIR="${D}" || die "Failed to install"
+
+ newinitd "${FILESDIR}/open-vm.initd" vmware-tools
+ newconfd "${FILESDIR}/open-vm.confd" vmware-tools
+
+ if use X;
+ then
+ insinto /etc/xdg/autostart
+ doins "${FILESDIR}/open-vm-tools.desktop"
+
+ elog "To be able to use the drag'n'drop feature of VMware for file"
+ elog "exchange, you need to do this:"
+ elog " Add 'vmware-tools' to your default runlevel"
+ elog " Add the users which should have access to this function"
+ elog " to the group 'vmware'"
+ fi
+}