summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2013-10-14 18:57:04 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2013-10-14 18:57:04 +0000
commitda93d4a0a6fc4f5f97a6c98640b54fa98acdab15 (patch)
treeb424933d004344a23f8d430355f326dc151a3940 /app-emulation/q4wine
parentRemove USE=yaml since the libyaml dependency is no longer optional in Ruby 2.... (diff)
downloadgentoo-2-da93d4a0a6fc4f5f97a6c98640b54fa98acdab15.tar.gz
gentoo-2-da93d4a0a6fc4f5f97a6c98640b54fa98acdab15.tar.bz2
gentoo-2-da93d4a0a6fc4f5f97a6c98640b54fa98acdab15.zip
Revbump to use system's qtsingleapplication package. Bug #487540. Patch by John Brezerk <brezerk@gmail.com>. Also change package version format to comply with portage standards
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key C2BA7F3C!)
Diffstat (limited to 'app-emulation/q4wine')
-rw-r--r--app-emulation/q4wine/ChangeLog10
-rw-r--r--app-emulation/q4wine/files/q4wine-qtsingleapp.patch15
-rw-r--r--app-emulation/q4wine/q4wine-1.0_p3-r1.ebuild68
3 files changed, 92 insertions, 1 deletions
diff --git a/app-emulation/q4wine/ChangeLog b/app-emulation/q4wine/ChangeLog
index 3999fe027e03..a8866a6df861 100644
--- a/app-emulation/q4wine/ChangeLog
+++ b/app-emulation/q4wine/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-emulation/q4wine
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/q4wine/ChangeLog,v 1.43 2013/06/27 12:55:22 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/q4wine/ChangeLog,v 1.44 2013/10/14 18:57:04 hwoarang Exp $
+
+*q4wine-1.0_p3-r1 (14 Oct 2013)
+
+ 14 Oct 2013; Markos Chandras <hwoarang@gentoo.org>
+ +files/q4wine-qtsingleapp.patch, +q4wine-1.0_p3-r1.ebuild:
+ Revbump to use system's qtsingleapplication package. Bug #487540. Patch by
+ John Brezerk <brezerk@gmail.com>. Also change package version format to comply
+ with portage standards
27 Jun 2013; Michael Palimaka <kensington@gentoo.org> -q4wine-0.121.ebuild,
-q4wine-1.0-r1.ebuild, -q4wine-1.0-r2.ebuild:
diff --git a/app-emulation/q4wine/files/q4wine-qtsingleapp.patch b/app-emulation/q4wine/files/q4wine-qtsingleapp.patch
new file mode 100644
index 000000000000..803284dbdb17
--- /dev/null
+++ b/app-emulation/q4wine/files/q4wine-qtsingleapp.patch
@@ -0,0 +1,15 @@
+https://github.com/brezerk/q4wine/issues/39
+
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index adb8db6..7c0d0d2 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -275,7 +275,7 @@ SET ( Q4WINE_HEADERS_DIR
+
+ IF (${WITH_SYSTEM_SINGLEAPP} MATCHES ON )
+ MESSAGE(STATUS "Searching for QtSingleApplication package (WITH_SYSTEM_SINGLEAPP=ON) --\n")
+- find_path(QTSINGLEAPPLIB_INCLUDE_DIR QtSingleApplication PATH_SUFFIXES QtSolutions)
++ find_path(QTSINGLEAPPLIB_INCLUDE_DIR QtSingleApplication PATH_SUFFIXES QtSolutions PATHS /usr/include/qt4)
+ find_library(QTSINGLEAPPLIB QtSolutions_SingleApplication-2.6)
+
+ IF (QTSINGLEAPPLIB_INCLUDE_DIR AND QTSINGLEAPPLIB )
diff --git a/app-emulation/q4wine/q4wine-1.0_p3-r1.ebuild b/app-emulation/q4wine/q4wine-1.0_p3-r1.ebuild
new file mode 100644
index 000000000000..953e0fd83a3b
--- /dev/null
+++ b/app-emulation/q4wine/q4wine-1.0_p3-r1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/q4wine/q4wine-1.0_p3-r1.ebuild,v 1.1 2013/10/14 18:57:04 hwoarang Exp $
+
+EAPI="4"
+LANGS="cs de en es fa he it ru uk pl pt af"
+
+inherit cmake-utils
+
+# Upstream names the package PV-rX. We need to fix that to
+# PV_pX so we can use portage revisions.
+MY_PV="${PV/_p/-r}"
+MY_P="${PN}-${MY_PV}"
+DESCRIPTION="Qt4 GUI configuration tool for Wine"
+HOMEPAGE="http://q4wine.brezblock.org.ua/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/${PN}%20${PV}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +icoutils +wineappdb -dbus gnome kde"
+
+for x in ${LANGS}; do
+ IUSE+=" linguas_${x}"
+done
+
+CDEPEND="dev-qt/qtgui:4
+ dev-qt/qtsingleapplication
+ dev-qt/qtsql:4[sqlite]"
+
+DEPEND="${CDEPEND}
+ dev-util/cmake"
+
+RDEPEND="${CDEPEND}
+ app-admin/sudo
+ app-emulation/wine
+ >=sys-apps/which-2.19
+ icoutils? ( >=media-gfx/icoutils-0.26.0 )
+ sys-fs/fuseiso
+ kde? ( kde-base/kdesu )
+ gnome? ( x11-libs/gksu )
+ dbus? ( dev-qt/qtdbus:4 )"
+
+DOCS="README AUTHORS ChangeLog"
+
+PATCHES=( ${FILESDIR}/${PN}-qtsingleapp.patch )
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs} \
+ -DWITH_SYSTEM_SINGLEAPP=ON \
+ $(cmake-utils_use debug DEBUG) \
+ $(cmake-utils_use_with icoutils ICOUTILS) \
+ $(cmake-utils_use_with wineappdb WINEAPPDB) \
+ $(cmake-utils_use_with dbus DBUS)"
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ for x in ${LANGS}; do
+ if ! has ${x} ${LINGUAS}; then
+ find "${D}" -name "${PN}_${x}*.qm" -exec rm {} \;
+ fi
+ done
+}