summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2006-05-06 10:16:33 +0000
committerLuca Barbato <lu_zero@gentoo.org>2006-05-06 10:16:33 +0000
commitaa0a0ca845cdf9875d0f65f31f5c9430d5cf7c06 (patch)
treefeb1489bbc31ec72900fc629023861c3e7b447ea /app-emulation/qemu-softmmu
parentFix build with gcc-4.1 and xatrix, bug #118299 (diff)
downloadgentoo-2-aa0a0ca845cdf9875d0f65f31f5c9430d5cf7c06.tar.gz
gentoo-2-aa0a0ca845cdf9875d0f65f31f5c9430d5cf7c06.tar.bz2
gentoo-2-aa0a0ca845cdf9875d0f65f31f5c9430d5cf7c06.zip
New version
(Portage version: 2.1_pre10-r2)
Diffstat (limited to 'app-emulation/qemu-softmmu')
-rw-r--r--app-emulation/qemu-softmmu/ChangeLog7
-rw-r--r--app-emulation/qemu-softmmu/files/digest-qemu-softmmu-0.8.16
-rw-r--r--app-emulation/qemu-softmmu/qemu-softmmu-0.8.1.ebuild101
3 files changed, 113 insertions, 1 deletions
diff --git a/app-emulation/qemu-softmmu/ChangeLog b/app-emulation/qemu-softmmu/ChangeLog
index 14f61321b1b8..023f835c7920 100644
--- a/app-emulation/qemu-softmmu/ChangeLog
+++ b/app-emulation/qemu-softmmu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/qemu-softmmu
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-softmmu/ChangeLog,v 1.18 2006/04/28 15:21:30 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-softmmu/ChangeLog,v 1.19 2006/05/06 10:16:33 lu_zero Exp $
+
+*qemu-softmmu-0.8.1 (06 May 2006)
+
+ 06 May 2006; Luca Barbato <lu_zero@gentoo.org> +qemu-softmmu-0.8.1.ebuild:
+ New version
28 Apr 2006; Luca Barbato <lu_zero@gentoo.org>
qemu-softmmu-0.8.0.20060329.ebuild:
diff --git a/app-emulation/qemu-softmmu/files/digest-qemu-softmmu-0.8.1 b/app-emulation/qemu-softmmu/files/digest-qemu-softmmu-0.8.1
new file mode 100644
index 000000000000..ecd18146290f
--- /dev/null
+++ b/app-emulation/qemu-softmmu/files/digest-qemu-softmmu-0.8.1
@@ -0,0 +1,6 @@
+MD5 02cfdecda90458d6393781496ec6b48b kqemu-0.7.2.tar.gz 79314
+RMD160 cdb154d51eb616d6ad9924da0175276a655edba7 kqemu-0.7.2.tar.gz 79314
+SHA256 4158b2c67603f5256a78d0065d715bde068a457aa58bbfef12dda20fe7f7ad8b kqemu-0.7.2.tar.gz 79314
+MD5 67d924324a5ab79d017bd97a1e767285 qemu-0.8.1.tar.gz 1623264
+RMD160 04d163d4792bbea39fc0b1e52af124cdb7e907dc qemu-0.8.1.tar.gz 1623264
+SHA256 a1f83666f5c05eaee9bfc608a3a5034ad95d0fd3c99937bb399bf9235a6aa0c9 qemu-0.8.1.tar.gz 1623264
diff --git a/app-emulation/qemu-softmmu/qemu-softmmu-0.8.1.ebuild b/app-emulation/qemu-softmmu/qemu-softmmu-0.8.1.ebuild
new file mode 100644
index 000000000000..eba50031d79b
--- /dev/null
+++ b/app-emulation/qemu-softmmu/qemu-softmmu-0.8.1.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-softmmu/qemu-softmmu-0.8.1.ebuild,v 1.1 2006/05/06 10:16:33 lu_zero Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Multi-platform & multi-targets cpu emulator and dynamic translator"
+HOMEPAGE="http://fabrice.bellard.free.fr/qemu/"
+SRC_URI="${HOMEPAGE}${P/-softmmu/}.tar.gz
+ kqemu? ( ${HOMEPAGE}kqemu-0.7.2.tar.gz )"
+
+LICENSE="GPL-2 LGPL-2.1 KQEMU"
+SLOT="0"
+KEYWORDS="-alpha ~amd64 ~ppc -sparc ~x86"
+IUSE="sdl kqemu" #qvm86 debug nptl qemu-fast nptlonly"
+RESTRICT="nostrip test"
+
+DEPEND="virtual/libc
+ sdl? ( media-libs/libsdl )
+ !<=app-emulation/qemu-0.7.0
+ kqemu? ( app-emulation/kqemu )
+ app-text/texi2html"
+RDEPEND="sdl? ( media-libs/libsdl )"
+
+S="${WORKDIR}/${P/-softmmu/}"
+
+set_target_list() {
+ TARGET_LIST="i386-softmmu ppc-softmmu sparc-softmmu x86_64-softmmu arm-softmmu mips-softmmu"
+ export TARGET_LIST
+}
+
+pkg_setup() {
+ if [ "$(gcc-major-version)" == "4" ]; then
+ ewarn "Qemu could not build with GCC 4"
+ fi
+}
+
+#RUNTIME_PATH="/emul/gnemul/"
+src_unpack() {
+ unpack ${A}
+ if use kqemu; then
+ mv ${WORKDIR}/kqemu ${S}
+ cd ${S}/kqemu
+ #Let the configure find kqemu but NOT build it
+ sed -i -e 's:$(MAKE) -C kqemu*::' ${S}/Makefile
+ fi
+
+ cd ${S}
+
+ # Alter target makefiles to accept CFLAGS set via flag-o.
+ sed -i 's/^\(C\|OP_C\|HELPER_C\)FLAGS=/\1FLAGS+=/' \
+ Makefile Makefile.target tests/Makefile
+ # Ensure mprotect restrictions are relaxed for emulator binaries
+ [[ -x /sbin/paxctl ]] && \
+ sed -i 's/^VL_LDFLAGS=$/VL_LDFLAGS=-Wl,-z,execheap/' \
+ Makefile.target
+ # Prevent install of kernel module by qemu's makefile
+ sed -i 's/\(.\/install.sh\)/#\1/' Makefile
+}
+
+src_compile() {
+ #Let the application set its cflags
+ unset CFLAGS
+
+ # Switch off hardened tech
+ filter-flags -fpie -fstack-protector
+
+ myconf="--disable-gcc-check"
+ if ! use sdl ; then
+ myconf="$myconf --disable-gfx-check"
+ fi
+ set_target_list
+# --interp-prefix=${RUNTIME_PATH}/qemu-%M
+ ./configure \
+ --prefix=/usr \
+ --target-list="${TARGET_LIST}" \
+ --enable-slirp \
+ --kernel-path=${KV_DIR} \
+ $(use_enable kqemu) \
+ ${myconf} \
+ $(use_enable sdl)\
+ || die "could not configure"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make install \
+ prefix=${D}/usr \
+ bindir=${D}/usr/bin \
+ datadir=${D}/usr/share/qemu \
+ docdir=${D}/usr/share/doc/${P} \
+ mandir=${D}/usr/share/man || die
+
+ chmod -x ${D}/usr/share/man/*/*
+}
+
+pkg_postinst() {
+ einfo "You will need the Universal TUN/TAP driver compiled into"
+ einfo "kernel or as a module to use the virtual network device."
+}