summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2010-10-21 09:26:10 +0000
committerTiziano Müller <dev-zero@gentoo.org>2010-10-21 09:26:10 +0000
commit15701430ba8c3f35a5babf105a9081b4b037a21e (patch)
treec3ea530bb2335b0165ebb740b803bba628b0c4ff /app-emulation/spice
parentVersion bump (bug #335937). (diff)
downloadgentoo-2-15701430ba8c3f35a5babf105a9081b4b037a21e.tar.gz
gentoo-2-15701430ba8c3f35a5babf105a9081b4b037a21e.tar.bz2
gentoo-2-15701430ba8c3f35a5babf105a9081b4b037a21e.zip
Version bump (bug #335936), dropped opengl USE flag since OpenGL-support is currently broken.
(Portage version: 2.2_rc98/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/spice')
-rw-r--r--app-emulation/spice/ChangeLog8
-rw-r--r--app-emulation/spice/spice-0.6.3.ebuild45
2 files changed, 52 insertions, 1 deletions
diff --git a/app-emulation/spice/ChangeLog b/app-emulation/spice/ChangeLog
index 06f3d4cc7562..0d47f895fc43 100644
--- a/app-emulation/spice/ChangeLog
+++ b/app-emulation/spice/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/spice
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice/ChangeLog,v 1.1 2010/08/11 16:22:04 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice/ChangeLog,v 1.2 2010/10/21 09:26:10 dev-zero Exp $
+
+*spice-0.6.3 (21 Oct 2010)
+
+ 21 Oct 2010; Tiziano Müller <dev-zero@gentoo.org> +spice-0.6.3.ebuild:
+ Version bump (bug #335936), dropped opengl USE flag since OpenGL-support
+ is currently broken.
*spice-0.5.3 (11 Aug 2010)
diff --git a/app-emulation/spice/spice-0.6.3.ebuild b/app-emulation/spice/spice-0.6.3.ebuild
new file mode 100644
index 000000000000..a8a5a40a3ce3
--- /dev/null
+++ b/app-emulation/spice/spice-0.6.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice/spice-0.6.3.ebuild,v 1.1 2010/10/21 09:26:10 dev-zero Exp $
+
+EAPI=3
+
+DESCRIPTION="SPICE server and client."
+HOMEPAGE="http://spice-space.org/"
+SRC_URI="http://spice-space.org/download/releases/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+gui static-libs"
+
+RDEPEND="~app-emulation/spice-protocol-${PV}
+ >=x11-libs/pixman-0.17.7
+ media-libs/alsa-lib
+ media-libs/celt:0.5.1
+ dev-libs/openssl
+ >=x11-libs/libXrandr-1.2
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrender
+ media-libs/jpeg
+ sys-libs/zlib
+ gui? ( dev-games/cegui )"
+DEPEND="dev-util/pkgconfig
+ ${RDEPEND}"
+
+# maintainer notes:
+# * opengl support is currently broken
+
+src_configure() {
+ local myconf=""
+ use gui && myconf+="--enable-gui "
+ econf ${myconf} \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc NEWS TODO
+ use static-libs || rm "${D}"/usr/lib*/*.la
+}