summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-03-27 06:22:07 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-03-27 06:22:07 +0000
commit431c75872263c1b5ba3195600b85bf342246f9e2 (patch)
tree69e151898165273ed3f8486e0ef0ae63518ec810 /app-emulation/spice
parentFix dev-lang/lua SLOT dependency. (diff)
downloadgentoo-2-431c75872263c1b5ba3195600b85bf342246f9e2.tar.gz
gentoo-2-431c75872263c1b5ba3195600b85bf342246f9e2.tar.bz2
gentoo-2-431c75872263c1b5ba3195600b85bf342246f9e2.zip
old; per dev-zero
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-emulation/spice')
-rw-r--r--app-emulation/spice/ChangeLog8
-rw-r--r--app-emulation/spice/files/spice-0.12.3-CVE-2013-4130.patch70
-rw-r--r--app-emulation/spice/files/spice-0.12.4-alsa-conditional.patch51
-rw-r--r--app-emulation/spice/spice-0.12.2.ebuild88
-rw-r--r--app-emulation/spice/spice-0.12.3-r1.ebuild103
-rw-r--r--app-emulation/spice/spice-0.12.4-r1.ebuild94
6 files changed, 7 insertions, 407 deletions
diff --git a/app-emulation/spice/ChangeLog b/app-emulation/spice/ChangeLog
index 580cc9219def..07376d0d5ee2 100644
--- a/app-emulation/spice/ChangeLog
+++ b/app-emulation/spice/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/spice
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice/ChangeLog,v 1.65 2015/03/25 13:43:05 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice/ChangeLog,v 1.66 2015/03/27 06:22:07 mr_bones_ Exp $
+
+ 27 Mar 2015; Michael Sterrett <mr_bones_@gentoo.org>
+ -files/spice-0.12.3-CVE-2013-4130.patch,
+ -files/spice-0.12.4-alsa-conditional.patch, -spice-0.12.2.ebuild,
+ -spice-0.12.3-r1.ebuild, -spice-0.12.4-r1.ebuild:
+ old; per dev-zero
25 Mar 2015; Agostino Sarubbo <ago@gentoo.org> spice-0.12.5-r1.ebuild:
Stable for x86, wrt bug #542722
diff --git a/app-emulation/spice/files/spice-0.12.3-CVE-2013-4130.patch b/app-emulation/spice/files/spice-0.12.3-CVE-2013-4130.patch
deleted file mode 100644
index f18b40fe7707..000000000000
--- a/app-emulation/spice/files/spice-0.12.3-CVE-2013-4130.patch
+++ /dev/null
@@ -1,70 +0,0 @@
-From 53488f0275d6c8a121af49f7ac817d09ce68090d Mon Sep 17 00:00:00 2001
-From: David Gibson <david@gibson.dropbear.id.au>
-Date: Fri, 05 Jul 2013 07:11:46 +0000
-Subject: Use RING_FOREACH_SAFE in red_channel.c functions which are missing it
-
-Currently, both red_channel_pipes_add_type() and
-red_channel_pipes_add_empty_msg() use plaing RING_FOREACH() which is not
-safe versus removals from the ring within the loop body.
-
-Although it's rare, such a removal can occur in both cases. In the case
-of red_channel_pipes_add_type() we have:
- red_channel_pipes_add_type()
- -> red_channel_client_pipe_add_type()
- -> red_channel_client_push()
-
-And in the case of red_channel_client_pipes_add_empty_msg() we have:
- red_channel_client_pipes_add_empty_msg()
- -> red_channel_client_pipe_add_empty_msg()
- -> red_channel_client_push()
-
-But red_channel_client_push() can cause a removal from the clients ring if
-a network error occurs:
- red_channel_client_push()
- -> red_channel_client_send()
- -> red_peer_handle_outgoing()
- -> handler->cb->on_error callback
- = red_channel_client_default_peer_on_error()
- -> red_channel_client_disconnect()
- -> red_channel_remove_client()
- -> ring_remove()
-
-When this error path does occur, the assertion in RING_FOREACH()'s
-ring_next() trips, and the process containing the spice server is aborted.
-i.e. your whole VM dies, as a result of an unfortunately timed network
-error on the spice channel.
-
-Please apply.
-
-Signed-off-by: David Gibson <dgibson@redhat.com>
----
-diff --git a/server/red_channel.c b/server/red_channel.c
-index c0b1781..8742008 100644
---- a/server/red_channel.c
-+++ b/server/red_channel.c
-@@ -1572,9 +1572,9 @@ void red_channel_client_pipe_add_type(RedChannelClient *rcc, int pipe_item_type)
-
- void red_channel_pipes_add_type(RedChannel *channel, int pipe_item_type)
- {
-- RingItem *link;
-+ RingItem *link, *next;
-
-- RING_FOREACH(link, &channel->clients) {
-+ RING_FOREACH_SAFE(link, next, &channel->clients) {
- red_channel_client_pipe_add_type(
- SPICE_CONTAINEROF(link, RedChannelClient, channel_link),
- pipe_item_type);
-@@ -1593,9 +1593,9 @@ void red_channel_client_pipe_add_empty_msg(RedChannelClient *rcc, int msg_type)
-
- void red_channel_pipes_add_empty_msg(RedChannel *channel, int msg_type)
- {
-- RingItem *link;
-+ RingItem *link, *next;
-
-- RING_FOREACH(link, &channel->clients) {
-+ RING_FOREACH_SAFE(link, next, &channel->clients) {
- red_channel_client_pipe_add_empty_msg(
- SPICE_CONTAINEROF(link, RedChannelClient, channel_link),
- msg_type);
---
-cgit v0.9.0.2-2-gbebe
diff --git a/app-emulation/spice/files/spice-0.12.4-alsa-conditional.patch b/app-emulation/spice/files/spice-0.12.4-alsa-conditional.patch
deleted file mode 100644
index 82abb37c61d1..000000000000
--- a/app-emulation/spice/files/spice-0.12.4-alsa-conditional.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-From 58195c195110f0dbb24d831b5eefb2f094848b26 Mon Sep 17 00:00:00 2001
-From: Christian Ruppert <idl0r@qasl.de>
-Date: Sun, 03 Nov 2013 17:38:55 +0000
-Subject: Require alsa only with --enable-client
-
-Hey guys,
-
-the alsa libraries/header seem to be required only when configured with
---enable-client so I wrote a patch to make configure respect it.
-
---
-Regards,
-Christian Ruppert
-
-From 53683cc75ba092799f856f710cb45b2aacfb6123 Mon Sep 17 00:00:00 2001
-From: Christian Ruppert <idl0r@gentoo.org>
-Date: Sun, 3 Nov 2013 18:36:26 +0100
-Subject: [PATCH] Require alsa only with --enable-client
----
-diff --git a/configure.ac b/configure.ac
-index 7e81329..882bf1b 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -246,12 +246,6 @@ fi
- AC_MSG_RESULT([found])
- fi
-
--if test "$os_linux" = yes; then
-- PKG_CHECK_MODULES(ALSA, alsa)
-- AC_SUBST(ALSA_CFLAGS)
-- AC_SUBST(ALSA_LIBS)
--fi
--
- PKG_CHECK_MODULES(SSL, openssl)
- AC_SUBST(SSL_CFLAGS)
- AC_SUBST(SSL_LIBS)
-@@ -280,6 +274,12 @@ AC_SUBST(GL_LIBS)
- SPICE_NONPKGCONFIG_LIBS+=" $GL_LIBS"
-
- if test "x$red_target" = "xx11" && test "x$enable_client" = "xyes" ; then
-+ if test "$os_linux" = yes; then
-+ PKG_CHECK_MODULES(ALSA, alsa)
-+ AC_SUBST(ALSA_CFLAGS)
-+ AC_SUBST(ALSA_LIBS)
-+ fi
-+
- PKG_CHECK_MODULES(XRANDR, xrandr)
- PKG_CHECK_MODULES(XFIXES, xfixes)
- PKG_CHECK_MODULES(MISC_X, x11 xext xrender)
---
-cgit v0.9.0.2-2-gbebe
diff --git a/app-emulation/spice/spice-0.12.2.ebuild b/app-emulation/spice/spice-0.12.2.ebuild
deleted file mode 100644
index aef1395123aa..000000000000
--- a/app-emulation/spice/spice-0.12.2.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice/spice-0.12.2.ebuild,v 1.6 2014/08/06 06:44:37 patrick Exp $
-
-EAPI=5
-
-PYTHON_DEPEND="2"
-
-inherit eutils python
-
-DESCRIPTION="SPICE server and client"
-HOMEPAGE="http://spice-space.org/"
-SRC_URI="http://spice-space.org/download/releases/${P}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="+client +gui sasl smartcard static-libs" # static
-
-RDEPEND=">=x11-libs/pixman-0.17.7
- media-libs/alsa-lib
- media-libs/celt:0.5.1
- dev-libs/openssl
- virtual/jpeg
- sys-libs/zlib
- sasl? ( dev-libs/cyrus-sasl )
- smartcard? ( >=app-emulation/libcacard-0.1.2 )
- client? (
- gui? ( =dev-games/cegui-0.6*[opengl] )
- >=x11-libs/libXrandr-1.2
- x11-libs/libX11
- x11-libs/libXext
- x11-libs/libXinerama
- x11-libs/libXfixes
- x11-libs/libXrender
- )"
-
-# broken as we don't have static alsa-lib and building that one static requires more work
-# static? (
-# >=x11-libs/pixman-0.17.7[static-libs(+)]
-# media-libs/celt:0.5.1[static-libs(+)]
-# virtual/jpeg[static-libs(+)]
-# sys-libs/zlib[static-libs(+)]
-# media-libs/alsa-lib[static-libs(-)]
-# >=x11-libs/libXrandr-1.2[static-libs(+)]
-# x11-libs/libX11[static-libs(+)]
-# x11-libs/libXext[static-libs(+)]
-# x11-libs/libXinerama[static-libs(+)]
-# x11-libs/libXfixes[static-libs(+)]
-# x11-libs/libXrender[static-libs(+)]
-# )
-# )"
-DEPEND="virtual/pkgconfig
- dev-python/pyparsing
- ${RDEPEND}"
-
-pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
-}
-
-# maintainer notes:
-# * opengl support is currently broken
-# * TODO: add slirp for tunnel-support
-
-src_prepare() {
- epatch \
- "${FILESDIR}/0.11.0-gold.patch"
-}
-
-src_configure() {
- python_convert_shebangs 2 spice-common/spice_codegen.py
-
- econf \
- $(use_enable static-libs static) \
- --disable-tunnel \
- $(use_enable client) \
- $(use_enable gui) \
- $(use_with sasl) \
- $(use_enable smartcard) \
- --disable-static-linkage
-# $(use_enable static static-linkage) \
-}
-
-src_install() {
- default
- use static-libs || rm "${D}"/usr/lib*/*.la
-}
diff --git a/app-emulation/spice/spice-0.12.3-r1.ebuild b/app-emulation/spice/spice-0.12.3-r1.ebuild
deleted file mode 100644
index e8ead8f8ec8d..000000000000
--- a/app-emulation/spice/spice-0.12.3-r1.ebuild
+++ /dev/null
@@ -1,103 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice/spice-0.12.3-r1.ebuild,v 1.9 2014/08/06 06:44:37 patrick Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7} pypy pypy2_0 )
-
-inherit eutils python-any-r1
-
-DESCRIPTION="SPICE server and client"
-HOMEPAGE="http://spice-space.org/"
-SRC_URI="http://spice-space.org/download/releases/${P}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="client gui sasl smartcard static-libs" # static
-
-RDEPEND=">=x11-libs/pixman-0.17.7
- >=dev-libs/glib-2.22:2
- media-libs/alsa-lib
- >=media-libs/celt-0.5.1.1:0.5.1
- dev-libs/openssl
- virtual/jpeg
- sys-libs/zlib
- sasl? ( dev-libs/cyrus-sasl )
- smartcard? ( >=app-emulation/libcacard-0.1.2 )
- client? (
- gui? ( =dev-games/cegui-0.6*[opengl] )
- >=x11-libs/libXrandr-1.2
- x11-libs/libX11
- x11-libs/libXext
- >=x11-libs/libXinerama-1.0
- x11-libs/libXfixes
- x11-libs/libXrender
- )"
-
-# broken as we don't have static alsa-lib and building that one static requires more work
-# static? (
-# >=x11-libs/pixman-0.17.7[static-libs(+)]
-# media-libs/celt:0.5.1[static-libs(+)]
-# virtual/jpeg[static-libs(+)]
-# sys-libs/zlib[static-libs(+)]
-# media-libs/alsa-lib[static-libs(-)]
-# >=x11-libs/libXrandr-1.2[static-libs(+)]
-# x11-libs/libX11[static-libs(+)]
-# x11-libs/libXext[static-libs(+)]
-# x11-libs/libXinerama[static-libs(+)]
-# x11-libs/libXfixes[static-libs(+)]
-# x11-libs/libXrender[static-libs(+)]
-# )
-# )"
-DEPEND="virtual/pkgconfig
- $(python_gen_any_dep \
- '>=dev-python/pyparsing-1.5.6-r2[${PYTHON_USEDEP}]')
- ${RDEPEND}"
-
-python_check_deps() {
- has_version ">=dev-python/pyparsing-1.5.6-r2[${PYTHON_USEDEP}]"
-}
-
-pkg_setup() {
- [[ ${MERGE_TYPE} != binary ]] && python-any-r1_pkg_setup
-}
-
-# maintainer notes:
-# * opengl support is currently broken
-# * TODO: add slirp for tunnel-support
-
-src_prepare() {
- epatch \
- "${FILESDIR}/0.11.0-gold.patch"
-
- epatch "${FILESDIR}/${P}-CVE-2013-4130.patch"
-
- epatch_user
-}
-
-src_configure() {
- econf \
- $(use_enable static-libs static) \
- --disable-tunnel \
- $(use_enable client) \
- $(use_enable gui) \
- $(use_with sasl) \
- $(use_enable smartcard) \
- --disable-static-linkage
-# $(use_enable static static-linkage) \
-}
-
-src_install() {
- default
- use static-libs || prune_libtool_files
-}
-
-pkg_postinst() {
- if use gui; then
- ewarn "USE=gui will be removed in the next version."
- ewarn "Upstream has stated that 'spicy' is deprecated and that you"
- ewarn "should use 'remote-viewer' from app-emulation/virt-viewer."
- fi
-}
diff --git a/app-emulation/spice/spice-0.12.4-r1.ebuild b/app-emulation/spice/spice-0.12.4-r1.ebuild
deleted file mode 100644
index 14a34acb4bfa..000000000000
--- a/app-emulation/spice/spice-0.12.4-r1.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice/spice-0.12.4-r1.ebuild,v 1.3 2014/08/06 06:44:37 patrick Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7} pypy pypy2_0 )
-
-inherit autotools eutils python-any-r1
-
-DESCRIPTION="SPICE server and client"
-HOMEPAGE="http://spice-space.org/"
-SRC_URI="http://spice-space.org/download/releases/${P}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="client sasl smartcard static-libs" # static
-
-RDEPEND=">=x11-libs/pixman-0.17.7
- >=dev-libs/glib-2.22:2
- >=media-libs/celt-0.5.1.1:0.5.1
- dev-libs/openssl
- virtual/jpeg
- sys-libs/zlib
- sasl? ( dev-libs/cyrus-sasl )
- smartcard? ( >=app-emulation/libcacard-0.1.2 )
- client? (
- media-libs/alsa-lib
- >=x11-libs/libXrandr-1.2
- x11-libs/libX11
- x11-libs/libXext
- >=x11-libs/libXinerama-1.0
- x11-libs/libXfixes
- x11-libs/libXrender
- )"
-
-# broken as we don't have static alsa-lib and building that one static requires more work
-# static? (
-# >=x11-libs/pixman-0.17.7[static-libs(+)]
-# media-libs/celt:0.5.1[static-libs(+)]
-# virtual/jpeg[static-libs(+)]
-# sys-libs/zlib[static-libs(+)]
-# media-libs/alsa-lib[static-libs(-)]
-# >=x11-libs/libXrandr-1.2[static-libs(+)]
-# x11-libs/libX11[static-libs(+)]
-# x11-libs/libXext[static-libs(+)]
-# x11-libs/libXinerama[static-libs(+)]
-# x11-libs/libXfixes[static-libs(+)]
-# x11-libs/libXrender[static-libs(+)]
-# )
-# )"
-DEPEND="virtual/pkgconfig
- $(python_gen_any_dep \
- '>=dev-python/pyparsing-1.5.6-r2[${PYTHON_USEDEP}]')
- ${RDEPEND}"
-
-python_check_deps() {
- has_version ">=dev-python/pyparsing-1.5.6-r2[${PYTHON_USEDEP}]"
-}
-
-pkg_setup() {
- [[ ${MERGE_TYPE} != binary ]] && python-any-r1_pkg_setup
-}
-
-# maintainer notes:
-# * opengl support is currently broken
-# * TODO: add slirp for tunnel-support
-
-src_prepare() {
- epatch \
- "${FILESDIR}/0.11.0-gold.patch" \
- "${FILESDIR}/${P}-alsa-conditional.patch"
-
- epatch_user
- eautoreconf
-}
-
-src_configure() {
- econf \
- $(use_enable static-libs static) \
- --disable-tunnel \
- $(use_enable client) \
- $(use_with sasl) \
- $(use_enable smartcard) \
- --disable-gui \
- --disable-static-linkage
-# $(use_enable static static-linkage) \
-}
-
-src_install() {
- default
- use static-libs || prune_libtool_files
-}