summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-06-07 15:36:01 +0000
committerJustin Lecher <jlec@gentoo.org>2012-06-07 15:36:01 +0000
commite30880fd785aa571c7ba062512e1f009f36b3d3a (patch)
treeba550b0a7178ad658568687a3cfd54dbf8284390 /app-emulation/spice
parentppc stable (bug 410601) (diff)
downloadgentoo-2-e30880fd785aa571c7ba062512e1f009f36b3d3a.tar.gz
gentoo-2-e30880fd785aa571c7ba062512e1f009f36b3d3a.tar.bz2
gentoo-2-e30880fd785aa571c7ba062512e1f009f36b3d3a.zip
Add fix for underlinking detected by gold
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/spice')
-rw-r--r--app-emulation/spice/ChangeLog6
-rw-r--r--app-emulation/spice/files/0.10.1-gold.patch16
-rw-r--r--app-emulation/spice/spice-0.10.1.ebuild6
3 files changed, 25 insertions, 3 deletions
diff --git a/app-emulation/spice/ChangeLog b/app-emulation/spice/ChangeLog
index 07169ce5a208..b4279a397ef2 100644
--- a/app-emulation/spice/ChangeLog
+++ b/app-emulation/spice/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/spice
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice/ChangeLog,v 1.24 2012/05/03 18:49:07 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice/ChangeLog,v 1.25 2012/06/07 15:36:01 jlec Exp $
+
+ 07 Jun 2012; Justin Lecher <jlec@gentoo.org> +files/0.10.1-gold.patch,
+ spice-0.10.1.ebuild:
+ Add fix for underlinking detected by gold
03 May 2012; Jeff Horelick <jdhore@gentoo.org> spice-0.8.1.ebuild,
spice-0.8.2-r1.ebuild, spice-0.10.0.ebuild, spice-0.10.1.ebuild:
diff --git a/app-emulation/spice/files/0.10.1-gold.patch b/app-emulation/spice/files/0.10.1-gold.patch
new file mode 100644
index 000000000000..24add0ee95c6
--- /dev/null
+++ b/app-emulation/spice/files/0.10.1-gold.patch
@@ -0,0 +1,16 @@
+ server/tests/Makefile.am | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/server/tests/Makefile.am b/server/tests/Makefile.am
+index 4513322..265b22b 100644
+--- a/server/tests/Makefile.am
++++ b/server/tests/Makefile.am
+@@ -9,7 +9,7 @@ INCLUDES = \
+ $(SPICE_NONPKGCONFIG_CFLAGS) \
+ $(NULL)
+
+-AM_LDFLAGS = $(top_builddir)/server/libspice-server.la
++AM_LDFLAGS = $(top_builddir)/server/libspice-server.la -pthread
+
+ COMMON_BASE=basic_event_loop.c basic_event_loop.h test_util.h ../../common/backtrace.c
+
diff --git a/app-emulation/spice/spice-0.10.1.ebuild b/app-emulation/spice/spice-0.10.1.ebuild
index 46449d43db18..34251582eda1 100644
--- a/app-emulation/spice/spice-0.10.1.ebuild
+++ b/app-emulation/spice/spice-0.10.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice/spice-0.10.1.ebuild,v 1.4 2012/05/03 18:49:07 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice/spice-0.10.1.ebuild,v 1.5 2012/06/07 15:36:01 jlec Exp $
EAPI=4
@@ -39,7 +39,9 @@ DEPEND="virtual/pkgconfig
# * TODO: add slirp for tunnel-support
src_prepare() {
- epatch "${FILESDIR}/0.10.1-disable-werror.patch"
+ epatch \
+ "${FILESDIR}/0.10.1-disable-werror.patch" \
+ "${FILESDIR}/${PV}-gold.patch"
eautoreconf
}