summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2006-10-15 23:23:38 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2006-10-15 23:23:38 +0000
commitd7abe279196ee0f852b088e8dd1128a7ad22a7b5 (patch)
tree94540b8bc74e93770b9dcc85b124b07b8bfedf66 /app-emulation/spim/spim-7.3.ebuild
parentfix #150640 and new version. (diff)
downloadgentoo-2-d7abe279196ee0f852b088e8dd1128a7ad22a7b5.tar.gz
gentoo-2-d7abe279196ee0f852b088e8dd1128a7ad22a7b5.tar.bz2
gentoo-2-d7abe279196ee0f852b088e8dd1128a7ad22a7b5.zip
version bump from usptream
(Portage version: 2.1.2_pre3-r1)
Diffstat (limited to 'app-emulation/spim/spim-7.3.ebuild')
-rw-r--r--app-emulation/spim/spim-7.3.ebuild98
1 files changed, 98 insertions, 0 deletions
diff --git a/app-emulation/spim/spim-7.3.ebuild b/app-emulation/spim/spim-7.3.ebuild
new file mode 100644
index 000000000000..8d7c80c07847
--- /dev/null
+++ b/app-emulation/spim/spim-7.3.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/spim/spim-7.3.ebuild,v 1.1 2006/10/15 23:23:38 compnerd Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="MIPS Simulator"
+HOMEPAGE="http://www.cs.wisc.edu/~larus/spim.html"
+SRC_URI="http://www.cs.wisc.edu/~larus/SPIM/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc-macos ~sparc ~x86"
+IUSE="X"
+
+RDEPEND="X? ( || ( ( x11-libs/libXaw x11-libs/libXp ) virtual/x11 ) )"
+DEPEND="${RDEPEND}
+ X? ( || ( ( x11-misc/imake x11-proto/xproto ) virtual/x11 ) )
+ >=sys-apps/sed-4
+ sys-devel/bison"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Fix documentation files
+ cd ${S}/Documentation
+ mv spim.man spim.1
+ mv xspim.man xspim.1
+}
+
+src_compile() {
+ cd ${S}/spim
+
+ ./Configure || die "Configure Failed!"
+
+ sed -i \
+ -e 's:@make:@$(MAKE):' \
+ -e 's:\(BIN_DIR = \).*$:\1\$(DESTDIR)/usr/bin:' \
+ -e 's:\(MAN_DIR = \).*$:\1\$(DESTDIR)/usr/share/man:' \
+ -e 's:\(EXCEPTION_DIR = \).*$:\1$(DESTDIR)/var/lib/spim:' \
+ -e 's:\(^\W*install.*\) exceptions.s \(.*$\):\1 \$(CPU_DIR)/exceptions.s \2:' \
+ -e "s:^\W*install.* spim.man .*$::" \
+ -e "s:tail -2:tail -n2:" \
+ Makefile
+
+ emake CC="$(tc-getCC)" || die
+
+ if use X ; then
+ cd ${S}/xspim
+
+ ./Configure || die "Configure Failed!"
+
+ xmkmf || die
+
+ sed -i \
+ -e 's:@make:@$(MAKE):' \
+ -e "s:\(BIN_DIR = \).*$:\1/usr/bin:" \
+ -e "s:\(MAN_DIR = \).*$:\1/usr/share/man:" \
+ -e "s:\(EXCEPTION_DIR = \).*$:\1/var/lib/spim/exceptions.s:" \
+ Makefile
+
+ emake CC="$(tc-getCC)" -j1 xspim || die
+ fi
+}
+
+src_test() {
+ cd ${S}/spim
+ make test || die "Failed to pass tests!"
+}
+
+src_install() {
+ dodir /usr/bin
+ dodir /usr/share/man
+ dodir /var/lib/spim
+
+ cd ${S}/spim
+ make install DESTDIR="${D}" || die "Unable to install spim"
+
+ if use X ; then
+ cd ${S}/xspim
+ make DESTDIR="${D}" install || die "Unable to install xspim"
+ fi
+
+ cd ${S}/Documentation
+ doman spim.1
+ use X && doman xspim.1
+
+ dohtml SPIM.html
+ dodoc BLURB
+
+ cd ${S}
+ dodoc README VERSION ChangeLog
+
+ # Set the default spim exception handler
+ insinto /etc/env.d
+ doins ${FILESDIR}/23spim
+}