summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-12-11 23:14:25 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-12-11 23:14:25 +0000
commitdc3a0cd3e98d106e8322b554c7b5086d1fcfb341 (patch)
tree5863cac2fc54df4721ab644855700e4a6e3ebf91 /app-emulation/tuxnes
parentVersion bump + bugfix per Bug#8936 (diff)
downloadgentoo-2-dc3a0cd3e98d106e8322b554c7b5086d1fcfb341.tar.gz
gentoo-2-dc3a0cd3e98d106e8322b554c7b5086d1fcfb341.tar.bz2
gentoo-2-dc3a0cd3e98d106e8322b554c7b5086d1fcfb341.zip
New package. x86 mask
Diffstat (limited to 'app-emulation/tuxnes')
-rw-r--r--app-emulation/tuxnes/ChangeLog9
-rw-r--r--app-emulation/tuxnes/files/configure.in-tuxnes-0.75-gentoo.diff46
-rw-r--r--app-emulation/tuxnes/files/digest-tuxnes-0.751
-rw-r--r--app-emulation/tuxnes/tuxnes-0.75.ebuild67
4 files changed, 123 insertions, 0 deletions
diff --git a/app-emulation/tuxnes/ChangeLog b/app-emulation/tuxnes/ChangeLog
new file mode 100644
index 000000000000..087ab3520ade
--- /dev/null
+++ b/app-emulation/tuxnes/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for app-emulation/mol
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/tuxnes/ChangeLog,v 1.1 2002/12/11 23:14:25 rphillips Exp $
+
+*tuxnes-0.75 (11 Dec 2002)
+
+ 11 Dec 2002; Ryan Phillips <rphillips@gentoo.org> ChangeLog :
+ New package
+
diff --git a/app-emulation/tuxnes/files/configure.in-tuxnes-0.75-gentoo.diff b/app-emulation/tuxnes/files/configure.in-tuxnes-0.75-gentoo.diff
new file mode 100644
index 000000000000..73204ae0e3da
--- /dev/null
+++ b/app-emulation/tuxnes/files/configure.in-tuxnes-0.75-gentoo.diff
@@ -0,0 +1,46 @@
+--- tuxnes-0.75/configure.in 2001-04-15 20:08:07.000000000 -0500
++++ tuxnes-0.75-gentoo/configure.in 2002-12-03 00:38:41.000000000 -0500
+@@ -31,7 +31,8 @@
+ dnl Don't assume we want high level optimisations, it is known to
+ dnl produce broken code on certain architectures using certain compilers
+ dnl --------------------------------------------------------------------
+-CFLAGS="-O"
++dnl We'll fix this the Gentoo way
++dnl CFLAGS="-O"
+ AC_SUBST(CFLAGS)
+
+ dnl --------------------------------------------------------------------
+@@ -46,12 +47,12 @@
+ AC_ARG_ENABLE(warnings, [ --enable-warnings enable more compilation warning checks [default=no]], enable_warnings="yes", enable_warnings="no")
+
+ if test "x$enable_warnings" = "xyes"; then
+- CFLAGS="$CFLAGS -pipe -W -Wall -ansi -pedantic -Wbad-function-cast \
++ CFLAGS="$CFLAGS -W -Wall -ansi -pedantic -Wbad-function-cast \
+ -Wcast-align -Wcast-qual -Wchar-subscripts -Wconversion -Winline \
+ -Wmissing-prototypes -Wnested-externs -Wpointer-arith \
+ -Wredundant-decls -Wshadow -Wstrict-prototypes -Wwrite-strings"
+ else
+- CFLAGS="$CFLAGS -pipe -Wall"
++ CFLAGS="$CFLAGS"
+ fi
+ AC_SUBST(CFLAGS)
+
+@@ -144,12 +145,9 @@
+ [ --without-ggi disable check for GGI (General Graphics Interface)])
+
+ if test "x$with_ggi" != "xno"; then
+- OCPPFLAGS="$CPPFLAGS"
+- CPPFLAGS="-I/usr/local/include"
+- AC_CHECK_HEADERS(ggi/gii.h ggi/ggi.h, CFLAGS="$CFLAGS -I/usr/local/include")
++ AC_CHECK_HEADERS(ggi/gii.h ggi/ggi.h)
+ AC_CHECK_LIB(ggi, ggiInit)
+ AC_CHECK_LIB(gii, giiInit)
+- CPPFLAGS="$OCPPFLAGS"
+ fi
+
+ dnl --------------------------------------------------------------------
+@@ -210,3 +208,4 @@
+ AC_CHECK_FUNCS(gettimeofday strtod strtoul)
+
+ AC_OUTPUT(Makefile)
++
diff --git a/app-emulation/tuxnes/files/digest-tuxnes-0.75 b/app-emulation/tuxnes/files/digest-tuxnes-0.75
new file mode 100644
index 000000000000..7bc52404f40d
--- /dev/null
+++ b/app-emulation/tuxnes/files/digest-tuxnes-0.75
@@ -0,0 +1 @@
+MD5 5db0cd42dfdff3e681805e93b4867c43 tuxnes-0.75.tar.gz 198735
diff --git a/app-emulation/tuxnes/tuxnes-0.75.ebuild b/app-emulation/tuxnes/tuxnes-0.75.ebuild
new file mode 100644
index 000000000000..0eda4c612450
--- /dev/null
+++ b/app-emulation/tuxnes/tuxnes-0.75.ebuild
@@ -0,0 +1,67 @@
+# Copyright 2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/tuxnes/tuxnes-0.75.ebuild,v 1.1 2002/12/11 23:14:25 rphillips Exp $
+
+inherit flag-o-matic
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="TuxNES is an emulator for the 8-bit Nintendo Entertainment System"
+SRC_URI="http://unc.dl.sourceforge.net/sourceforge/tuxnes/${P}.tar.gz"
+HOMEPAGE="http://tuxnes.sourceforge.net/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="X ggi"
+DEPEND=">=media-libs/netpbm-9.12
+ X? ( virtual/x11 )
+ ggi? ( >=media-libs/libggi-2.0.1 )"
+
+src_unpack() {
+ unpack ${A}
+
+ echo ">>> Patching configure.in"
+ patch ${S}/configure.in \
+ ${FILESDIR}/configure.in-${P}-gentoo.diff \
+ &>/dev/null
+
+ echo ">>> Running autoreconf"
+ cd "${S}" && \
+ autoreconf &>/dev/null
+}
+
+src_compile() {
+ local config_opts
+
+ # Breaks with higher optimization
+ replace-flags "-O?" "-O"
+
+ # Enable X support?
+ [ "`use X`" ] \
+ && config_opts="--with-x" \
+ || config_opts="--without-x"
+
+ # Enable GGI support?
+ [ "`use ggi`" ] \
+ && config_opts="${config_opts} --with-ggi" \
+ || config_opts="${config_opts} --without-ggi"
+
+ # Don't even bother checking for W windows
+ econf --without-w ${config_opts}
+
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} \
+ install \
+ || die
+
+ # Install pixmaps
+ dodir /usr/share/pixmaps
+ insinto /usr/share/pixmaps
+ doins tuxnes.xpm tuxnes2.xpm
+
+ # Install documentation
+ dodoc AUTHORS BUGS ChangeLog CHANGES \
+ COPYING INSTALL NEWS README THANKS
+}