summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2006-03-06 18:17:14 +0000
committerMichael Januszewski <spock@gentoo.org>2006-03-06 18:17:14 +0000
commit1ea3553af8cd53fd7378eb67da981b0c62aede5a (patch)
treec007c79fff09fe17cf7a029fe7bc9d871d1f281b /app-emulation/uade
parentremove old version; quote strings containing env vars (diff)
downloadgentoo-2-1ea3553af8cd53fd7378eb67da981b0c62aede5a.tar.gz
gentoo-2-1ea3553af8cd53fd7378eb67da981b0c62aede5a.tar.bz2
gentoo-2-1ea3553af8cd53fd7378eb67da981b0c62aede5a.zip
Removed all references to beep-media-player.
(Portage version: 2.1_pre5-r4)
Diffstat (limited to 'app-emulation/uade')
-rw-r--r--app-emulation/uade/ChangeLog8
-rw-r--r--app-emulation/uade/files/uade-0.91-bmp-fix.patch38
-rw-r--r--app-emulation/uade/uade-1.00.ebuild10
-rw-r--r--app-emulation/uade/uade-1.01.ebuild10
-rw-r--r--app-emulation/uade/uade-1.02.ebuild10
-rw-r--r--app-emulation/uade/uade-1.03.ebuild10
-rw-r--r--app-emulation/uade/uade-2.01.ebuild10
7 files changed, 26 insertions, 70 deletions
diff --git a/app-emulation/uade/ChangeLog b/app-emulation/uade/ChangeLog
index 3812759e9e05..db740f07f161 100644
--- a/app-emulation/uade/ChangeLog
+++ b/app-emulation/uade/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/uade
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/uade/ChangeLog,v 1.30 2006/02/06 12:55:48 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/uade/ChangeLog,v 1.31 2006/03/06 18:17:14 spock Exp $
+
+ 06 Mar 2006; Michał Januszewski <spock@gentoo.org>
+ -files/uade-0.91-bmp-fix.patch, uade-1.00.ebuild, uade-1.01.ebuild,
+ uade-1.02.ebuild, uade-1.03.ebuild, uade-2.01.ebuild:
+ Removed all references to beep-media-player, which is no longer available in
+ the Portage tree (bug #125228).
06 Feb 2006; Michał Januszewski <spock@gentoo.org> uade-2.01.ebuild:
Fixed dependencies.
diff --git a/app-emulation/uade/files/uade-0.91-bmp-fix.patch b/app-emulation/uade/files/uade-0.91-bmp-fix.patch
deleted file mode 100644
index 8ead959c7d7a..000000000000
--- a/app-emulation/uade/files/uade-0.91-bmp-fix.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-diff -u -r uade-0.91-org/plugindir/beepmp/uade.c uade-0.91/plugindir/beepmp/uade.c
---- uade-0.91-org/plugindir/beepmp/uade.c 2004-09-10 21:36:16.569584744 +0300
-+++ uade-0.91/plugindir/beepmp/uade.c 2004-09-10 21:36:33.496011536 +0300
-@@ -305,9 +305,12 @@
- /* xmms calls this function to check song */
- static int is_our_file(char *filename) {
- int ours;
-+ const char *prefix = "file://";
- if(!uade_is_operational) {
- return FALSE;
- }
-+ if (strncasecmp(filename, prefix, strlen(prefix)) == 0)
-+ filename += strlen(prefix);
- ours = check_my_file(filename, 0, 0);
- if (ours) {
- FILE *f = fopen(filename, "rb");
-@@ -648,6 +651,10 @@
- int *songdata;
- char *tempname;
- int have_name_hash;
-+ const char *prefix = "file://";
-+
-+ if (strncasecmp(filename, prefix, strlen(prefix)) == 0)
-+ filename += strlen(prefix);
-
- if (playingbit) {
- fprintf(stderr, "uade: A serious bug has been detected:\n");
-@@ -1059,6 +1066,10 @@
- static void get_song_info(char *filename, char **title, int *length) {
- char *temp;
- char md5namehash[33];
-+ const char *prefix = "file://";
-+
-+ if (strncasecmp(filename, prefix, strlen(prefix)) == 0)
-+ filename += strlen(prefix);
-
- temp = strrchr(filename, (int) '/');
- if (temp) {
diff --git a/app-emulation/uade/uade-1.00.ebuild b/app-emulation/uade/uade-1.00.ebuild
index bb566628dbd7..166192443a67 100644
--- a/app-emulation/uade/uade-1.00.ebuild
+++ b/app-emulation/uade/uade-1.00.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/uade/uade-1.00.ebuild,v 1.6 2005/04/21 18:57:57 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/uade/uade-1.00.ebuild,v 1.7 2006/03/06 18:17:14 spock Exp $
inherit eutils
@@ -11,14 +11,13 @@ SRC_URI="http://uade.ton.tut.fi/uade/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ~ppc amd64"
-IUSE="xmms sdl alsa oss perl bmp"
+IUSE="xmms sdl alsa oss perl"
RDEPEND="virtual/libc
xmms? ( >=media-sound/xmms-1.2.2
x11-libs/gtk+ )
sdl? ( media-libs/libsdl )
- alsa? ( >=media-libs/alsa-lib-1.0.5 )
- bmp? ( >=media-sound/beep-media-player-0.7_rc1 )"
+ alsa? ( >=media-libs/alsa-lib-1.0.5 )"
DEPEND="${RDEPEND}
xmms? ( sys-devel/libtool )"
@@ -32,7 +31,6 @@ src_compile() {
$(use_with sdl) \
$(use_with alsa) \
$(use_with xmms) \
- $(use_with bmp) \
|| die "configure failed"
emake || die 'emake failed'
}
diff --git a/app-emulation/uade/uade-1.01.ebuild b/app-emulation/uade/uade-1.01.ebuild
index 09025394d4b9..db731868dff0 100644
--- a/app-emulation/uade/uade-1.01.ebuild
+++ b/app-emulation/uade/uade-1.01.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/uade/uade-1.01.ebuild,v 1.3 2005/05/06 22:08:57 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/uade/uade-1.01.ebuild,v 1.4 2006/03/06 18:17:14 spock Exp $
inherit eutils
@@ -11,14 +11,13 @@ SRC_URI="http://uade.ton.tut.fi/uade/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ~ppc ~amd64"
-IUSE="xmms sdl alsa oss perl bmp"
+IUSE="xmms sdl alsa oss perl"
RDEPEND="virtual/libc
xmms? ( >=media-sound/xmms-1.2.2
x11-libs/gtk+ )
sdl? ( media-libs/libsdl )
- alsa? ( >=media-libs/alsa-lib-1.0.5 )
- bmp? ( >=media-sound/beep-media-player-0.7_rc1 )"
+ alsa? ( >=media-libs/alsa-lib-1.0.5 )"
DEPEND="${RDEPEND}
xmms? ( sys-devel/libtool )"
@@ -32,7 +31,6 @@ src_compile() {
$(use_with sdl) \
$(use_with alsa) \
$(use_with xmms) \
- $(use_with bmp) \
|| die "configure failed"
emake || die 'emake failed'
}
diff --git a/app-emulation/uade/uade-1.02.ebuild b/app-emulation/uade/uade-1.02.ebuild
index 623f173b8ce6..6cac4fede77f 100644
--- a/app-emulation/uade/uade-1.02.ebuild
+++ b/app-emulation/uade/uade-1.02.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/uade/uade-1.02.ebuild,v 1.3 2005/07/18 12:37:06 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/uade/uade-1.02.ebuild,v 1.4 2006/03/06 18:17:14 spock Exp $
inherit eutils
@@ -11,14 +11,13 @@ SRC_URI="http://uade.ton.tut.fi/uade/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ~ppc amd64"
-IUSE="xmms sdl alsa oss perl bmp"
+IUSE="xmms sdl alsa oss perl"
RDEPEND="virtual/libc
xmms? ( >=media-sound/xmms-1.2.2
x11-libs/gtk+ )
sdl? ( media-libs/libsdl )
- alsa? ( >=media-libs/alsa-lib-1.0.5 )
- bmp? ( >=media-sound/beep-media-player-0.7_rc1 )"
+ alsa? ( >=media-libs/alsa-lib-1.0.5 )"
DEPEND="${RDEPEND}
xmms? ( sys-devel/libtool )"
@@ -32,7 +31,6 @@ src_compile() {
$(use_with sdl) \
$(use_with alsa) \
$(use_with xmms) \
- $(use_with bmp) \
|| die "configure failed"
emake || die 'emake failed'
}
diff --git a/app-emulation/uade/uade-1.03.ebuild b/app-emulation/uade/uade-1.03.ebuild
index c8fc3b7f6ddb..940f558ab953 100644
--- a/app-emulation/uade/uade-1.03.ebuild
+++ b/app-emulation/uade/uade-1.03.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/uade/uade-1.03.ebuild,v 1.1 2005/08/09 18:28:12 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/uade/uade-1.03.ebuild,v 1.2 2006/03/06 18:17:14 spock Exp $
inherit eutils
@@ -11,14 +11,13 @@ SRC_URI="http://uade.ton.tut.fi/uade/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~ppc ~amd64"
-IUSE="xmms sdl alsa oss perl bmp"
+IUSE="xmms sdl alsa oss perl"
RDEPEND="virtual/libc
xmms? ( >=media-sound/xmms-1.2.2
x11-libs/gtk+ )
sdl? ( media-libs/libsdl )
- alsa? ( >=media-libs/alsa-lib-1.0.5 )
- bmp? ( >=media-sound/beep-media-player-0.7_rc1 )"
+ alsa? ( >=media-libs/alsa-lib-1.0.5 )"
DEPEND="${RDEPEND}
xmms? ( sys-devel/libtool )"
@@ -32,7 +31,6 @@ src_compile() {
$(use_with sdl) \
$(use_with alsa) \
$(use_with xmms) \
- $(use_with bmp) \
|| die "configure failed"
emake || die 'emake failed'
}
diff --git a/app-emulation/uade/uade-2.01.ebuild b/app-emulation/uade/uade-2.01.ebuild
index 9b15236e45ef..bb1e48e47342 100644
--- a/app-emulation/uade/uade-2.01.ebuild
+++ b/app-emulation/uade/uade-2.01.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/uade/uade-2.01.ebuild,v 1.3 2006/02/06 12:55:48 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/uade/uade-2.01.ebuild,v 1.4 2006/03/06 18:17:14 spock Exp $
inherit eutils
@@ -14,8 +14,8 @@ KEYWORDS="~x86 ~ppc ~amd64"
IUSE="xmms"
RDEPEND="virtual/libc
- media-libs/libao
- xmms? ( >=media-sound/xmms-1.2.2 )"
+ media-libs/libao
+ xmms? ( >=media-sound/xmms-1.2.2 )"
DEPEND="${RDEPEND}"
@@ -39,7 +39,3 @@ src_install() {
dodoc AUTHORS ChangeLog doc/BUGS doc/PLANS
doman doc/uade123.1
}
-
-pkg_postinst() {
- einfo "The 2.x series of UADE currently doesn't support Beep Media Player."
-}