summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2002-11-08 15:34:38 +0000
committerHanno Böck <hanno@gentoo.org>2002-11-08 15:34:38 +0000
commit25589fc5c460bcd164e892d62eade71981578d53 (patch)
tree9534d8eb3220f29a5c756470dfc64daa4668f398 /app-emulation/vice
parentTagged as stable for x86 and alpha. (diff)
downloadgentoo-2-25589fc5c460bcd164e892d62eade71981578d53.tar.gz
gentoo-2-25589fc5c460bcd164e892d62eade71981578d53.tar.bz2
gentoo-2-25589fc5c460bcd164e892d62eade71981578d53.zip
vice update
Diffstat (limited to 'app-emulation/vice')
-rw-r--r--app-emulation/vice/ChangeLog8
-rw-r--r--app-emulation/vice/files/digest-vice-1.101
-rw-r--r--app-emulation/vice/vice-1.10.ebuild50
3 files changed, 58 insertions, 1 deletions
diff --git a/app-emulation/vice/ChangeLog b/app-emulation/vice/ChangeLog
index 2de3b69f1893..83e6834e1421 100644
--- a/app-emulation/vice/ChangeLog
+++ b/app-emulation/vice/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/vice
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/ChangeLog,v 1.1 2002/08/03 21:38:49 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/ChangeLog,v 1.2 2002/11/08 15:34:38 hanno Exp $
+
+*vice-1.10 (08 Nov 2002)
+
+ 08 Nov 2002; Hanno Boeck <hanno@gentoo.org> vice-1.10.ebuild :
+ New version.
+ Also fixed dependencies (no need to depend on full gnome).
*vice-1.9 (03 Aug 2002)
diff --git a/app-emulation/vice/files/digest-vice-1.10 b/app-emulation/vice/files/digest-vice-1.10
new file mode 100644
index 000000000000..d1ecbac36840
--- /dev/null
+++ b/app-emulation/vice/files/digest-vice-1.10
@@ -0,0 +1 @@
+MD5 f8389487363ffe8e7708e6491ed20150 vice-1.10.tar.gz 3111990
diff --git a/app-emulation/vice/vice-1.10.ebuild b/app-emulation/vice/vice-1.10.ebuild
new file mode 100644
index 000000000000..94a87ec52685
--- /dev/null
+++ b/app-emulation/vice/vice-1.10.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/vice-1.10.ebuild,v 1.1 2002/11/08 15:34:38 hanno Exp $
+
+IUSE="sdl nls gnome"
+
+DESCRIPTION="The Versatile Commodore 8-bit Emulator"
+HOMEPAGE="http://viceteam.bei.t-online.de/"
+SRC_URI="ftp://ftp.funet.fi/pub/cbm/crossplatform/emulators/VICE/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND=">=x11-base/xfree-4.0
+ sdl? ( media-libs/libsdl )
+ gnome? ( gnome-base/libgnomeui )"
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+ local myconf="--enable-fullscreen"
+ use sdl && myconf="${myconf} --with-sdl"
+ use gnome && myconf="${myconf} --enable-gnomeui"
+ use nls || myconf="${myconf} --disable-nls"
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man ${myconf} || die "./configure failed"
+ emake || die
+}
+
+src_install () {
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ dohtml ${D}/usr/lib/vice/doc/*.html
+ dodoc \
+ ${D}/usr/lib/vice/doc/NLS-Howto.txt \
+ ${D}/usr/lib/vice/doc/Readme.beos \
+ ${D}/usr/lib/vice/doc/Readme.dos \
+ ${D}/usr/lib/vice/doc/Win32-Howto.txt \
+ ${D}/usr/lib/vice/doc/mon.txt
+
+ rm ${D}/usr/lib/vice/doc -rf
+}